Bug 712 - tar: Ignoring unknown extended header keyword `SCHILY.fflags'
: tar: Ignoring unknown extended header keyword `SCHILY.fflags'
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 19:33 MSD by Andrey Ponomarenko
Modified: 2012-09-19 12:49 MSD (History)
2 users (show)

See Also:
RPM Package: tar-1.26-5-rosa.lts2012.0.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
sample archive (226.06 KB, application/x-gzip)
2012-08-30 18:01 MSD, Andrey Ponomarenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2012-08-28 19:33:14 MSD
Description of problem:

tar utility reports "tar: Ignoring unknown extended header keyword `SCHILY.fflags'" when extracting the archive created on Ubuntu 12.10 LTS.

How reproducible: always

Steps to Reproduce:

1. Create any archive (say a.tar.gz) on Ubuntu 12.10 LTS:

 $ echo "A" > any_file
 $ tar -cf a.tar any_file
 $ gzip a.tar

2. Go to ROSA Marathon and extract the archive:

 $ tar -xzf a.tar.gz
Comment 1 Denis Silakov 2012-08-30 17:31:12 MSD
Could you please attach a problematic tar archive? I don't have Ubuntu near me to create one:)
Comment 2 Andrey Ponomarenko 2012-08-30 18:01:55 MSD
Created attachment 521 [details]
sample archive
Comment 3 Dmitry Mikhirev 2012-09-05 12:27:18 MSD
vim-minimal does not support multibyte characters. Use vim-enhanced instead.
Comment 4 Dmitry Mikhirev 2012-09-05 12:28:23 MSD
Sorry, just ignore previous comment/
Comment 5 Denis Silakov 2012-09-14 15:30:09 MSD
This seems to be some old tar extension not supported by upstream GNU Tar; not sure why/how it is picked up by Ubuntu.

This warning shouldn't break anything - all the archives will be unpacked successfully. 

But if you want to get rid of these messages, use 'bsdtar' instead. It still supports that extension.