Bug 7049 - [UPDATE REQUEST] obs-studio 0.9.1 -> 0.14.2
: [UPDATE REQUEST] obs-studio 0.9.1 -> 0.14.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-18 13:14 MSD by Andrey Bondrov
Modified: 2016-05-30 11:15 MSD (History)
5 users (show)

See Also:
RPM Package: obs-studio
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
Console Log : Launch of OBS (89.58 KB, image/jpeg)
2016-05-18 15:16 MSD, darrencleaver
Details
OBS Files in Dolphin (65.71 KB, image/jpeg)
2016-05-18 19:56 MSD, darrencleaver
Details
OBS Studio Built from (49.33 KB, image/jpeg)
2016-05-18 19:58 MSD, darrencleaver
Details
OBS Starts asks to accept terms then DBUS error (164.75 KB, image/jpeg)
2016-05-18 19:59 MSD, darrencleaver
Details
Final Result of latest download (157.49 KB, image/jpeg)
2016-05-18 19:59 MSD, darrencleaver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2016-05-18 13:14:34 MSD
New version of obs-studio was released.
Comment 1 Andrey Bondrov 2016-05-18 13:17:22 MSD
Advisory: "Update obs-studio to new version 0.14.2"

https://abf.rosalinux.ru/build_lists/2674182
https://abf.rosalinux.ru/build_lists/2674183
Comment 2 Andrey Bondrov 2016-05-18 13:19:58 MSD
*** Bug 7046 has been marked as a duplicate of this bug. ***
Comment 3 darrencleaver 2016-05-18 15:16:03 MSD
Created attachment 4456 [details]
Console Log : Launch of OBS

I downloaded OBS-Studio release 2-plf2014.1 version 0.91. I get the following message when I launch OBS in terminal 

daz@daz-Aspire-V3-572G ~ $ obs
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Default.qss
Attempted path: /usr/share/obs/obs-studio/themes/Default.qss
Attempted path: share/obs/obs-studio/license/gplv2.txt
Attempted path: /usr/share/obs/obs-studio/license/gplv2.txt
QObject::connect: invalid null parameter
info: OBS 0.0.1 (linux)
info: Processor: 4 logical cores
info: Processor: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
info: Physical Memory: 15968MB Total
info: Kernel Version: Linux 4.4.10-nrj-desktop-1rosa-x86_64
info: Distribution: "ROSA Desktop Fresh R7" 2014.1
info: audio settings reset:
        samples per sec: 44100
        speakers:        2
        buffering (ms):  1000

info: X and Y: 902 466
Backbuffers: 2
Color Format: 3
ZStencil Format: 0
Adapter: 0

Segmentation fault (core dumped)
daz@daz-Aspire-V3-572G ~ $
Comment 4 Andrey Bondrov 2016-05-18 15:34:30 MSD
(In reply to comment #3)
> I downloaded OBS-Studio release 2-plf2014.1 version 0.91. I get the
> following message when I launch OBS in terminal 

Can you please try version 0.14.2-1plf instead?

You can get it from the container (install all RPMs except for -devel): http://abf-downloads.rosalinux.ru/rosa2014.1/container/2674183/x86_64/restricted/release/
Comment 5 darrencleaver 2016-05-18 18:57:15 MSD
In reply to  Comment #4 )

Done as suggested. 

Following terminal output:

daz@daz-Aspire-V3-572G ~ $ obs
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Default.qss
Attempted path: /usr/share/obs/obs-studio/themes/Default.qss
Attempted path: share/obs/obs-studio/license/gplv2.txt
Attempted path: /usr/share/obs/obs-studio/license/gplv2.txt
info: Processor: 4 logical cores
info: Processor: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
info: Physical Memory: 15968MB Total
info: Kernel Version: Linux 4.4.10-nrj-desktop-1rosa-x86_64
info: Distribution: "ROSA Desktop Fresh R7" 2014.1
QObject::connect: invalid null parameter
info: OBS 0.0.1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
        samples per sec: 44100
        speakers:        2
error: ARB_GLX_create_context not supported!
error: Failed to create context!
error: device_create (GL) failed
error: Failed to initialize video:  Unspecified error
Comment 6 darrencleaver 2016-05-18 19:07:32 MSD
In reply to comment #3

http://hw.rosalinux.ru/index.php?probe=668a4699fd
Comment 7 darrencleaver 2016-05-18 19:56:47 MSD
Created attachment 4457 [details]
OBS Files in Dolphin

Current files in folder for OBS-Studio in file manager
Comment 8 darrencleaver 2016-05-18 19:58:01 MSD
Created attachment 4458 [details]
OBS Studio Built from

I built from what is shown in this image this time
Comment 9 darrencleaver 2016-05-18 19:59:11 MSD
Created attachment 4459 [details]
OBS Starts asks to accept terms then DBUS error

OBS Starts asks to accept terms then DBUS error
Comment 10 Vladimir Potapov 2016-05-18 19:59:33 MSD
try
optirun obs
or
primusrun obs
(if proprietary drivers for NVIDIA installed by XFdrake)
Comment 11 darrencleaver 2016-05-18 19:59:55 MSD
Created attachment 4460 [details]
Final Result of latest download
Comment 12 Andrey Bondrov 2016-05-18 20:01:58 MSD
(In reply to comment #9)
> OBS Starts asks to accept terms then DBUS error

Looks like it's because it's started from root user. Just run it as a normal user.
Comment 13 darrencleaver 2016-05-18 20:06:36 MSD
(In reply to comment #10)
> try
> optirun obs
> or
> primusrun obs
> (if proprietary drivers for NVIDIA installed by XFdrake)

In response to comment #10

Result:

daz@daz-Aspire-V3-572G ~ $ optirun obs
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Default.qss
Attempted path: /usr/share/obs/obs-studio/themes/Default.qss
Attempted path: share/obs/obs-studio/license/gplv2.txt
Attempted path: /usr/share/obs/obs-studio/license/gplv2.txt
info: Processor: 4 logical cores
info: Processor: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
info: Physical Memory: 15968MB Total
info: Kernel Version: Linux 4.4.10-nrj-desktop-1rosa-x86_64
info: Distribution: "ROSA Desktop Fresh R7" 2014.1
QObject::connect: invalid null parameter
info: OBS 0.0.1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
        samples per sec: 44100
        speakers:        2
info: OpenGL version: 3.2.0 NVIDIA 361.42

info: ---------------------------------
info: video settings reset:
        base resolution:   1366x768
        output resolution: 1092x614
        fps:               30/1
        format:            NV12
info: ---------------------------------
info: Loading module: image-source.so
info: ---------------------------------
info: Loading module: linux-alsa.so
info: ---------------------------------
info: Loading module: linux-capture.so
info: ---------------------------------
info: Loading module: linux-decklink.so
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
info: No blackmagic support
info: Failed to start search for DeckLink devices
info: ---------------------------------
info: Loading module: linux-jack.so
info: ---------------------------------
info: Loading module: linux-pulseaudio.so
info: ---------------------------------
info: Loading module: linux-v4l2.so
info: ---------------------------------
info: Loading module: obs-ffmpeg.so
info: ---------------------------------
info: Loading module: obs-filters.so
info: ---------------------------------
info: Loading module: obs-outputs.so
info: ---------------------------------
info: Loading module: obs-transitions.so
info: ---------------------------------
info: Loading module: obs-x264.so
info: ---------------------------------
info: Loading module: rtmp-services.so
info: ---------------------------------
info: Loading module: text-freetype2.so
info: =====================================================================
info: output 'simple_stream' (rtmp_output) created
info: encoder 'simple_h264_stream' (obs_x264) created
info: AAC encoder bitrate mapping:
         32 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
         64 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
         96 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        128 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        160 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        192 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        224 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        256 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        288 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        320 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
info: encoder 'simple_aac' (ffmpeg_aac) created
info: output 'simple_file_output' (ffmpeg_muxer) created
error: Service '' not found
info: service 'default_service' (rtmp_common) created
info: No scene file found, creating default scene
info: All scene data cleared
info: ------------------------------------------------
info: source 'Scene' (scene) created
info: pulse-input: Server name: 'pulseaudio 8.0.0-2'
error: pulse-input: Sample spec is not valid
error: Failed to create source 'Desktop Audio'!
info: source 'Desktop Audio' (pulse_output_capture) created
info: pulse-input: Server name: 'pulseaudio 8.0.0-2'
error: pulse-input: Sample spec is not valid
error: Failed to create source 'Mic/Aux'!
info: source 'Mic/Aux' (pulse_input_capture) created
warning: Failed to glob scene collections
info: == Profiler Results =============================
info: run_program_init: 1196.38 ms
info:  ┣OBSApp::AppInit: 1.405 ms
info:  ┃ ┗OBSApp::InitLocale: 0.641 ms
info:  ┗OBSApp::OBSInit: 1024.38 ms
info:    ┣obs_startup: 0.873 ms
info:    ┗OBSBasic::OBSInit: 995.915 ms
info:      ┣OBSBasic::InitBasicConfig: 0.336 ms
info:      ┣OBSBasic::ResetAudio: 0.066 ms
info:      ┣OBSBasic::ResetVideo: 682.016 ms
info:      ┣OBSBasic::InitOBSCallbacks: 0.004 ms
info:      ┣OBSBasic::InitHotkeys: 0.032 ms
info:      ┣obs_load_all_modules: 42.662 ms
info:      ┃ ┣obs_init_module(image-source.so): 0.001 ms
info:      ┃ ┣obs_init_module(linux-alsa.so): 0.002 ms
info:      ┃ ┣obs_init_module(linux-capture.so): 1.615 ms
info:      ┃ ┣obs_init_module(linux-decklink.so): 0.195 ms
info:      ┃ ┣obs_init_module(linux-jack.so): 0.003 ms
info:      ┃ ┣obs_init_module(linux-pulseaudio.so): 0.002 ms
info:      ┃ ┣obs_init_module(linux-v4l2.so): 0.003 ms
info:      ┃ ┣obs_init_module(obs-ffmpeg.so): 26.032 ms
info:      ┃ ┣obs_init_module(obs-filters.so): 0.009 ms
info:      ┃ ┣obs_init_module(obs-outputs.so): 0.002 ms
info:      ┃ ┣obs_init_module(obs-transitions.so): 0.005 ms
info:      ┃ ┣obs_init_module(obs-x264.so): 0.001 ms
info:      ┃ ┣obs_init_module(rtmp-services.so): 0.079 ms
info:      ┃ ┗obs_init_module(text-freetype2.so): 0.042 ms
info:      ┣OBSBasic::ResetOutputs: 0.243 ms
info:      ┣OBSBasic::CreateHotkeys: 0.016 ms
info:      ┣OBSBasic::InitService: 0.045 ms
info:      ┣OBSBasic::InitPrimitives: 128.205 ms
info:      ┗OBSBasic::Load: 132.094 ms
info: =================================================
error: X Error: GLXBadDrawable
error: Failed to make context current.
error: X Error: GLXBadDrawable
error: X Error: GLXBadDrawable
error: Failed to make context current.
daz@daz-Aspire-V3-572G ~ $
Comment 14 darrencleaver 2016-05-18 20:07:31 MSD
In reply to comment #10

Result:

daz@daz-Aspire-V3-572G ~ $ primusrun obs
primus: fatal: broken GLX on main X display
daz@daz-Aspire-V3-572G ~ $
Comment 15 darrencleaver 2016-05-18 20:10:29 MSD
In response to comment #14

Probe #668a4699fd of Acer Aspire V3-572G
Log: glxinfo
Error: couldn't find RGB GLX visual or fbconfig
name of display: :0
Comment 16 Zombie Ryushu 2016-05-18 20:17:02 MSD
Your nVidia Drivers are screwed up.
Comment 17 darrencleaver 2016-05-18 20:29:32 MSD
In reply to comment 12#

Looks like it's because it's started from root user. Just run it as a normal user.

https://drive.google.com/open?id=0BwTauBkiy7M4OG1FMW1hQjdBblk
Comment 18 darrencleaver 2016-05-18 20:36:04 MSD
In reply to comment 16#

Screw up Nvidea

Solution?
Comment 19 Zombie Ryushu 2016-05-18 21:31:23 MSD
You need to ensure whatever dkms-nvidia packages are installed for your card are installed correctly. Go through your configuation again, make sure you are using the proprietary drivers are selected, all dependencies are installed. 

Do NOT install the nVidia Drivers the way the documentation says on Nvidia's site, they will break DKMS.
Comment 20 Vladimir Potapov 2016-05-19 05:55:19 MSD
(In reply to comment #18)
> In reply to comment 16#
> 
> Screw up Nvidea
> 
> Solution?

1) run XFdrake, set free drivers, reboot
2) uninstall all nvidia packages and drivers, reboot
3) run XFdrake, set up recommended proprietary drivers
Comment 21 Vladimir Potapov 2016-05-19 16:07:21 MSD
The update is sent to expanded testing
***************************************
Comment 22 darrencleaver 2016-05-19 16:08:32 MSD
Response to comment #20

" 1) run XFdrake, set free drivers, reboot
2) uninstall all nvidia packages and drivers, reboot
3) run XFdrake, set up recommended proprietary drivers "

ISSUE SOLVED

OBS-STUDIO NOW WORKING !

Thanks to all those that took the time to help with this problem. Most appreciated

Good work all !!
Comment 23 darrencleaver 2016-05-19 19:50:43 MSD
Reply comment 20#

Issue with Lag between OBS-Studio to Youtube-Live Stream

Potential cause: ROSA is not installing selected Nvidia drivers after running 
XFdrake + or inxi isn't showing changes?

https://drive.google.com/open?id=0BwTauBkiy7M4QkR3c0dVQmJvcFU
Comment 24 Vladimir Potapov 2016-05-19 20:08:13 MSD
get output of
glxinfo |grep OpenGL
Comment 25 darrencleaver 2016-05-19 20:13:40 MSD
@ #24

daz@daz-Aspire-V3-572G ~ $ glxinfo |grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2) 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.0.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
daz@daz-Aspire-V3-572G ~ $
Comment 26 Vladimir Potapov 2016-05-19 20:24:35 MSD
Thank you!
get output of
optirun glxinfo |grep OpenGL
Comment 27 darrencleaver 2016-05-19 21:47:22 MSD
@ #26

daz@daz-Aspire-V3-572G ~ $ optirun glxinfo |grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 840M/PCIe/SSE2
OpenGL version string: 4.5.0 NVIDIA 361.42
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
daz@daz-Aspire-V3-572G ~ $
Comment 28 Vladimir Potapov 2016-05-20 03:37:56 MSD
Ok, you have two video cards. 
If you need to use the Intel, run
obs

if you need to use the Nvidia, run
optirun obs
Comment 29 Vladimir Potapov 2016-05-20 03:40:21 MSD
(In reply to comment #23)
> Reply comment 20#
> 
> Issue with Lag between OBS-Studio to Youtube-Live Stream
> 
> Potential cause: ROSA is not installing selected Nvidia drivers after
> running 
> XFdrake + or inxi isn't showing changes?
> 
> https://drive.google.com/open?id=0BwTauBkiy7M4QkR3c0dVQmJvcFU

try obs on nvidia card by
optirun obs
or
primusrun obs
Comment 30 darrencleaver 2016-05-20 16:57:20 MSD
@ 29

" try obs on nvidia card by
optirun obs
or
primusrun obs" 

RESULTS:

optirun obs

daz@daz-Aspire-V3-572G ~ $ optirun obs
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/themes/Default.qss
Attempted path: /usr/share/obs/obs-studio/themes/Default.qss
Attempted path: share/obs/obs-studio/license/gplv2.txt
Attempted path: /usr/share/obs/obs-studio/license/gplv2.txt
info: Processor: 4 logical cores
info: Processor: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
info: Physical Memory: 15968MB Total
info: Kernel Version: Linux 4.4.10-nrj-desktop-1rosa-x86_64
info: Distribution: "ROSA Desktop Fresh R7" 2014.1
QObject::connect: invalid null parameter
info: OBS 0.0.1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
        samples per sec: 44100
        speakers:        2
info: OpenGL version: 3.2.0 NVIDIA 361.42

info: ---------------------------------
info: video settings reset:
        base resolution:   1366x768
        output resolution: 1092x614
        fps:               30/1
        format:            NV12
info: ---------------------------------
info: Loading module: image-source.so
info: ---------------------------------
info: Loading module: linux-alsa.so
info: ---------------------------------
info: Loading module: linux-capture.so
info: ---------------------------------
info: Loading module: linux-decklink.so
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
info: No blackmagic support
info: Failed to start search for DeckLink devices
info: ---------------------------------
info: Loading module: linux-jack.so
info: ---------------------------------
info: Loading module: linux-pulseaudio.so
info: ---------------------------------
info: Loading module: linux-v4l2.so
info: ---------------------------------
info: Loading module: obs-ffmpeg.so
info: ---------------------------------
info: Loading module: obs-filters.so
info: ---------------------------------
info: Loading module: obs-outputs.so
info: ---------------------------------
info: Loading module: obs-transitions.so
info: ---------------------------------
info: Loading module: obs-x264.so
info: ---------------------------------
info: Loading module: rtmp-services.so
info: ---------------------------------
info: Loading module: text-freetype2.so
info: =====================================================================
info: output 'simple_stream' (rtmp_output) created
info: encoder 'simple_h264_stream' (obs_x264) created
info: AAC encoder bitrate mapping:
         32 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
         64 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
         96 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        128 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        160 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        192 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        224 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        256 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        288 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
        320 kbit/s: 'FFmpeg Default AAC Encoder' (ffmpeg_aac)
info: encoder 'simple_aac' (ffmpeg_aac) created
info: output 'simple_file_output' (ffmpeg_muxer) created
info: service 'default_service' (rtmp_common) created
info: All scene data cleared
info: ------------------------------------------------
info: pulse-input: Server name: 'pulseaudio 8.0.0-2'
error: pulse-input: Sample spec is not valid
error: Failed to create source 'Desktop Audio'!
info: source 'Desktop Audio' (pulse_output_capture) created
info: pulse-input: Server name: 'pulseaudio 8.0.0-2'
error: pulse-input: Sample spec is not valid
error: Failed to create source 'Mic/Aux'!
info: source 'Mic/Aux' (pulse_input_capture) created
info: v4l2-input: Start capture from /dev/video0
info: v4l2-input: Input: 0
info: v4l2-input: Resolution: 160x120
info: v4l2-input: Pixelformat: VYUY
info: v4l2-input: Linesize: 320 Bytes
info: v4l2-input: Framerate: 30.00 fps
info: source 'Video Capture Device (V4L2)' (v4l2_input) created
info: source 'Scene' (scene) created
info: == Profiler Results =============================
info: run_program_init: 518.216 ms
info:  ┣OBSApp::AppInit: 1.432 ms
info:  ┃ ┗OBSApp::InitLocale: 0.635 ms
info:  ┗OBSApp::OBSInit: 347.195 ms
info:    ┣obs_startup: 1.229 ms
info:    ┗OBSBasic::OBSInit: 315.905 ms
info:      ┣OBSBasic::InitBasicConfig: 0.346 ms
info:      ┣OBSBasic::ResetAudio: 0.123 ms
info:      ┣OBSBasic::ResetVideo: 118.026 ms
info:      ┣OBSBasic::InitOBSCallbacks: 0.003 ms
info:      ┣OBSBasic::InitHotkeys: 0.032 ms
info:      ┣obs_load_all_modules: 16.827 ms
info:      ┃ ┣obs_init_module(image-source.so): 0.002 ms
info:      ┃ ┣obs_init_module(linux-alsa.so): 0.002 ms
info:      ┃ ┣obs_init_module(linux-capture.so): 1.59 ms
info:      ┃ ┣obs_init_module(linux-decklink.so): 0.154 ms
info:      ┃ ┣obs_init_module(linux-jack.so): 0.003 ms
info:      ┃ ┣obs_init_module(linux-pulseaudio.so): 0.002 ms
info:      ┃ ┣obs_init_module(linux-v4l2.so): 0.004 ms
info:      ┃ ┣obs_init_module(obs-ffmpeg.so): 0.071 ms
info:      ┃ ┣obs_init_module(obs-filters.so): 0.007 ms
info:      ┃ ┣obs_init_module(obs-outputs.so): 0.003 ms
info:      ┃ ┣obs_init_module(obs-transitions.so): 0.005 ms
info:      ┃ ┣obs_init_module(obs-x264.so): 0.002 ms
info:      ┃ ┣obs_init_module(rtmp-services.so): 0.719 ms
info:      ┃ ┗obs_init_module(text-freetype2.so): 0.026 ms
info:      ┣OBSBasic::ResetOutputs: 0.226 ms
info:      ┣OBSBasic::CreateHotkeys: 0.017 ms
info:      ┣OBSBasic::InitService: 0.416 ms
info:      ┣OBSBasic::InitPrimitives: 8.323 ms
info:      ┗OBSBasic::Load: 138.023 ms
info: =================================================
error: X Error: GLXBadDrawable
error: Failed to make context current.
error: X Error: GLXBadDrawable
error: X Error: GLXBadDrawable
error: Failed to make context current.
daz@daz-Aspire-V3-572G ~ $
Comment 31 Vladimir Potapov 2016-05-20 17:15:24 MSD
Hm. Will the error when booting from default kernel - 4.1.22?
Comment 32 darrencleaver 2016-05-20 20:23:11 MSD
@ #28 & #31

OBS-Studio does run with :

primusrun obs ( Nvidia )

obs ( Intel ) also works now

@ #28 

"Ok, you have two video cards. "

Why do I have two video cards? One Intel and one NVidea ?

What is better to run? 

Can you tell by this log what the cards are? 
http://hw.rosalinux.ru/index.php?probe=668a4699fd

As Id like to get a much better card installed if possible to help give OBS some more boost
Comment 33 darrencleaver 2016-05-20 20:24:18 MSD
(In reply to comment #31)
> Hm. Will the error when booting from default kernel - 4.1.22?


Current :

4.4.10-nrj-desktop-1rosa-x86_64

No error booting
Comment 34 Eugene Shatokhin 2016-05-20 21:18:48 MSD
(In reply to comment #32)
> Why do I have two video cards? One Intel and one NVidea ?
> 
> What is better to run? 
> 
> Can you tell by this log what the cards are? 
> http://hw.rosalinux.ru/index.php?probe=668a4699fd

Yes, here they are:
1. (integrated) Intel HD Graphics 5500
2. NVidia GM108M [GeForce 840M]
Comment 35 Eugene Shatokhin 2016-05-22 19:23:39 MSD
As far as I understand it, OBS Studio runs OK if launched with 'primusrun obs'. Right?
Comment 36 darrencleaver 2016-05-22 20:15:19 MSD
@ #35

As far as I understand it, OBS Studio runs OK if launched with 'primusrun obs'. Right?

Yes OBS Studio does run. However I there is too much of a lag between getting the video to you-tube live stream to make it viable to use. I do not know if its OBS settings, ( which I am sure are correct ). Or if its youtube's settings of allowing a certain amount of data to be launched into their servers. Either way its a project I have given up on. I am now looking at using Big Blue Button as the streaming software. I have put a request into ROSA to see if they can build a software package for it . http://docs.bigbluebutton.org/install/install.html

On a side note: If anyone can answer or solve the following problem and can run what I am asking of. Willing do make a donation $ to ROSA or dev that can help answer the question and provide steps to building it. 

Taking into account the dev of Big Blue Button said this to me : 
We designed BigBlueButton for groups of 50 users (or less).  See

  http://docs.bigbluebutton.org/support/faq.html#how-many-simultaneous-users-can-bigbluebutton-support

We would recommend you use a different solution.

HOWEVER: Bases on the server specs you see I would have , I hypothetically dont see why it would not work >>>

Having trouble finding out the answer to this question. I want to live stream a conference using ( at this stage ) http://demo.bigbluebutton.org/ ( BBB ) However my system and server does not have enough power to stream HD720 p in real time to around 200-600 world wide. I plan to use a Cloud Server and upload a Virtual OS with the streaming software BBB on it. What I cant get the answer to even from the Cloud Host Vultr https://www.vultr.com/ is , ( Is how is it possible to stream the Video from my local machine into the VM Cloud and run through BBB). Its been suggested I might use a IP Webcam instead of the USB connection to my local machine. Then an option to send the stream from my local machine at the event to the Cloud OS Id SSH it to the Cloud OS. The Cloud Host specs are 700GB SSD, 655536MB Memory with 150000GB Bandwidth . There is also the question of how much of an issue re: Bandwidth uploading Live Video from Local Machine to Cloud OS how much that will effect the quality of the stream . I hope all that makes sense. I really have little money for this project , however should someone provide a solid answer and can replicate what I am wanting to achieve I will offer a payment negotiated
Comment 37 Eugene Shatokhin 2016-05-23 11:24:16 MSD
CC'ing Stas Fomin, he might be interested in this discussion as well.
Comment 38 Stas Fomin 2016-05-24 01:01:52 MSD
«there is too much of a lag between getting the video to you-tube»

I it not a bug of OBS. It is how Youtube works.
Lag about 40s-1m30s is normal, according my experience.

Youtube (also Haingout on Air) not for streaming that need immediate response.

Try hitbox.tv (end geo-select server that near to you),
it possible to minimize lag to 2-3s (with hitbox).
Comment 39 Vladimir Potapov 2016-05-24 05:34:23 MSD
obs-studio-0.14.2-1
https://abf.rosalinux.ru/build_lists/2674182
https://abf.rosalinux.ru/build_lists/2674183
****************************** Advisory *********************************
Update obs-studio to new version 0.14.2
*************************************************************************
QA Verified