Bug 7045 - Mixed architectures in dependencies of package lib64SDL_mixer-devel
: Mixed architectures in dependencies of package lib64SDL_mixer-devel
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-14 15:57 MSD by Anton Stankevich
Modified: 2016-05-21 01:29 MSD (History)
2 users (show)

See Also:
RPM Package: lib64SDL_mixer-devel
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Stankevich 2016-05-14 15:57:59 MSD
Description of problem:
I try to install lib64SDL_mixer-devel, having already installed lib64gcrypt-devel.
Installation of this package fais because of mixed achitectures in depedencies (produce file conflicts). Invalid items are listed below:
- libgcrypt-devel-1.6.1-2-rosa2014.1.i586
- libotr-devel-4.1.1-1-rosa2014.1.i586
Version-Release number of selected component (if applicable):
  lib64SDL_mixer-devel-1.2.12-4-rosa2014.1
  lib64gcrypt-devel-1.6.1-2-rosa2014.1
How reproducible:
  Always
Steps to Reproduce:
1. Run rpmdrake
2. Install lib64gcrypt-devel
3. Check that Main32 source is switched on!
4. Install lib64SDL_mixer-devel.
5. See the message about conflicts of some files from package lib64gcrypt-devel.

Note: The bug is not reproduced if you have switched off 32 bit package sources. Thas why 3 point is important.
Comment 1 Denis Silakov 2016-05-21 01:29:48 MSD
I wonder if "urpmi lib64SDL_mixer-devel" will work in this case? If yes then it is likely an issue with dependency resolution in rpmdrake.