Bug 7004 - Kernel and cpupower upgrades mismatch
: Kernel and cpupower upgrades mismatch
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-05 19:47 MSD by Mikhail N
Modified: 2016-05-05 23:33 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail N 2016-05-05 19:47:14 MSD
The instructions on http://wiki.rosalab.ru/ru/index.php/%D0%9E%D0%B1%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_%D1%8F%D0%B4%D1%80%D0%B0_%D0%B4%D0%BE_4.3 are old, I know that, but if to follow them and change 4.3 to 4.4 then the cpupower package is updated to 4.4 but the kernel is still 4.1

There are no articles on wiki which would describe the new kernel update process and I cannot write it because I don't know.
Comment 1 Eugene Shatokhin 2016-05-05 23:33:17 MSD
Indeed.

I have fixed the instructions there and prepared more general ones to avoid creating a new Wiki page each time an unofficial kernel branch is prepared:

Rus: http://wiki.rosalab.ru/ru/index.php/%D0%A3%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B0_%D0%BD%D0%B5%D0%BE%D1%84%D0%B8%D1%86%D0%B8%D0%B0%D0%BB%D1%8C%D0%BD%D1%8B%D1%85_%D0%B2%D0%B5%D1%80%D1%81%D0%B8%D0%B9_%D1%8F%D0%B4%D1%80%D0%B0

Eng: http://wiki.rosalab.ru/en/index.php/Installing_unofficial_kernels

In short, installing kernel-nrj-desktop-latest and kernel-nrj-desktop-devel-latest is deprecated.

kernel-nrj-desktop-4.4-latest and kernel-nrj-desktop-4.4-devel-latest should be used for kernels 4.4.x, same for other unofficial kernels from kernels_stable_personal/repository/*.