Bug 70 - Garbage instead of russian text when I switch to russian keyboard layout in virtual console
: Garbage instead of russian text when I switch to russian keyboard layout in v...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: High major
: 2012 Marathon RP1
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-18 09:56 MSD by FirstLevel
Modified: 2014-06-03 16:28 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-04-18 09:56:40 MSD
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. I have two language in my system: russian and english. I 've defined the
"Ctrl-Shift" combination to switch to another keyboard layout. It works fine in
KDE.
2. Then  I go to virtual console (by Ctrl-Alt-F1)
3. If I press "Ctrl-Shift" I see garbage instead of russian text.
See the attach 
http://s017.radikal.ru/i444/1110/fe/a6f6afc48113.png
And more... 
After first pressing  "Ctrl-Shift" this combination doesn't work another time
and I can't to switch back to english keyboard layout.
Comment 1 alexander barakin 2012-05-25 14:55:23 MSD
at least missing directory /lib/modules/<old-linux-modules>

i'll try to solve this problem·
Comment 2 alexander barakin 2012-05-25 14:57:10 MSD
(In reply to comment #1)
> at least missing directory /lib/modules/<old-linux-modules>
> 
> i'll try to solve this problem·

ups! this message refers to another bug
Comment 3 Aleksandr Kazantcev 2012-05-25 15:01:45 MSD
Add 

loadkeys -u ru 

in  /etc/rc.d/rc.local
Comment 4 Alexander Burmashev 2012-05-25 15:07:20 MSD
should we make this system-wide = fix some package ?
Comment 5 Alexander Burmashev 2012-08-03 15:25:17 MSD
Advisory:
loadkeys added by default
Buildlists:
https://abf.rosalinux.ru/build_lists/640434
https://abf.rosalinux.ru/build_lists/640433
Comment 6 Vladimir Potapov 2012-08-03 15:55:08 MSD
in testing
Comment 7 Vladimir Potapov 2012-08-04 05:25:38 MSD
1) I 've defined the "Alt-Shift" combination to switch to another keyboard layout.
But in virtual console work ctrl+shift
2) In i586 in the console instead of the Russian characters are displayed "???". (x64-OK)
Comment 8 Vladimir Potapov 2012-08-04 05:45:12 MSD
P.S. I am using  english locale on my i586 system.
Perhaps this additional problem. But in the Konsole everything works correctly.
Comment 9 FirstLevel 2012-08-31 10:01:56 MSD
(In reply to comment #3)
> Add 
> 
> loadkeys -u ru 
> 
> in  /etc/rc.d/rc.local

This method works for me when I choose "Ctrl-Shift" combination fir switch languages.
But another problem user tells that if he has "CapsLock" for switching languages this method does not work at all. He has only latin symbols and pressing "CapsLock"  only switch latin lowercase to uppercase, but russian symbols does not apper.
Comment 10 alexander barakin 2012-12-13 17:54:17 MSK
(In reply to comment #9)
> (In reply to comment #3)
> > Add 
> > 
> > loadkeys -u ru 
> > 
> > in  /etc/rc.d/rc.local
> 
> This method works for me when I choose "Ctrl-Shift" combination fir switch
> languages.
> But another problem user tells that if he has "CapsLock" for switching
> languages this method does not work at all. He has only latin symbols and
> pressing "CapsLock"  only switch latin lowercase to uppercase, but russian
> symbols does not apper.

afaik, it's impossible.

in any case, it's a completely different bug.
i think this bug should be closed as resolved.
create a new bug, if you think it necessary.
Comment 11 FirstLevel 2012-12-16 17:07:58 MSK
(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #3)
> > > Add 
> > > 
> > > loadkeys -u ru 
> > > 
> > > in  /etc/rc.d/rc.local
> > 
> > This method works for me when I choose "Ctrl-Shift" combination fir switch
> > languages.
> > But another problem user tells that if he has "CapsLock" for switching
> > languages this method does not work at all. He has only latin symbols and
> > pressing "CapsLock"  only switch latin lowercase to uppercase, but russian
> > symbols does not apper.
> 
> afaik, it's impossible.
> 
> in any case, it's a completely different bug.
> i think this bug should be closed as resolved.
> create a new bug, if you think it necessary.

Ok. I have created another bug http://bugs.rosalinux.ru/show_bug.cgi?id=1251 about problem with CapsLock