Bug 6954 - Installing python3-gstreamer1.0 makes firefox hang in various cases
: Installing python3-gstreamer1.0 makes firefox hang in various cases
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
http://abf.rosalinux.ru
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-20 00:54 MSD by Giovanni Mariani
Modified: 2017-03-07 21:31 MSK (History)
1 user (show)

See Also:
RPM Package: python-gstreamer1.0-1.6.2-1.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
Konsole log of a hung firefox session (browsing ABF site) (2.18 KB, text/x-log)
2016-04-20 00:54 MSD, Giovanni Mariani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-04-20 00:54:28 MSD
Created attachment 4442 [details]
Konsole log of a hung firefox session (browsing ABF site)

Description of problem:
After installing python3-gstreamer1.0 firefox started to hang in various reproducible ways:
* browsing some websites such as http://abf.rosalinux.ru;
* trying to download a file from http://abf-downloads.rosalinux.ru/rosa2014.1/repository/SRPMS/main/updates/, by clicking on it.

Launching firefox from a konsole shows some error messages about /usr/lib64/python3.4/site-packages/gi/module.py (see attached log).

Version-Release number of selected component (if applicable):
1.6.2-1

How reproducible:
Always (with the "right" sites).

Steps to Reproduce:
1. Install python3-gstreamer1.0
2. Start firefox from a konsole
3a. Go to http://abf.rosalinux.ru
4a. Watch the hang while loading the home page
5a. Look at the error message in konsole
*or*
3b. Go to http://abf-downloads.rosalinux.ru/rosa2014.1/repository/SRPMS/main/updates/
4b. Click on a link to download a file
5b. Watch the hang (the tab says: "Connecting")
6b. Look at the error message in konsole
Comment 1 Giovanni Mariani 2016-04-20 00:55:21 MSD
Obviously, removing python3-gstreamer1.0 restores the firefox functionality...
Comment 2 Denis Silakov 2017-03-07 09:36:59 MSK
IS this still the issue?
Comment 3 Giovanni Mariani 2017-03-07 21:31:55 MSK
Since I now have python3-gstreamer1.0-1.6.2-1-rosa2014.1.x86_64 installed and still using firefox without a glitch, I would say "No".
Closing...