Bug 693 - mdkapplet crash
: mdkapplet crash
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 21:42 MSD by Sylvainsjc
Modified: 2015-12-26 12:58 MSK (History)
6 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Screenshot abrt (66.41 KB, image/jpeg)
2012-08-22 21:42 MSD, Sylvainsjc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvainsjc 2012-08-22 21:42:23 MSD
Created attachment 492 [details]
Screenshot abrt

Description of problem: since the last update this morning, few minutes after opening the session, bug report tool tells mdkapplet crash
This occurs at each login

the error in abrt is the following :
  Undefined subroutine &common::cmp_kernel_versions called at /usr/lib/libDrakX/network/tools.pm line 271.
  standalone::bug_handler() called from /usr/bin/mdkapplet:299

Packages updated :
2012-08-22 07:50:10 lib64nm-util2-0.9.2.0-5-rosa.lts2012.0.x86_64
                    libdrakx-net-0.97-2-rosa.lts2012.0.noarch
                    bash-4.2-11.1-rosa.lts2012.0.x86_64
                    lib64nm-glib-vpn1-0.9.2.0-5-rosa.lts2012.0.x86_64
                    lib64nm-glib4-0.9.2.0-5-rosa.lts2012.0.x86_64
                    drakx-net-text-0.97-2-rosa.lts2012.0.noarch
                    initscripts-9.25-12-rosa.lts2012.0.x86_64
                    drakx-net-0.97-2-rosa.lts2012.0.noarch
2012-08-22 07:50:23 dhcp-common-4.2.4-0.P1.1.1-rosa.lts2012.0.x86_64
                    networkmanager-0.9.2.0-5-rosa.lts2012.0.x86_64
                    pm-utils-1.4.1-8-rosa.lts2012.0.x86_64
                    mdkonline-2.77.22-6-rosa.lts2012.0.noarch
                    dhcp-client-4.2.4-0.P1.1.1-rosa.lts2012.0.x86_64

See attached screenshot
Comment 1 Aleksandr Kazantcev 2012-08-22 21:50:34 MSD
It's crash with broken update :( 

All of you need - install this package:

https://abf.rosalinux.ru/build_lists/687871
https://abf.rosalinux.ru/build_lists/687870

As update will appear for short time and this fix need only if you update to NM-0.9.2-5 we don't push this package to repo.

But soon we update NM for 0.9.4 (last test seen it's work) and drakx-net too.
Comment 2 Denis Koryavov 2012-08-22 22:45:12 MSD
Or just remove mdkonline package and install it again. New package came to repository by mistake.
Comment 3 Sylvainsjc 2012-08-23 07:01:26 MSD
Thank you very much, it works now.
Comment 4 stefninie 2012-09-02 22:31:09 MSD
(In reply to comment #2)
> Or just remove mdkonline package and install it again. New package came to
> repository by mistake.

Sorry but I have removed then reinstalled mdkonline but it doesn't work at home. 
I have still the window of the rosa linux bug report tool at starting.
Comment 5 Aleksandr Kazantcev 2012-09-14 21:55:20 MSD
*** Bug 768 has been marked as a duplicate of this bug. ***
Comment 6 Aleksandr Kazantcev 2012-09-18 11:45:28 MSD
*** Bug 777 has been marked as a duplicate of this bug. ***
Comment 7 Denis Silakov 2013-01-14 11:20:49 MSK
Packages that led to this issue (updated drakx-net and networkmanager) were dropped from repositories, so such a problem should not arise anymore.

If you still experience the problem, please downgrade drakx-net and networkmanager to versions from main/release. (you can try to use urpm-reposync to automaticalyl sync your system with repositories).