Bug 6905 - [UPDATE REQUEST] libreoffice 4.4.7 -> 5.1.2
: [UPDATE REQUEST] libreoffice 4.4.7 -> 5.1.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-06 07:48 MSD by Andrey Bondrov
Modified: 2016-05-06 20:20 MSD (History)
3 users (show)

See Also:
RPM Package: libreoffice
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments
rubl (6.64 KB, application/wps-office.xlsx)
2016-04-18 18:53 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2016-04-06 07:48:30 MSD
New version of LibreOffice was released.
Comment 1 Andrey Bondrov 2016-04-06 07:52:10 MSD
1. libwps:

Advisory: "Update libwps to new version 0.4.3"

https://abf.rosalinux.ru/build_lists/2629723
https://abf.rosalinux.ru/build_lists/2629724

2. liborcus:

Advisory: "Update liborcus to new version 0.9.1"

https://abf.rosalinux.ru/build_lists/2629727
https://abf.rosalinux.ru/build_lists/2629728

3. libexttextcat:

Advisory: "Update libexttextcat to new version 3.4.4"

https://abf.rosalinux.ru/build_lists/2629729
https://abf.rosalinux.ru/build_lists/2629730

4. libreoffice:

Advisory: "Update LibreOffice to new version 5.1.1"

https://abf.rosalinux.ru/build_lists/2630035
https://abf.rosalinux.ru/build_lists/2630036
Comment 3 Vladimir Potapov 2016-04-06 14:32:30 MSD
Не открывает файлы с smb-шар.
Comment 4 Denis Silakov 2016-04-06 19:19:17 MSD
*** Bug 6865 has been marked as a duplicate of this bug. ***
Comment 5 Vladimir Potapov 2016-04-06 19:31:15 MSD
The update is sent to expanded testing
**************************************
Comment 6 Andrey Bondrov 2016-04-08 20:31:20 MSD
libreoffice (requires containers #1, #2, #3, replaces older build #4):

Advisory: "Update LibreOffice to new version 5.1.2"

https://abf.rosalinux.ru/build_lists/2630586
https://abf.rosalinux.ru/build_lists/2630587
Comment 7 Vladimir Potapov 2016-04-08 21:10:21 MSD
The update is sent to expanded testing
***************************************
Comment 8 Vladimir Potapov 2016-04-11 16:30:44 MSD
При старте запрашивает яву
$ lowriter
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
Comment 9 Vladimir Potapov 2016-04-11 16:35:01 MSD
(In reply to comment #8)
> При старте запрашивает яву
> $ lowriter
> javaldx: Could not find a Java Runtime Environment!
> Warning: failed to read path from javaldx

urpmi libreoffice-java solve the issue
Comment 10 Andrey Bondrov 2016-04-11 17:58:24 MSD
(In reply to comment #8)
> При старте запрашивает яву
> $ lowriter
> javaldx: Could not find a Java Runtime Environment!
> Warning: failed to read path from javaldx

Это вроде бы опциональная фича. Только для base обязательная зависимость от libreoffice-java.
Comment 11 Denis Silakov 2016-04-14 00:20:43 MSD
(In reply to comment #10)
> (In reply to comment #8)
> > При старте запрашивает яву
> > $ lowriter
> > javaldx: Could not find a Java Runtime Environment!
> > Warning: failed to read path from javaldx
> 
> Это вроде бы опциональная фича. Только для base обязательная зависимость от
> libreoffice-java.

Да, оно всегда так было. Просто раньше в консоли на это ругани не было. Но если попробовать сделать что-то, требующее яву, то и сейчас появится окошко с сообщением об ее отсутсвии.
Comment 12 Vladimir Potapov 2016-04-16 19:22:23 MSD
1) Не рисуются круг и квадрат в фигурах
2) Название одного из стилей псевдографикой
http://forum.rosalab.ru/viewtopic.php?f=53&t=5372&p=68619#p68549
В windows-версии ошибки не наблюдаются.
Comment 13 Vladimir Potapov 2016-04-18 18:53:34 MSD
Created attachment 4441 [details]
rubl

Не рисуются символы рубля.
Решается установкой шрифтов paratype-pt-sans-fonts
Comment 14 Vladimir Potapov 2016-04-18 18:54:34 MSD
фигуры круг и квадрат начинают рисоваться после установки libreoffice-openclipart
Comment 15 Vladimir Potapov 2016-04-18 18:55:16 MSD
Установленный libreoffice-kde4 вызывает 100% загрузку процессора при открытии диалога открытия файла
Comment 16 Andrey Bondrov 2016-04-26 20:12:18 MSD
libreoffice (requires containers #1, #2, #3, replaces older build #4):

Advisory: "Update LibreOffice to new version 5.1.2"

https://abf.rosalinux.ru/build_lists/2636211
https://abf.rosalinux.ru/build_lists/2636212
Comment 17 Vladimir Potapov 2016-04-27 14:22:01 MSD
The update is sent to expanded testing
***************************************
Comment 18 Vladimir Potapov 2016-05-06 14:34:22 MSD
libreoffice-5.1.2-2
https://abf.rosalinux.ru/build_lists/2636211
https://abf.rosalinux.ru/build_lists/2636212
*************************** Advisory *******************************
Update LibreOffice to new version 5.1.2
********************************************************************
QA Verified