Bug 6840 - [UPDATE REQUEST] kernel 4.1.19
: [UPDATE REQUEST] kernel 4.1.19
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 6839
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 22:58 MSK by Eugene Shatokhin
Modified: 2016-03-21 17:37 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
eugene.shatokhin: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2016-03-13 22:58:42 MSK
Kernel was updated to version 4.1.19 with additional fixes.
Comment 1 Eugene Shatokhin 2016-03-13 23:03:51 MSK
Advisory:
The kernel was updated to version 4.1.19 with lots of fixes all-around. In addition to upstream changes, the following fixes and enhancements were made:
1) CONFIG_INTEL_IOMMU_DEFAULT_ON option as well as a few others were disabled: they might have caused boot problems;
2) WiFi hard-block issues on some HP laptops were fixed;
3) AUFS was updated to version "4.1.13+-20160223".


Build lists:
i586:
https://abf.io/build_lists/2627082
x86_64:
https://abf.io/build_lists/2627083
Comment 2 Eugene Shatokhin 2016-03-14 11:31:36 MSK
This update should not be published until #6839 is fixed. Kernel updates invoke update-grub2 so that bug will trigger then.
Comment 3 Vladimir Potapov 2016-03-14 18:00:14 MSK
new error messages in log:
мар 14 21:55:14 DNS-R7-X64 systemd[1]: Dependency failed for Kernel Samepage Merging (KSM) Tuning Daemon.
мар 14 21:55:14 DNS-R7-X64 systemd[1]: Job ksmtuned.service/start failed with result 'dependency'.
мар 14 21:55:14 DNS-R7-X64 systemd[1]: Unit ksm.service entered failed state.
мар 14 21:55:14 DNS-R7-X64 systemd[1]: ksm.service failed.
Comment 4 Eugene Shatokhin 2016-03-14 20:14:46 MSK
Please provide either the full output of 'journalctl -ab' or, better, upload the logs with hw-probe after the problem happens.
Comment 5 Vladimir Potapov 2016-03-15 04:48:53 MSK
(In reply to comment #4)
> Please provide either the full output of 'journalctl -ab' or, better, upload
> the logs with hw-probe after the problem happens.
Sorry, it's qemu issue.
Comment 6 Eugene Shatokhin 2016-03-15 11:42:10 MSK
(In reply to comment #3)
> new error messages in log:
> мар 14 21:55:14 DNS-R7-X64 systemd[1]: Dependency failed for Kernel Samepage
> Merging (KSM) Tuning Daemon.
> мар 14 21:55:14 DNS-R7-X64 systemd[1]: Job ksmtuned.service/start failed
> with result 'dependency'.
> мар 14 21:55:14 DNS-R7-X64 systemd[1]: Unit ksm.service entered failed state.
> мар 14 21:55:14 DNS-R7-X64 systemd[1]: ksm.service failed.

OK, I reproduced this on my machine.

This one is not related to the kernel but rather comes from QEMU.

-------------------
# systemctl status ksm
ksm.service - Kernel Samepage Merging
   Loaded: loaded (/lib/systemd/system/ksm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Пт 2016-03-11 23:47:55 MSK; 3 days ago
  Process: 3772 ExecStart=/usr/libexec/ksmctl start (code=exited, status=203/EXEC)
 Main PID: 3772 (code=exited, status=203/EXEC)

мар 11 23:47:51 x230 systemd[1]: Starting Kernel Samepage Merging...
мар 11 23:47:51 x230 systemd[3772]: Failed at step EXEC spawning /usr/libexec/ksmctl: No such file or directory
мар 11 23:47:55 x230 systemd[1]: ksm.service: main process exited, code=exited, status=203/EXEC
мар 11 23:47:55 x230 systemd[1]: Failed to start Kernel Samepage Merging.
мар 11 23:47:55 x230 systemd[1]: Unit ksm.service entered failed state.
мар 11 23:47:55 x230 systemd[1]: ksm.service failed.
-------------------

ksm.service failed because there is no /usr/libexec/ksmctl. The file should be provided by "qemu" package but is missing for some reason. Perhaps something broke during rebuild of the QEMU's packages. I will look into it later.
Comment 7 Vladimir Potapov 2016-03-16 15:58:10 MSK
The update is sent to expanded testing
**************************************
Comment 8 Vladimir Potapov 2016-03-21 16:59:30 MSK
kernel-4.1.19-2
https://abf.io/build_lists/2627082
https://abf.io/build_lists/2627083
************************** Advisory ****************************
The kernel was updated to version 4.1.19 with lots of fixes all-around. In addition to upstream changes, the following fixes and enhancements were made:
1) CONFIG_INTEL_IOMMU_DEFAULT_ON option as well as a few others were disabled: they might have caused boot problems;
2) WiFi hard-block issues on some HP laptops were fixed;
3) AUFS was updated to version "4.1.13+-20160223".
****************************************************************
QA Verified