Bug 6821 - perl-Net-DNS conflict
: perl-Net-DNS conflict
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 21:09 MSK by Zombie Ryushu
Modified: 2016-03-09 00:12 MSK (History)
1 user (show)

See Also:
RPM Package: dnssec-tools
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-03-08 21:09:24 MSK
Installation failed:    file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/CDNSKEY.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/CDS.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/DLV.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/DNSKEY.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/DS.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/KEY.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/NSEC.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/NSEC3.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/NSEC3PARAM.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/RRSIG.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch
        file /usr/lib/perl5/vendor_perl/5.18.2/Net/DNS/RR/SIG.pm from install of perl-Net-DNS-1.40.0-1.noarch conflicts with file from package perl-Net-DNS-SEC-0.220.0-1.noarch

To satisfy dependencies, the following 3 packages will be removed (5.3MB):
  dnssec-tools-2.0-2-rosa2014.1.x86_64
   (due to missing perl(Net::DNS::SEC),
    due to missing perl(Net::DNS::SEC::Tools::BootStrap),
    due to missing perl(Net::DNS::SEC::Tools::Donuts::Rule),
    due to missing perl(Net::DNS::SEC::Tools::QWPrimitives),
    due to missing perl(Net::DNS::SEC::Tools::TrustAnchor),
    due to missing perl(Net::DNS::SEC::Tools::conf),
    due to missing perl(Net::DNS::SEC::Tools::defaults),
    due to missing perl(Net::DNS::SEC::Tools::dnssectools),
    due to missing perl(Net::DNS::SEC::Tools::keyrec),
    due to missing perl(Net::DNS::SEC::Tools::realm),
    due to missing perl(Net::DNS::SEC::Tools::realmmgr),
    due to missing perl(Net::DNS::SEC::Tools::rolllog),
    due to missing perl(Net::DNS::SEC::Tools::rollmgr),
    due to missing perl(Net::DNS::SEC::Tools::rollrec),
    due to missing perl(Net::DNS::SEC::Tools::timetrans),
    due to missing perl(Net::DNS::SEC::Tools::tooloptions),
    due to missing perl(Net::DNS::SEC::Validator),
    due to missing perl(Net::DNS::ZoneFile::Fast),
    due to unsatisfied perl-dnssec-tools >= 2.0)
  perl-Net-DNS-SEC-0.220.0-1-rosa2014.1.noarch
  perl-dnssec-tools-2.0-2-rosa2014.1.x86_64
   (due to missing perl(Net::DNS::RR::DS))
Comment 1 Denis Silakov 2016-03-09 00:12:43 MSK
Fixed in updated perl-Net-DNS-SEC