Bug 6817 - vbam 2.0 beta "Throttle" with WX and Game Link support.
: vbam 2.0 beta "Throttle" with WX and Game Link support.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://github.com/visualboyadvance-m...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-08 12:26 MSK by Zombie Ryushu
Modified: 2017-05-05 12:09 MSD (History)
2 users (show)

See Also:
RPM Package: vbam
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-03-08 12:26:28 MSK
vbam needs to be recompiled with WX Support and Link Cable support. It should likely be imported from Suse as vbam 2.0 beta 2. This version has Game Link support and support for interfacing with Dolphin Emu.
Comment 1 Zombie Ryushu 2017-05-03 09:47:00 MSD
There is a regression in this build. Super Game Boy Support does not function.
Comment 2 Zombie Ryushu 2017-05-03 16:21:30 MSD
From upstream:

Yeah... Beta 2 is old. Don't use it. We made progress since then.
https://github.com/visualboyadvance-m/visualboyadvance-m/releases/tag/throttle
Comment 3 Andrey Bondrov 2017-05-05 11:10:55 MSD
(In reply to comment #2)
> From upstream:
> 
> Yeah... Beta 2 is old. Don't use it. We made progress since then.
> https://github.com/visualboyadvance-m/visualboyadvance-m/releases/tag/
> throttle

I updated vbam package to 2.0.0-1.throttle.2 release in rosa2016.1 repository. Please test if it works well. If it does, I'll backport it to rosa2014.1.
Comment 4 Zombie Ryushu 2017-05-05 11:30:24 MSD
There is a build error having to do with WX in the build. 

http://file-store.rosalinux.ru/api/v1/file_stores/501f12da62a0f4692b5432f815db0de6394481c9.log?show=true

I'm not sure what's making it do this.
Comment 5 Andrey Bondrov 2017-05-05 11:57:33 MSD
(In reply to comment #4)
> There is a build error having to do with WX in the build. 
> 
> http://file-store.rosalinux.ru/api/v1/file_stores/
> 501f12da62a0f4692b5432f815db0de6394481c9.log?show=true
> 
> I'm not sure what's making it do this.

I guess we cannot backport vbam to rosa2014.1 then...

The only way to solve this issue is to rebuild wxgtk3.0 with disabled STL:

https://abf.rosalinux.ru/import/wxgtk3.0/commit/d0961c2661e05872b84a02ed28288d978707b5d2

But this change makes wxgtk3.0 binary incompatible with current rosa2014.1 build. It means every package that uses wxgtk3.0 should be rebuilt. So I guess we'll just skip vbam backport.

I'll mark this bug as resolved because rosa2016.1 package is up to date now.
Comment 6 Zombie Ryushu 2017-05-05 11:59:28 MSD
What about an SDL Only build without the WX GUI? I don't use the WX GUI.
Comment 7 Andrey Bondrov 2017-05-05 12:07:03 MSD
(In reply to comment #6)
> What about an SDL Only build without the WX GUI? I don't use the WX GUI.

SDL means no GUI, it's much worse than broken Super Game Boy support, IMHO. Likely you should build such package to your personal repository only.
Comment 8 Zombie Ryushu 2017-05-05 12:09:32 MSD
I've contacted the upstream maintainer.