Bug 6744 - [UPDATE REQUEST] firefox 24.4.0 -> 24.8.1
: [UPDATE REQUEST] firefox 24.4.0 -> 24.8.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 14:15 MSK by Andrey Bondrov
Modified: 2016-02-22 14:43 MSK (History)
1 user (show)

See Also:
RPM Package: firefox
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2016-02-18 14:15:45 MSK
New version of Firefox ESR 24.x was released some time ago and it makes sense to update it for Fresh and Marathon. This request is for Marathon version.
Comment 1 Andrey Bondrov 2016-02-18 14:30:31 MSK
Advisory: "Update Firefox to new version 24.8.1"

nss:
https://abf.rosalinux.ru/build_lists/2624730
https://abf.rosalinux.ru/build_lists/2624731

firefox:
https://abf.rosalinux.ru/build_lists/2624732
https://abf.rosalinux.ru/build_lists/2624733

firefox-l10n:
https://abf.rosalinux.ru/build_lists/2624776
https://abf.rosalinux.ru/build_lists/2624777

P.S. Firefox x86_64 build tests failed because of known urpmi bug.
Comment 2 Andrey Bondrov 2016-02-21 05:12:29 MSK
Advisory: "Update NSS to new version 3.21"

nss:
https://abf.rosalinux.ru/build_lists/2625072
https://abf.rosalinux.ru/build_lists/2625073

Advisory: "Update Firefox to new version 24.8.1. Enable TLS 1.2 support."

firefox:
https://abf.rosalinux.ru/build_lists/2625076
https://abf.rosalinux.ru/build_lists/2625077

firefox-l10n:
https://abf.rosalinux.ru/build_lists/2625098
https://abf.rosalinux.ru/build_lists/2625099
Comment 3 Andrey Bondrov 2016-02-21 08:42:56 MSK
Advisory: "Update NSS to new version 3.21"

nss:
https://abf.rosalinux.ru/build_lists/2625072
https://abf.rosalinux.ru/build_lists/2625073

Advisory: "Update Firefox to new version 24.8.1. Enable TLS 1.2 support. Enable TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 and TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 support"

firefox:
https://abf.rosalinux.ru/build_lists/2625100
https://abf.rosalinux.ru/build_lists/2625101

firefox-l10n:
https://abf.rosalinux.ru/build_lists/2625102
https://abf.rosalinux.ru/build_lists/2625103
Comment 4 Vladimir Potapov 2016-02-21 18:25:31 MSK
You forgot TLS 1.2 enable
security.tls.version.max = 3
security.tls.version.min = 1

if I change the parameters manually, cdn.rosalinux.ru open correct and https://www.ssllabs.com/ssltest/viewMyClient.html say OK.
Comment 5 Andrey Bondrov 2016-02-22 04:46:46 MSK
(In reply to comment #4)
> You forgot TLS 1.2 enable
> security.tls.version.max = 3
> security.tls.version.min = 1

Just for a record, I didn't forget to adjust these settings in prefs.js. It was just a wrong place to adjust them. Fixed build lists:

Advisory: "Update NSS to new version 3.21"

nss:
https://abf.rosalinux.ru/build_lists/2625072
https://abf.rosalinux.ru/build_lists/2625073

Advisory: "Update Firefox to new version 24.8.1. Enable TLS 1.2 support. Enable TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 and TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 support"

firefox:
https://abf.rosalinux.ru/build_lists/2625128
https://abf.rosalinux.ru/build_lists/2625129

firefox-l10n:
https://abf.rosalinux.ru/build_lists/2625150
https://abf.rosalinux.ru/build_lists/2625151
Comment 6 Vladimir Potapov 2016-02-22 07:51:15 MSK
nss-3.21-1
https://abf.rosalinux.ru/build_lists/2625072
https://abf.rosalinux.ru/build_lists/2625073

firefox-24.8.1-4
https://abf.rosalinux.ru/build_lists/2625128
https://abf.rosalinux.ru/build_lists/2625129

firefox-l10n-24.8.1-1
https://abf.rosalinux.ru/build_lists/2625150
https://abf.rosalinux.ru/build_lists/2625151
********************** Advisory ***************************
Update NSS to new version 3.21
Update Firefox to new version 24.8.1. Enable TLS 1.2 support. Enable TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256 and TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 support
***********************************************************
QA Verified