Bug 6720 - [UPDATE REQUEST] gns3
: [UPDATE REQUEST] gns3
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-12 09:21 MSK by Zombie Ryushu
Modified: 2016-03-14 16:59 MSK (History)
2 users (show)

See Also:
RPM Package: gns3
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2016-02-12 09:21:13 MSK
I request an update to GNS3 to whatever the latest version availible is.
Comment 1 Zombie Ryushu 2016-02-12 09:24:12 MSK
I think thats 1.3.13
Comment 2 Zombie Ryushu 2016-02-25 06:53:58 MSK
Update, while GNS3 Functions, it seems to have trouble enuerating DynaMips Support. A newer version needs to be pulled from OpenSuse. It should be compiled to link to VirtualBox and WireShark.
Comment 3 Zombie Ryushu 2016-02-26 12:00:45 MSK
gns, gns3-server, and gns3-converter are all packaged, however they fail tests because the underlying Python modules python3-raven, python3-aiohttp, and several others are not packaged.
Comment 4 Zombie Ryushu 2016-02-27 12:12:28 MSK
gns3-server, and gns3-converter builds and publishes
Comment 5 Zombie Ryushu 2016-02-27 13:45:45 MSK
gns3 is still failing tests. can someone do a controlled experiment on this? I have met all dependencies
Comment 6 Zombie Ryushu 2016-02-27 17:19:52 MSK
There are some version mismatch issues created by Python 3 vs. Python 2 modules being installed such as: 
pkg_resources DistributionNotFound: The 'paramiko>=1.15.1' distribution was not found and is required by gns3

This happens because only Python 2 is installed and GNS3 is a Python 3 Application.
Comment 7 Denis Silakov 2016-02-27 18:30:00 MSK
We didn't have python3-paramiko. I have pushed it to repos a moment ago.
Comment 8 Zombie Ryushu 2016-02-28 01:51:54 MSK
(In reply to comment #7)
> We didn't have python3-paramiko. I have pushed it to repos a moment ago.

It succeeded on i586 and failed on x86_64
Comment 9 Zombie Ryushu 2016-02-28 05:37:53 MSK
  File "/usr/bin/gns3", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3102, in <module>
    @_call_aside
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3088, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 3115, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 658, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 959, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.4/site-packages/pkg_resources/__init__.py", line 846, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'paramiko>=1.15.1' distribution was not found and is required by gns3-gui
Comment 10 Zombie Ryushu 2016-02-29 04:27:57 MSK
It builds but its complaning pyqt5 is now required.
Comment 11 Zombie Ryushu 2016-02-29 04:31:55 MSK
Its working, but python3-qt5 will be required
Comment 12 Denis Silakov 2016-03-14 16:49:19 MSK
I've pushed new gns3 to our repos. It would be nice for smb to check it; can't do it for myself by now since I have a mess of python 3.4/3.5 modules on my machine.
Comment 13 Zombie Ryushu 2016-03-14 16:58:10 MSK
It does actually function, some configuration adjustments have to be made, but it is able to run Cisco IOS Images via Dynamips, and PC Images via Virtual box. I consider this a complete success.