Bug 6675 - [UPDATE REQUEST] sound-juicer 3.17.90 -> 3.18.1
: [UPDATE REQUEST] sound-juicer 3.17.90 -> 3.18.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-03 19:29 MSK by Giovanni Mariani
Modified: 2016-02-29 18:42 MSK (History)
2 users (show)

See Also:
RPM Package: sound-juicer
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
Log of a session with sound-juicer (7.18 KB, text/plain)
2016-02-17 22:17 MSK, Giovanni Mariani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-02-03 19:29:47 MSK
New release of sound-juicer for GNOME: 3.18.1
Comment 1 Giovanni Mariani 2016-02-03 19:31:40 MSK
Advisory: update sound-juicer to release 3.18.1

Packages for Main:
https://abf.rosalinux.ru/build_lists/2622055
https://abf.rosalinux.ru/build_lists/2622056
Comment 2 Vladimir Potapov 2016-02-17 16:53:36 MSK
The program don't play my CD (ROMP and VLC work correct)
Comment 3 Vladimir Potapov 2016-02-17 16:54:24 MSK
(In reply to comment #2)
> The program don't play my CD (ROMP and VLC work correct)
i.e. don't work with my CD
Comment 4 Giovanni Mariani 2016-02-17 18:54:29 MSK
(In reply to comment #3)
> (In reply to comment #2)
> > The program don't play my CD (ROMP and VLC work correct)
> i.e. don't work with my CD
Hmm...
It more or less works, here.
How are you trying to run the CD play? AFAICT there is no autoplay...

On my PC, with our actual release (3.17.90):
* Selecting all tracks (button on the bottom right) + Play button => OK
* Selecting none + Play button => OK (ie no playing)
* Double-cliking on a track => OK (and continue playing the next selected tracks)

With the new one:
* Selecting all tracks (button on the bottom right) + Play button => no results
* Selecting none + Play button => OK (ie no playing)
* Double-cliking on a track => OK (and continue playing the next selected tracks)

Are you doing the first of the above actions?
If so, it looks like we could have a bug here, albeit mitigated by the existence of an easy workaround (action 3 above)...
Is that enough to allow publishing or have we to wait for news from upstream?
(A quick look on the GNOME bugzilla does not show bugs about the above thing)
Comment 5 Vladimir Potapov 2016-02-17 19:04:41 MSK
It's bug https://bugs.launchpad.net/ubuntu/+source/sound-juicer/+bug/627008
I reproduce it on new installed Fresh R7 KDE
workaround (gvfs-mount cdda://sr0) fix the bug
Comment 6 Giovanni Mariani 2016-02-17 22:17:24 MSK
Created attachment 4396 [details]
Log of a session with sound-juicer
Comment 7 Giovanni Mariani 2016-02-17 22:19:33 MSK
(In reply to comment #6)
> Created attachment 4396 [details]
> Log of a session with sound-j
(In reply to comment #5)
> It's bug https://bugs.launchpad.net/ubuntu/+source/sound-juicer/+bug/627008
> I reproduce it on new installed Fresh R7 KDE
> workaround (gvfs-mount cdda://sr0) fix the bug
I'm not seeing this happening on my PC: the program starts and reads the CD well, populating the track list on the main window...

The only glitch I'm seeing is the one I wrote about above...
Comment 8 Giovanni Mariani 2016-02-17 23:07:55 MSK
(In reply to comment #5)
> It's bug https://bugs.launchpad.net/ubuntu/+source/sound-juicer/+bug/627008
> I reproduce it on new installed Fresh R7 KDE
> workaround (gvfs-mount cdda://sr0) fix the bug
Perhaps does it need some gvfs-* packages not installed by default?
In my system (where I don't have this error), I have:
lib64gvfs0-1.24.1-1-rosa2014.1.x86_64
gvfs-fuse-1.24.1-1-rosa2014.1.x86_64
gvfs-archive-1.24.1-1-rosa2014.1.x86_64
gvfs-gphoto2-1.24.1-1-rosa2014.1.x86_64
gvfs-1.24.1-1-rosa2014.1.x86_64
gvfs-smb-1.24.1-1-rosa2014.1.x86_64
gvfs-mtp-1.24.1-1-rosa2014.1.x86_64

And you?
Comment 9 Vladimir Potapov 2016-02-18 15:49:23 MSK
rpm -qa|grep gvfs
lib64gvfs0-1.24.1-1-rosa2014.1.x86_64
gvfs-1.24.1-1-rosa2014.1.x86_64
gvfs-mtp-1.24.1-1-rosa2014.1.x86_64
gvfs-smb-1.24.1-1-rosa2014.1.x86_64
gvfs-archive-1.24.1-1-rosa2014.1.x86_64
gvfs-fuse-1.24.1-1-rosa2014.1.x86_64
gvfs-gphoto2-1.24.1-1-rosa2014.1.x86_64
Comment 10 Giovanni Mariani 2016-02-18 22:30:43 MSK
(In reply to comment #9)
> rpm -qa|grep gvfs
> lib64gvfs0-1.24.1-1-rosa2014.1.x86_64
> gvfs-1.24.1-1-rosa2014.1.x86_64
> gvfs-mtp-1.24.1-1-rosa2014.1.x86_64
> gvfs-smb-1.24.1-1-rosa2014.1.x86_64
> gvfs-archive-1.24.1-1-rosa2014.1.x86_64
> gvfs-fuse-1.24.1-1-rosa2014.1.x86_64
> gvfs-gphoto2-1.24.1-1-rosa2014.1.x86_64
So no differences here...
Launching sj with SJ_DEBUG=playing or SJ_DEBUG=cd env set does it show something of interest?
Comment 11 Vladimir Potapov 2016-02-24 20:09:16 MSK
(In reply to comment #10)
> (In reply to comment #9)
> > rpm -qa|grep gvfs
> > lib64gvfs0-1.24.1-1-rosa2014.1.x86_64
> > gvfs-1.24.1-1-rosa2014.1.x86_64
> > gvfs-mtp-1.24.1-1-rosa2014.1.x86_64
> > gvfs-smb-1.24.1-1-rosa2014.1.x86_64
> > gvfs-archive-1.24.1-1-rosa2014.1.x86_64
> > gvfs-fuse-1.24.1-1-rosa2014.1.x86_64
> > gvfs-gphoto2-1.24.1-1-rosa2014.1.x86_64
> So no differences here...
> Launching sj with SJ_DEBUG=playing or SJ_DEBUG=cd env set does it show
> something of interest?

I see two new messages:

Media is not an audio CD
Media added to device /dev/sr0
Comment 12 Vladimir Potapov 2016-02-24 20:42:25 MSK
Oh! The program work correct with gnome R7!
Comment 13 Vladimir Potapov 2016-02-24 20:43:23 MSK
The update is sent to expanded testing
**************************************
Comment 14 Vladimir Potapov 2016-02-29 18:35:41 MSK
sound-juicer-3.18.1-1
https://abf.rosalinux.ru/build_lists/2622055
https://abf.rosalinux.ru/build_lists/2622056
************************** Advisory ********************************
update sound-juicer to release 3.18.1
********************************************************************
QA Verified