Bug 6602 - [UPDATE REQUEST] mpg123 1.15.4 -> 1.22.4
: [UPDATE REQUEST] mpg123 1.15.4 -> 1.22.4
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 19:39 MSK by Giovanni Mariani
Modified: 2016-02-16 16:19 MSK (History)
2 users (show)

See Also:
RPM Package: mpg123
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-01-18 19:39:13 MSK
We are a couple of years behind...
New release for mpg123: 1.22.4

Changes since our 1.15.4:
* added configs for vintage CPUs utilizing C or assembly DCT36
* added support for ID3v2 APIC frames
* added FORMAT command to generic control
* added tinyalsa Output (by Jarno Lehtinen)
* Support float and 32/24 bit integer output also with fixed-point decoders
* A-Law output encoding is actually implemented now
* Rework Xing/Info/Lame tag parsing, also detecting short ones without the TOC now
* Fix chopped-off playback with pulseaudio output
* SDL output fixup
* Fix integer code to 32 bit numbers where it would waste 64 bit on modern systems
* Fixed bugs #201-207; 201; 212; 214-216
* Fix regression since 1.14.1 in free format support.
Comment 1 Giovanni Mariani 2016-01-18 19:40:39 MSK
Advisory: update mpg123 to release 1.22.4

Packages (published on Testing):
https://abf.rosalinux.ru/build_lists/2619625
https://abf.rosalinux.ru/build_lists/2619626
Comment 2 Vladimir Potapov 2016-02-10 13:54:18 MSK
The update is sent to expanded testing
***************************************
Comment 3 Vladimir Potapov 2016-02-16 14:22:06 MSK
mpg123-1.22.4-1
https://abf.rosalinux.ru/build_lists/2619625
https://abf.rosalinux.ru/build_lists/2619626
************************** Advisory ******************************
update mpg123 to release 1.22.4
******************************************************************
QA Verified