Bug 6591 - [UPDATE REQUEST] guayadeque 0.3.5 -> 0.3.7
: [UPDATE REQUEST] guayadeque 0.3.5 -> 0.3.7
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 21:58 MSK by Giovanni Mariani
Modified: 2016-02-09 14:13 MSK (History)
2 users (show)

See Also:
RPM Package: guayadeque
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-01-16 21:58:23 MSK
New release 0.3.7 for guayedeque.

Since 0.3.5:
- cleaned interface
- added mpris 2.2  and TuneIn radio support
- added options to rename podcast channel name and to write the complete output pipeline
- added Seeked mpris2 signal
- various fixes: audio output autoconfiguring option, load tracks from command line or file manager, amazon cover download engine.
Comment 1 Giovanni Mariani 2016-01-16 22:00:11 MSK
Advisory: update guayadeque music player to release 0.3.7.

Packages (published on Testing):
https://abf.rosalinux.ru/build_lists/2619355
https://abf.rosalinux.ru/build_lists/2619356
Comment 2 Vladimir Potapov 2016-02-03 19:05:57 MSK
The program segfault (press "stop" button if radio play). 
It's no regression (previous version segfault too) but... maybe it will fix?
Comment 3 Giovanni Mariani 2016-02-03 20:44:44 MSK
(In reply to comment #2)
> The program segfault (press "stop" button if radio play). 
> It's no regression (previous version segfault too) but... maybe it will fix?
It segfaults also for other sources: looks like it's the pression of the "stop" thing the culprit (the stop-at-the-end option works)...
There is also an open ticket about this on the program site:
https://sourceforge.net/p/guayadeque/bugs-reports/140/
but it does not seem to have a lot of recent activity.

By looking at the code repository, however, I found a commit looking promising:
I will try a build with it...
Comment 4 Giovanni Mariani 2016-02-03 21:47:47 MSK
> By looking at the code repository, however, I found a commit looking
> promising:
> I will try a build with it...
Abf is going nuts: No space left on device @ fptr_finalize...
So I can give you only the i586 build to try:
https://abf.rosalinux.ru/build_lists/2622075

However the x86_64 one I built here does not crash anymore when pressing "stop".
Comment 5 Giovanni Mariani 2016-02-04 00:41:33 MSK
(In reply to comment #4)
And here is the x86_64 build to test:
https://abf.rosalinux.ru/build_lists/2622120
Comment 6 Vladimir Potapov 2016-02-05 12:59:50 MSK
The update is sent to expanded testing
**************************************
Comment 7 Vladimir Potapov 2016-02-09 14:02:18 MSK
guayadeque-0.3.7-2
https://abf.rosalinux.ru/build_lists/2622075
https://abf.rosalinux.ru/build_lists/2622120
***************************** Advisory *****************************
update guayadeque music player to release 0.3.7
********************************************************************
QA Verified