Bug 6589 - [UPDATE REQUEST] espeak 1.46.02 -> 1.48.04
: [UPDATE REQUEST] espeak 1.46.02 -> 1.48.04
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 18:14 MSK by Giovanni Mariani
Modified: 2016-02-01 19:21 MSK (History)
3 users (show)

See Also:
RPM Package: espeak
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-01-16 18:14:25 MSK
We are a couple of years behind...

New since 1.46.02:
- added languages: Aragonese, Basque, Farsi, Irish, Lithuanian, Malay, Punjabi.
- Many language improvements.
- A few bugs fixed.
Comment 1 Giovanni Mariani 2016-01-16 18:19:14 MSK
Advisory: update espeak to release 1.48.04.

I left alone the dictionaries for Russian and Chinese (cannot read or speak them): perhaps do those need an update?

Packages (published on Testing):
https://abf.rosalinux.ru/build_lists/2619325
https://abf.rosalinux.ru/build_lists/2619326
Comment 2 Vladimir Potapov 2016-01-28 17:57:24 MSK
The updates is sent to expanded testing
****************************************
Comment 3 Vladimir Potapov 2016-01-30 12:02:35 MSK
Update fail:

станавливается lib64espeak1-1.48.04-1-rosa2014.1.x86_64.rpm espeak-1.48.04-1-rosa2014.1.x86_64.rpm из /var/cache/urpmi/rpms
warning: LOOP:
warning: not removing espeak-1.48.04-1.x86_64 "Requires(auto): libespeak.so.1()(64bit)" from tsort relations.
warning: removing lib64espeak1-1.48.04-1.x86_64 "Requires: espeak >= 1.48.04" from tsort relations.
warning: LOOP:
warning: removing espeak-1.46.02-4.x86_64 "Requires: espeak >= 1.46.02" from tsort relations.
warning: not removing lib64espeak1-1.46.02-4.x86_64 "Requires(auto): libespeak.so.1()(64bit)" from tsort relations.
Подготовка...                    ################################################################################################################################################################################
      1/2: lib64espeak1          ################################################################################################################################################################################
      2/2: espeak                ################################################################################################################################################################################
error: распаковка архива не удалась на файле /usr/share/espeak-data/voices/en: cpio: renameне удалось - Это каталог
ERROR: 'unpack' failed for espeak-1.48.04-1-rosa2014.1.x86_64: 
      1/2: удаляется espeak-1.46.02-4.x86_64
Comment 4 Denis Silakov 2016-01-30 12:28:15 MSK
New build lists (fixed replacing folder with a file):

https://abf.io/build_lists/2621382
https://abf.io/build_lists/2621383
Comment 5 Vladimir Potapov 2016-01-30 12:34:35 MSK
(In reply to comment #4)
> New build lists (fixed replacing folder with a file):
> 
> https://abf.io/build_lists/2621382
> https://abf.io/build_lists/2621383
Please, up release
Comment 7 Vladimir Potapov 2016-01-30 13:43:14 MSK
The update is sent to expanded testing
**************************************
Comment 8 Vladimir Potapov 2016-02-01 16:55:34 MSK
espeak-1.48.04-2
https://abf.io/build_lists/2621390
https://abf.io/build_lists/2621391
****************************** Advisory ****************************
update espeak to release 1.48.04
********************************************************************
QA Verified