Bug 6573 - [UPDATE REQUEST] mpd 0.19.9 -> 0.19.12
: [UPDATE REQUEST] mpd 0.19.9 -> 0.19.12
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High major
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 20:32 MSK by Giovanni Mariani
Modified: 2016-02-10 12:13 MSK (History)
2 users (show)

See Also:
RPM Package: mpd
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
ss (193.72 KB, image/png)
2016-01-29 12:49 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni Mariani 2016-01-13 20:32:40 MSK
New release of mpd (0.19.12).
Updated some BReqs and enabled support for avahi and soxr.
Comment 1 Giovanni Mariani 2016-01-13 20:35:20 MSK
Advisory: "Update mpd to new release 0.19.12".

Main (published on testing):
https://abf.rosalinux.ru/build_lists/2618330
https://abf.rosalinux.ru/build_lists/2618331

Restricted:
https://abf.rosalinux.ru/build_lists/2618338
https://abf.rosalinux.ru/build_lists/2618339
Comment 2 Giovanni Mariani 2016-01-14 00:40:04 MSK
Cancelling the QA request.
Found a way to make the build not fail when enabling the support for mad files.
See http://bugs.musicpd.org/view.php?id=4484.

Stay tuned...
Comment 3 Giovanni Mariani 2016-01-14 00:54:44 MSK
Advisory:
Update mpd to new release 0.19.12
Fix build and enable mad support
Bump release.

Main (published on testing):
https://abf.rosalinux.ru/build_lists/2618409
https://abf.rosalinux.ru/build_lists/2618410

Restricted:
https://abf.rosalinux.ru/build_lists/2618411
https://abf.rosalinux.ru/build_lists/2618412
Comment 4 Vladimir Potapov 2016-01-14 18:40:04 MSK
Hm, I can't play music by mpd (by cantata) on x64 system (i586  - OK).
Do you test x64?
Comment 5 Giovanni Mariani 2016-01-14 21:18:32 MSK
(In reply to comment #4)
> Hm, I can't play music by mpd (by cantata) on x64 system (i586  - OK).
> Do you test x64?

Yes, always before sending QA request: I only used gmpc, not cantata...

Indeed, launching cantata in a konsole fails with undefined symbol error:
cantata: symbol lookup error: cantata: undefined symbol: _ZN9QGtkStyle14getGConfStringERK7QStringS2_

We need to rebuild it, I guess...
Comment 6 Denis Silakov 2016-01-19 16:15:02 MSK
It looks like a problem in cantata, not in mpd. QGtkStyle is no longer defined in new Qt versions (see for example bug 6558).

So I suggest to push this mpd to testing and update/fix cantata in separate bug.
Comment 7 Giovanni Mariani 2016-01-19 17:30:47 MSK
(In reply to comment #6)
> It looks like a problem in cantata, not in mpd. QGtkStyle is no longer
> defined in new Qt versions (see for example bug 6558).
> 
> So I suggest to push this mpd to testing and update/fix cantata in separate
> bug.
Yeah. I have locally rebuilt cantata with the new package from bug #6558 and it WFM with the proposed mpd.
Comment 8 Denis Silakov 2016-01-19 18:17:24 MSK
One can try to use cantata from these containers:

(cantata)
https://abf.io/build_lists/2619793
https://abf.io/build_lists/2619794
Comment 9 Vladimir Potapov 2016-01-29 12:49:53 MSK
Created attachment 4363 [details]
ss

For me, current cantata (2.0) work only with free (no plf) version of mpd
Please, fix it!
*********************
QA Denied
Comment 10 Giovanni Mariani 2016-01-30 23:26:23 MSK
Sorry for the late reply (I was away from my PC for some days).

Vladimir, I cannot reproduce your failure:
both mpd versions of mpd work fine for me (gmpc and the latest cantata tested).

To configure my mpd server I used this handy script (mpd-configure) from
http://lacocina.nl: it gave me the corrections to do at the provided mpd.conf file and all went well at the first try.

However I noticed that the new release refused to start the first time I tried because of an invalid zeroconf_name, so I had to correct this, but after that all was well.
Since the zeroconf_name causing trouble was perfectly OK with our previous release of mpd, perhaps you are hitting something of similar (and your mpd.log should tell you what is...)

Te be sure we need more infos:
* how is configured your mpd (mpd.conf)? 

* running mpd from a console (with systemctl) prints something of interesting?

* your mpd.log says something about that failure (perhaps after setting "verbose" for the output level in the mpd.conf file)?

* And journalctl?
Comment 11 Vladimir Potapov 2016-02-01 13:04:21 MSK
I don't config mpd manually, I install cantata and run it. (Rosa fresh must be user-frendly :-)
Oh! I found the issue.
mpd daemon start after install, but don't start on boot. I reboot for testing and found error message :-)
Comment 12 Giovanni Mariani 2016-02-01 15:14:58 MSK
(In reply to comment #11)
> I don't config mpd manually, I install cantata and run it. (Rosa fresh must
> be user-frendly :-)
In my little experience I never got mpd to start without a little massaging of mpd.conf... perhaps I have only bad luck.
Anyway this is UNIX not Windows: so there is always a limit in the user-friendlyness of the things :-)

> Oh! I found the issue.
> mpd daemon start after install, but don't start on boot.
This is normal, IMO: in the specfile we don't do nothing to activate mpd at startup time; we only install the systemd unit files... To actually activate it at boot time we shoul add something in a %post section (and provide a %preun/%postun one as well).

Is that a desired feature for our package? If so I can modify mpd.spec to actually made the server to always start at boot time.
However please notice that the above is really useless: mpd comes with a .socket systemd unit file and this allow mpd to always start on-demand, as soon a client tries to connect to the server...
I disable the .service unit and go happy with the .socket one.

> I reboot for
> testing and found error message :-)
And what is the error message? The same I got about zeroconf_name?
Comment 13 Giovanni Mariani 2016-02-09 14:48:32 MSK
Ping @Vladimir...
What must I do to proceed with the update?
I would like to see the thing landing...
Comment 14 Vladimir Potapov 2016-02-10 10:01:29 MSK
OK, I surrender :-)

mpd-0.19.12-2
https://abf.rosalinux.ru/build_lists/2618409
https://abf.rosalinux.ru/build_lists/2618410

mpd-0.19.12-2plf
https://abf.rosalinux.ru/build_lists/2618411
https://abf.rosalinux.ru/build_lists/2618412
************************* Advisory ****************************
Update mpd to new release 0.19.12
Fix build and enable mad support
***************************************************************
QA Verified