Bug 6410 - Lenovo G480 ( Qualcomm Atheros AR8162 ) wired connection not working after update kernel 4.1
: Lenovo G480 ( Qualcomm Atheros AR8162 ) wired connection not working after up...
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: Groups for solving hardware issues.
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 04:01 MSK by Fabiano Kuller
Modified: 2016-03-10 22:48 MSK (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Kuller 2015-12-04 04:01:47 MSK
ethernet connection was working, then later a kernel to 4.1 update was happened thats all my wired connection stopped working.

But still I am able to connect wifi.
Comment 1 Eugene Shatokhin 2015-12-04 10:25:11 MSK
First of all, please upload the info and the logs from that system using hw-probe (http://hw.rosalinux.ru/index.php?show=check).

Without that info, there is little we can do.
Comment 2 Fabiano Kuller 2015-12-04 15:16:29 MSK
(In reply to comment #1)
> First of all, please upload the info and the logs from that system using
> hw-probe (http://hw.rosalinux.ru/index.php?show=check).
> 
> Without that info, there is little we can do.



link to information


http://hw.rosalinux.ru/index.php?probe=b96ea140cf#Devices

Thank you
Comment 3 Eugene Shatokhin 2015-12-04 16:38:58 MSK
(In reply to comment #2)
> http://hw.rosalinux.ru/index.php?probe=b96ea140cf#Devices

Thanks.

Now, if you select the previous kernel (3.14.x or whatever else is installed and worked OK before) at boot time, does the wired connection work?

Could you send us the data with hw-probe for that boot too?
Comment 4 Fabiano Kuller 2015-12-04 17:15:47 MSK
(In reply to comment #3)
> (In reply to comment #2)
> > http://hw.rosalinux.ru/index.php?probe=b96ea140cf#Devices
> 
> Thanks.
> 
> Now, if you select the previous kernel (3.14.x or whatever else is installed
> and worked OK before) at boot time, does the wired connection work?
> 
> Could you send us the data with hw-probe for that boot too?


now follows with information using the kernel 3.14

http://hw.rosalinux.ru/index.php?probe=b2ab27c63a

thank you
Comment 5 Eugene Shatokhin 2015-12-04 20:41:51 MSK
(In reply to comment #4)
> now follows with information using the kernel 3.14
> 
> http://hw.rosalinux.ru/index.php?probe=b2ab27c63a
> 
> thank you

I see. So the network works well with 3.14 but seems to repeatedly go up and down with 4.1.13.

Might be something with 'alx' driver or the networking in the kernel as a whole.

Assuming the driver is to blame, I could revert the changes made to it since kernel 3.14 (there are only a few). We'll see if it works then.

I will try to do this when I have time. 

In the meantime, you can stick with 3.14.x kernels.

The newer ones from that branch are available in our unofficial repository:
http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/rosa2014.1/x86_64/kernel_3_14/release/
Comment 6 Fabiano Kuller 2015-12-04 20:59:06 MSK
(In reply to comment #5)
> (In reply to comment #4)
> > now follows with information using the kernel 3.14
> > 
> > http://hw.rosalinux.ru/index.php?probe=b2ab27c63a
> > 
> > thank you
> 
> I see. So the network works well with 3.14 but seems to repeatedly go up and
> down with 4.1.13.
> 
> Might be something with 'alx' driver or the networking in the kernel as a
> whole.
> 
> Assuming the driver is to blame, I could revert the changes made to it since
> kernel 3.14 (there are only a few). We'll see if it works then.
> 
> I will try to do this when I have time. 
> 
> In the meantime, you can stick with 3.14.x kernels.
> 
> The newer ones from that branch are available in our unofficial repository:
> http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/
> rosa2014.1/x86_64/kernel_3_14/release/


OK.

Thank you

Eugene
Comment 7 Eugene Shatokhin 2015-12-08 20:03:29 MSK
The issue looks very similar to this one: https://bugzilla.kernel.org/show_bug.cgi?id=70761.

Could you try temporarily increasing MTU, which they suggest as a possible workaround?

As root:
ip link set eth0 mtu 9000

After that, you may need to turn the wired networking off and then on again.
Comment 8 Fabiano Kuller 2015-12-09 15:04:36 MSK
(In reply to comment #7)
> The issue looks very similar to this one:
> https://bugzilla.kernel.org/show_bug.cgi?id=70761.
> 
> Could you try temporarily increasing MTU, which they suggest as a possible
> workaround?
> 
> As root:
> ip link set eth0 mtu 9000
> 
> After that, you may need to turn the wired networking off and then on again.

Ok , it worked.

thank you
Comment 9 Eugene Shatokhin 2015-12-09 16:56:29 MSK
(In reply to comment #8)
> Ok , it worked.
> 
> thank you

So this is probably the same issue as discussed at https://bugzilla.kernel.org/show_bug.cgi?id=70761.

I have built the kernel with the last of the patches listed there, could you try it and see if it fixes things for you too? With the default MTU (1500) of course.

The packages are here:
http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/x86_64/kernel_4_1/release/

The easiest way to install it is probably as follows:

urpmi http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/x86_64/kernel_4_1/release/kernel-nrj-desktop-4.1.13-2testing-x86_64-1-1-rosa2014.1.x86_64.rpm http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/x86_64/kernel_4_1/release/kernel-nrj-desktop-devel-4.1.13-2testing-x86_64-1-1-rosa2014.1.x86_64.rpm
Comment 10 Fabiano Kuller 2015-12-09 18:12:52 MSK
(In reply to comment #9)
> (In reply to comment #8)
> > Ok , it worked.
> > 
> > thank you
> 
> So this is probably the same issue as discussed at
> https://bugzilla.kernel.org/show_bug.cgi?id=70761.
> 
> I have built the kernel with the last of the patches listed there, could you
> try it and see if it fixes things for you too? With the default MTU (1500)
> of course.
> 
> The packages are here:
> http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/
> x86_64/kernel_4_1/release/
> 
> The easiest way to install it is probably as follows:
> 
> urpmi
> http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/
> x86_64/kernel_4_1/release/kernel-nrj-desktop-4.1.13-2testing-x86_64-1-1-
> rosa2014.1.x86_64.rpm
> http://abf-downloads.rosalinux.ru/kernels_stable_personal/container/2605068/
> x86_64/kernel_4_1/release/kernel-nrj-desktop-devel-4.1.13-2testing-x86_64-1-
> 1-rosa2014.1.x86_64.rpm


The test kernel, worked perfectly with MTU 1500 .

approved

Thank you.
Comment 11 Eugene Shatokhin 2015-12-09 20:22:53 MSK
(In reply to comment #10)
> The test kernel, worked perfectly with MTU 1500 .
> 
> approved
> 
> Thank you.

Thanks for testing. Glad the patch helped. 

I will add the patch in our next kernel update if the problem does not appear again by then.
Comment 12 Eugene Shatokhin 2015-12-17 21:12:07 MSK
I have added the fix for alx driver to our packages with kernel 4.1.15, which will become the next kernel update (if it passes our QA).

Could you please check if networking in OK on your system with that kernel too?

The packages for x86_64 are available here:
http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/release/

To install the new kernel, one can use the following command:

urpmi http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/release/kernel-nrj-desktop-4.1.15-1rosa-x86_64-1-1-rosa2014.1.x86_64.rpm http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/release/kernel-nrj-desktop-devel-4.1.15-1rosa-x86_64-1-1-rosa2014.1.x86_64.rpm
Comment 13 Fabiano Kuller 2015-12-17 22:00:53 MSK
(In reply to comment #12)
> I have added the fix for alx driver to our packages with kernel 4.1.15,
> which will become the next kernel update (if it passes our QA).
> 
> Could you please check if networking in OK on your system with that kernel
> too?
> 
> The packages for x86_64 are available here:
> http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/
> release/
> 
> To install the new kernel, one can use the following command:
> 
> urpmi
> http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/
> release/kernel-nrj-desktop-4.1.15-1rosa-x86_64-1-1-rosa2014.1.x86_64.rpm
> http://abf-downloads.rosalinux.ru/rosa2014.1/container/2607760/x86_64/main/
> release/kernel-nrj-desktop-devel-4.1.15-1rosa-x86_64-1-1-rosa2014.1.x86_64.
> rpm

OK, it worked correctly networking.

Thank you.
Comment 14 Eugene Shatokhin 2015-12-18 11:56:33 MSK
(In reply to comment #13)
> OK, it worked correctly networking.
> 
> Thank you.

Great! Thanks for testing.
Comment 15 Eugene Shatokhin 2016-01-03 00:28:51 MSK
The kernel packages containing the fix (kernel version 4.1.15) have been published. 

Closing.
Comment 16 Fabiano Kuller 2016-03-08 16:10:36 MSK
(In reply to comment #15)
> The kernel packages containing the fix (kernel version 4.1.15) have been
> published. 
> 
> Closing.

With kernel 4.1.16 the problem returned, now changing MTU the problem persists.

Thank you
Comment 17 Eugene Shatokhin 2016-03-08 18:11:54 MSK
1. Does the problem show up if you select kernel 4.1.15 at boot time? The previous kernels are not removed automatically, so 4.1.15 should still be avaialble.

2. After the problem happens with kernel 4.1.16, could you upload the data using hw-probe again? Need to take a look at the logs.
Comment 18 Fabiano Kuller 2016-03-10 22:11:40 MSK
(In reply to comment #17)
> 1. Does the problem show up if you select kernel 4.1.15 at boot time? The
> previous kernels are not removed automatically, so 4.1.15 should still be
> avaialble.
> 
> 2. After the problem happens with kernel 4.1.16, could you upload the data
> using hw-probe again? Need to take a look at the logs.

I apologize, I found that the problem is in the university network.

Thank you.
Comment 19 Fabiano Kuller 2016-03-10 22:12:55 MSK
(In reply to comment #18)
> (In reply to comment #17)
> > 1. Does the problem show up if you select kernel 4.1.15 at boot time? The
> > previous kernels are not removed automatically, so 4.1.15 should still be
> > avaialble.
> > 
> > 2. After the problem happens with kernel 4.1.16, could you upload the data
> > using hw-probe again? Need to take a look at the logs.
> 
> I apologize, I found that the problem is in the university network.
> 
> Thank you.

I upgraded to the 4.4 Kernel, I am very satisfied
Comment 20 Eugene Shatokhin 2016-03-10 22:48:06 MSK
(In reply to comment #19)
> > 
> > I apologize, I found that the problem is in the university network.
> > 
> > Thank you.
> 
> I upgraded to the 4.4 Kernel, I am very satisfied

Ah, I see. Great!