Bug 635 - 2012lts printer install bad driver hp 1220
: 2012lts printer install bad driver hp 1220
Status: RESOLVED DUPLICATE of bug 2720
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-12 23:02 MSD by philippe.roubach
Modified: 2015-06-22 13:36 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-08-12 23:02:40 MSD
Description of problem:


switch on the printer
then
system asks to you if you want to install some packets
then
answer "ok"
then
the install runs
then
at the end you have a notification for printing a test page
and
that's finished

go to drakprinter
then
go to the properties of the printer
then
you see the driver is "hp-1220,pcl3, hpcups"

this is the wrong driver

my hp 1220 is a postcript one

my printer got the postscipt extension and the memory extension

more : with postscript extension driver i can set the memory extension
Comment 1 philippe.roubach 2012-08-12 23:07:45 MSD
2012lts x86_64
Comment 2 philippe.roubach 2012-08-13 10:55:19 MSD
with Mageia 2

no pb the good postscript driver is installed
Comment 3 Denis Silakov 2012-08-23 21:10:43 MSD
Can you try to install an updated hplip package? It is not in the repos yet, but can be taken from here:

http://abf.rosalinux.ru/downloads/rosa2012lts/container/hplip-680067/RPMS/
(32bit version)

http://abf.rosalinux.ru/downloads/rosa2012lts/container/hplip-680068/RPMS/
(64bit version)
Comment 4 Denis Silakov 2012-09-04 15:30:48 MSD
Well, updated hplip is now available in repositories. Would be nice to know if it helps to resolve this bug...
Comment 5 Denis Silakov 2012-09-04 15:40:33 MSD
Ok, after updating hplip to 3.12.6, "HP LaserJet 1220 Postscript" driver appears among available drivers for this printer and it will be selected by default when configuring printer for the first time.
Comment 6 philippe.roubach 2012-09-04 16:10:58 MSD
sorry but it is false

i made a test with rosa marathon rp1 64 bit and hplip 3.12.6 the last one

the selected driver is always the pcl one not the ppd one

the ppd is in hplip since almost the very beginning of hplip
it was installed by default without pb with mandriva 2008

it's not a hplip pb it's pb upper in system-config-printer
since 2009.0 the setup of the hp 1220 is broken
if you delete the printer installed in  system-config-printer
then
you use hp device manager to install the printer then a good ppd is installed

i assume there is something in cfp that force the use of pcl driver

more

- unable to print with pcl or ppd one if i use cfg

i found :
-the uri used by hp device manger is :
hp:/usb/HP_LaserJet_1220?serial=00CNCK053755
- the uri used by cfg is
usb://HP/LaserJet%201220?serial=00CNCK053755
Comment 7 Stanislav Fomin 2015-03-06 19:35:29 MSK
Need restesting before releasing Enterprise X2.
Comment 8 Denis Silakov 2015-05-25 21:06:39 MSD
Is it possible to check if this bug is valid for ROSA Desktop Fresh R5?
Comment 9 Denis Silakov 2015-06-22 13:36:31 MSD
Let's join this with bug 2720, since we unlikely will care of it for Marathon, and for RED X2 we use Desktop Fresh as a basis.

*** This bug has been marked as a duplicate of bug 2720 ***