Bug 6337 - Black squares when scrolling on firefox
: Black squares when scrolling on firefox
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-17 16:45 MSK by Fabiano Kuller
Modified: 2015-12-27 16:22 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Black squares when scrolling on firefox (175.19 KB, image/png)
2015-11-17 16:45 MSK, Fabiano Kuller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Kuller 2015-11-17 16:45:31 MSK
Created attachment 4294 [details]
Black squares when scrolling on firefox

Steps to reproduce:

Scroll up and down on random web sites. I have disabled all the plugins and I ran Firefox in safe mode and the bug still reporduces. Thunderbird has a similar issue.


Actual results:

I see black squares that seem to stick to the scroled area.
https://www.youtube.com/watch?v=4hX2ZSWYWUo
Comment 1 Eugene Budanov 2015-12-02 00:24:38 MSK
Same for me. As I can understand, this is upstream bug and it's was fixed in Intel driver. See this, for example: https://bugzilla.mozilla.org/show_bug.cgi?id=939760
Comment 2 Eugene Budanov 2015-12-02 00:25:57 MSK
Sorry for wrong link: https://bugzilla.mozilla.org/show_bug.cgi?id=941826
Comment 3 Fabiano Kuller 2015-12-02 04:35:58 MSK
(In reply to comment #1)
> Same for me. As I can understand, this is upstream bug and it's was fixed in
> Intel driver. See this, for example:
> https://bugzilla.mozilla.org/show_bug.cgi?id=939760

I could solve this way:

switch the graphics subsystem from SNA to UXA mode in file /etc/X11/xorg.conf.d/20-intel.conf


Thank you 

Eugene
Comment 4 Eugene Shatokhin 2015-12-02 13:01:16 MSK
(In reply to comment #3)
> I could solve this way:
> 
> switch the graphics subsystem from SNA to UXA mode in file
> /etc/X11/xorg.conf.d/20-intel.conf

You are right, UXA is more reliable for the current version of the driver.

The updates are in progress but this will take time.
Comment 5 Eugene Budanov 2015-12-26 19:39:33 MSK
After update to new graphic stack problem was solved. Thanks.
Comment 6 Eugene Shatokhin 2015-12-26 20:29:02 MSK
Glad the problem is gone. Closing.
Comment 7 Fabiano Kuller 2015-12-27 16:22:54 MSK
(In reply to comment #5)
> After update to new graphic stack problem was solved. Thanks.

OK.

Thanks Eugene.