Bug 631 - df reports /sys/fs/fuse/connections: No such file or directory
: df reports /sys/fs/fuse/connections: No such file or directory
Status: RESOLVED DUPLICATE of bug 374
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 17:15 MSD by Andrey Ponomarenko
Modified: 2012-08-20 16:16 MSD (History)
1 user (show)

See Also:
RPM Package: coreutils-8.12-5.2-rosa.lts2012.0.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2012-08-09 17:15:24 MSD
The df command from coreutils reports on each call in clear ROSA Marathon 2012 that `/sys/fs/fuse/connections': No such file or directory

$ df -h
df: `/sys/fs/fuse/connections': No such file or directory
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        12G  4.2G  6.8G  39% /
/dev/sda6       2.3G  1.2G  1.1G  52% /home
Comment 1 Denis Silakov 2012-08-17 15:02:02 MSD
Does the problem disappear if you replace /etc/mtab with a symlink to /proc/mounts, e.g.:

rm -f /etc/mtab
ln -s /proc/mounts /etc/mtab

?
Comment 2 Andrey Ponomarenko 2012-08-20 16:12:18 MSD
Yes, it does. But the output has been changed.

Before:

df: `/sys/fs/fuse/connections': No such file or directory
df: `/sys/fs/fuse/connections': No such file or directory
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        12G  4.2G  6.8G  39% /
/dev/sda6       2.3G  1.2G  1.1G  53% /home

After:

Filesystem      Size  Used Avail Use% Mounted on
rootfs           12G  4.2G  6.8G  39% /
devtmpfs        490M     0  490M   0% /dev
tmpfs           503M  244K  502M   1% /dev/shm
tmpfs           503M  2.5M  500M   1% /run
/dev/sda1        12G  4.2G  6.8G  39% /
tmpfs           503M  2.5M  500M   1% /run
tmpfs           503M     0  503M   0% /sys/fs/cgroup
tmpfs           503M     0  503M   0% /media
/dev/sda6       2.3G  1.2G  1.1G  53% /home
Comment 3 Denis Silakov 2012-08-20 16:16:35 MSD
Difference is expected. /etc/mtab as used in ROSA is deprecated, we should use a symlink to /proc/mounts instead, as discussed in bug #374. And "/sys/fs/fuse/connections" appears in /etc/mtab due to the same reasons as duplicated entries in bug #374.

*** This bug has been marked as a duplicate of bug 374 ***