Bug 6272 - mono-4.0 from the repo is actually 3.12
: mono-4.0 from the repo is actually 3.12
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 20:59 MSD by Igor Yakovlev
Modified: 2015-10-12 13:00 MSD (History)
1 user (show)

See Also:
RPM Package: mono-4.0-2.10.9-3-rosa2014.1.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Yakovlev 2015-10-11 20:59:41 MSD
Description of problem:

Installed package mono-4.0 seems to contain JIT 3.12 instead of 4.0. Please, fix the issue.

Version-Release number of selected component (if applicable):

mono-4.0-2.10.9-3-rosa2014.1.x86_64

How reproducible:
checking via mono -V

Steps to Reproduce:
1. # urpmi mono-4.0
2. $ mono -V
Comment 1 Denis Silakov 2015-10-12 13:00:18 MSD
"4.0" in this name doesn't mean mono version. It stands for CLR API version supported by the package.

And if you carefully look at the output of "urpmi mono-4.0" you will notice that urpmi installs "mono-3.12.1-6.rosa2014.1.x86_64" (not "mono-4.0-2.10.9-3-rosa2014.1.x86_64" as suggested in your comment). This comes from the fact that "mono-4.0" is just a virtual provide of that package, not the package version.

I agree that this is confusing. Long ago somebody decided to provide separate subpackages for different CLR API versions (mono-2.0, mono-3.5, mono-4.0). We have dropped subpackages since the but still have virtual provides for backward compatibility. We will remove them in future.

As for your original comment - we just don't have mono version 4.0 at all at the moment. Not sure when we will build it, this package doesn't seem to be very popular and maintainers doesn't pay much attention to it.

I will close this bug as invalid since actually this is not a problem - "urpmi mono-4.0" installs mono version 3.12 and this is expected behavior. Normally you shouldn't call for installation of particular version, just call "urpmi mono" and it will install the latest available version for you. There are several exceptions from this rule (when we really provide separate packages for different versions), but mono is not among them.