Bug 6267 - otter-browser fails to start
: otter-browser fails to start
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 19:45 MSD by Mikhail N
Modified: 2016-04-16 13:53 MSD (History)
3 users (show)

See Also:
RPM Package: otter-browser
ISO-related:
Bad POT generating:
Upstream:


Attachments
otter-browser (115.56 KB, image/jpeg)
2016-03-19 10:03 MSK, Алзим
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail N 2015-10-09 19:45:36 MSD
user@Dom1-Rosa ~ $ otter-browser
Warning: QSqlDatabase: QSQLITE driver not loaded ((null):0, (null))
Warning: QSqlDatabase: available drivers:  ((null):0, (null))
Warning: QSqlQuery::exec: database not open ((null):0, (null))
Warning: QSqlQuery::exec: database not open ((null):0, (null))
Warning: QSqlQuery::exec: database not open ((null):0, (null))
Warning: QSqlQuery::exec: database not open ((null):0, (null))
Warning: QSqlQuery::exec: database not open ((null):0, (null))
Ошибка сегментирования (слепок снят)

otter-browser does not start

KDE 4
Comment 1 Denis Silakov 2015-10-12 15:27:45 MSD
Do you use 32bit or 64bit system? Try to install lib64qt5sql5-sqlite package (libqt5sql5-sqlite for 32bit system) and check if the issue remains.

I have otter-browser 0.9.07 installed on my 64bit ROSA with KDE and it works fine at least doesn't fail at start), so maybe this is just a dependency or configuration problem.
Comment 2 Mikhail N 2015-10-12 16:20:03 MSD
64 бита, 
lib64qt5sql5-sqlite уже и так установлен,
сейчас попробовал, терминал немного другое выдает:

user@Dom1-Rosa ~ $ otter-browser
Ошибка сегментирования (слепок снят)
user@Dom1-Rosa ~ $ /usr/bin/otter-browser
Ошибка сегментирования (слепок снят)
user@Dom1-Rosa ~ $ 

Логов браузера не нашел.
Comment 3 Mikhail N 2015-10-12 16:21:00 MSD
Opera-presto worked fine.
Comment 4 Denis Silakov 2015-10-12 16:24:14 MSD
Логи браузера вряд ли будут, раз он сразу валится. Можно посмотреть на core dump после того, как он упал:

$ coredumpctl dump otter-browser

Скорее всего проблема где-то в Qt5. Либо в наших сборках, либо в том, как otter-browser с ним работает.
Comment 5 Mikhail N 2015-10-12 16:37:25 MSD
user@Dom1-Rosa ~ $ coredumpctl dump otter-browser
           PID: 19395 (otter-browser)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Пн 2015-10-12 15:21:43 MSK (7min ago)
  Command Line: otter-browser
    Executable: /usr/bin/otter-browser
 Control Group: /user.slice/user-500.slice/session-c1.scope
          Unit: session-c1.scope
         Slice: user-500.slice
       Session: c1
     Owner UID: 500 (user)
       Boot ID: 799226e15ac043fe88eb5ac8a9c2e461
    Machine ID: 420c2d9b34224e24ae51d2666628c3b3
      Hostname: Dom1-Rosa
      Coredump: /var/lib/systemd/coredump/core.otter-browser.0.799226e15ac043fe88eb5ac8a9c2e461.19395.1444652503000000.xz
       Message: Process 19395 (otter-browser) of user 0 dumped core.
                
                Stack trace of thread 19395:
                #0  0x0000000000000000 n/a (n/a)
Refusing to dump core to tty.

Coredump: https://yadi.sk/d/dbThiPorjgNfh
Comment 6 symbianflo 2016-03-19 00:15:31 MSK
Since I try to maintain otter I need to understand things, so please guys use englsh, italian,romanian, or hungarian , russian I don't speak , sorry...
I'd like to reproduce your problem .
Latest otter is:
┌─[ symbianflo @ abfonly ] - [ Mandrivausers.ro ] 
└─[ MRB:aint-no-shit $]: otter-browser -v
Otter 0.9.09

did you still encounter the same problems here too?
Comment 7 symbianflo 2016-03-19 00:18:07 MSK
(In reply to comment #6)
> Since I try to maintain otter I need to understand things, so please guys
> use englsh, italian,romanian, or hungarian , russian I don't speak , sorry...
> I'd like to reproduce your problem .
> Latest otter is:
> ┌─[ symbianflo @ abfonly ] - [ Mandrivausers.ro ] 
> └─[ MRB:aint-no-shit $]: otter-browser -v
> Otter 0.9.09
> 
> did you still encounter the same problems here too?


Warning: QSqlQuery::prepare: database not open ((null):0, (null))

it's pretty much harmless, should be something else that you missed to track down.
Comment 8 Алзим 2016-03-19 10:03:57 MSK
Created attachment 4422 [details]
otter-browser
Comment 9 Алзим 2016-03-19 10:07:58 MSK
Стоит у меня этот Выдра-Браузер и стоит на рабочей KDE4, и работает нормально.

(А вот с добавлением Attachments я похоже что-то не так сделал. Я хотел всё в одно сообщение написать: текст и скрин. Это из-за того, что первый раз. Думаю, потом разберусь.)
Comment 10 Denis Silakov 2016-03-19 11:03:46 MSK
For sflo: comment #9 says that otter-browser works fine in KDE4. And actually it works fine for me as well. I think I saw one fault during the last several months but not segfault at every start like the original of this bug stated.
Comment 11 symbianflo 2016-03-19 12:43:38 MSK
(In reply to comment #10)
> For sflo: comment #9 says that otter-browser works fine in KDE4. And
> actually it works fine for me as well. I think I saw one fault during the
> last several months but not segfault at every start like the original of
> this bug stated.

ok , mysql is already abandon so the history is no longer manage by it, 
I'll push a new tag/release next week or so, and pack it.
Anyway , we had a similar dump, can you tell him to try changing the 
kde icon theme in use , maybe oxygen, ( since it's provided by default 
by the iso, so no new packages need to be installed),  if this 
will solve it , from the next release we drop integration with system/qt5
 icons and use the internal provided icon set.
If not , then I need more infos.
Thanks Denis.
Comment 12 symbianflo 2016-03-19 15:25:47 MSK
Also if you like otter and care to help , you can try weekly builds from rosalinuxro, or for this week build :

64 bit    https://abf.rosalinux.ru/build_lists/2627927

32 bit    https://abf.rosalinux.ru/build_lists/2627926

thanks in advance
Comment 13 Denis Silakov 2016-04-13 01:53:25 MSD
Let's finally close as "worksforme". If somebody is able to reproduce the failure, core dump is welcome.
Comment 14 symbianflo 2016-04-13 21:39:59 MSD
(In reply to comment #13)
> Let's finally close as "worksforme". If somebody is able to reproduce the
> failure, core dump is welcome.

With the new arrival of Pulfer's qt5 5.6.0 we can update the old contrib version I'll choose the best weekly build to 
update the contrib package , maybe 119 , 'cose it has russian and italian at 100%
as soon as 119 tarball is out I'll push it in contrib.
Comment 15 symbianflo 2016-04-16 13:53:51 MSD
(In reply to comment #14)
> (In reply to comment #13)
> > Let's finally close as "worksforme". If somebody is able to reproduce the
> > failure, core dump is welcome.
> 
> With the new arrival of Pulfer's qt5 5.6.0 we can update the old contrib
> version I'll choose the best weekly build to 
> update the contrib package , maybe 119 , 'cose it has russian and italian at
> 100%
> as soon as 119 tarball is out I'll push it in contrib.

latest weekly 119 is published in contrib