Bug 624 - Client can not to recognize some LDAP groups
: Client can not to recognize some LDAP groups
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 13:20 MSD by FirstLevel
Modified: 2013-02-06 17:21 MSK (History)
2 users (show)

See Also:
RPM Package: openldap-2.4.25-5-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
ldap.conf (9.63 KB, text/plain)
2012-08-07 13:20 MSD, FirstLevel
Details
Listing of LDAP database from server ldapsearch - x -b dc=hit (17.06 KB, application/gzip)
2012-08-10 09:54 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-08-07 13:20:10 MSD
Created attachment 455 [details]
ldap.conf

Description of problem:
I use ROSA 2012 LTS as client for LDAP server.  LDAP Server is SLES 11 and I have also client with OpenSUSE 11.
When I have loggged in OpenSUSE I see all group s for my LDAP user
arhiv:~ # id galkin
uid=10050(galkin) gid=10018(it) groups=10018(it),10036(rkvd),10033(philal),10042(sb),10045(obmen)

But when I have logged in ROSA I see only one group
[root@localhost ~]# id galkin
uid=10050(galkin) gid=10018(it) группы=10018(it)

I have attached ldap.conf 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-08-09 13:47:44 MSD
I have created test laboratory with LDAP server debian 6.0 and client ROSA 2012 LTS.
I have no problem with getting groups. The output of "id username" is equal.
For example:
test@lts86bgz ~]$ id
uid=1000(test) gid=1000(test) группы=1000(test),100(users),1003(test1group),1004(test2group)
[test@lts86bgz ~]$ 
Test is user from LDAP server and test, test1group and test1group are groups from LDAP server.
Comment 2 FirstLevel 2012-08-10 09:54:42 MSD
Created attachment 461 [details]
Listing of LDAP database from server ldapsearch - x -b dc=hit
Comment 3 FirstLevel 2012-08-10 09:54:59 MSD
I have attached listing of LDAP database from server
Comment 4 Eugene Budanov 2012-08-31 16:00:09 MSD
I tested Marathon with SLES SP11 and ldap, but without SSL/TLS encryption. Working good. I receive list of all of users from LDAP server and can login on it. 

Connection to LDAP server I setup by ROSA drakauth utility. Do you use SSL/TLS on LDAP server?
Comment 5 FirstLevel 2012-09-03 07:21:25 MSD
(In reply to comment #4)
> I tested Marathon with SLES SP11 and ldap, but without SSL/TLS encryption.
> Working good. I receive list of all of users from LDAP server and can login
> on it. 
> 
> Connection to LDAP server I setup by ROSA drakauth utility. Do you use
> SSL/TLS on LDAP server?

User has told that SLES LDAP does not use SSL/TLS
Comment 6 FirstLevel 2012-09-06 12:53:15 MSD
I have sent working configuration files (from Eugene Budanov) to user and user has told that problem is exist with such configuration files.
Comment 7 Eugene Budanov 2012-09-06 12:59:58 MSD
That strange. Can user try to setup connection to LDAP server by drakauth utility, not by manual editing of configuration files?
Comment 8 FirstLevel 2012-09-10 08:00:12 MSD
(In reply to comment #7)
> That strange. Can user try to setup connection to LDAP server by drakauth
> utility, not by manual editing of configuration files?

User has told that one workstation hi has configured with drakauth and second  has configured manually. Result is identical and both clients hav this error with listing of groups.
Comment 9 Eugene Budanov 2012-09-10 14:31:09 MSD
Which version of openLDAP used?
Comment 10 Eugene Budanov 2012-09-10 14:32:02 MSD
LDAP server, of course.
Comment 11 FirstLevel 2012-09-10 19:44:05 MSD
(In reply to comment #10)
> LDAP server, of course.

Please could You ask You question more clearly?
Comment 12 Eugene Budanov 2013-02-06 17:21:26 MSK
Cannot reproduce bug. Closed.