Bug 6191 - nscd does not create /var/run/nscd causing failure to start.
: nscd does not create /var/run/nscd causing failure to start.
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-18 12:30 MSD by Zombie Ryushu
Modified: 2015-11-17 07:12 MSK (History)
4 users (show)

See Also:
RPM Package: nscd
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrey.bondrov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-09-18 12:30:13 MSD
nscd does not create /var/run/nscd  causing failure to start at boot time. This causes me to have to manually create it and restart the service every boot.
Comment 1 Zombie Ryushu 2015-09-18 13:28:25 MSD
ExecStartPre=/bin/mkdir -p /var/run/nscd
might fix the problem.
Comment 2 Denis Silakov 2015-09-18 13:32:14 MSD
A more correct way ("systemd path":)) is to place this file - https://abf.io/import/glibc/blob/rosa2014.1/nscd.conf - into /usr/lib/tmpfiles.d folder and launch "systemd-tmpfiles --create nscd.conf" with root permissions (this command should be launched only once and normally is executed automatically by rpm file triggers once smth is installed into /usr/lib/tmpfiles.d folder).

The updated glibc build is in progress, but it can tale some time for QA to test it.
Comment 3 Zombie Ryushu 2015-09-18 13:45:27 MSD
That redirects to a page containing information about nscd.conf, did you mean the actual nscd.conf config file?
Comment 4 Denis Silakov 2015-09-18 13:46:05 MSD
Yes, surely, I meant that 1-line file.
Comment 5 Zombie Ryushu 2015-09-18 13:54:59 MSD
Is this what you were talking about?

d /run/nscd 0755 root root
Comment 6 Denis Silakov 2015-09-18 13:55:33 MSD
Yes.
Comment 7 Zombie Ryushu 2015-09-18 14:50:37 MSD
(In reply to comment #6)
> Yes.

So a file containing exclusively that line?
Comment 8 Denis Silakov 2015-09-18 15:31:50 MSD
Yes.
Comment 9 Denis Silakov 2015-09-18 16:48:19 MSD
Advisory:
Provide tmpfiles config for nscd service to fix it start after system reboot.

Build lists:
https://abf.io/build_lists/2573061
https://abf.io/build_lists/2573062
Comment 10 Vladimir Potapov 2015-10-01 05:51:34 MSD
I can't reproduce the bug:

systemctl status nscd.service 
● nscd.service - Name Service Cache Daemon
   Loaded: loaded (/lib/systemd/system/nscd.service; enabled; vendor preset: disabled)
   Active: active (running) since Чт 2015-10-01 09:49:32 IRKT; 34s ago
 Main PID: 3041 (nscd)
   CGroup: /system.slice/nscd.service
           └─3041 /usr/sbin/nscd --foreground
Comment 11 Vladimir Potapov 2015-10-02 06:53:05 MSD
(In reply to comment #0)
> nscd does not create /var/run/nscd  causing failure to start at boot time.
> This causes me to have to manually create it and restart the service every
> boot.
I don't reproduce this bug. On my test computers, /var/run/nscd created correct and service start without errors
Comment 12 Zombie Ryushu 2015-10-03 01:36:39 MSD
(In reply to comment #11)
> (In reply to comment #0)
> > nscd does not create /var/run/nscd  causing failure to start at boot time.
> > This causes me to have to manually create it and restart the service every
> > boot.
> I don't reproduce this bug. On my test computers, /var/run/nscd created
> correct and service start without errors

It varies, not all systems have the problem, but Denis Silakov's fix works.
Comment 13 Vladimir Potapov 2015-10-08 22:20:05 MSD
устанавливается nscd-2.19-20-rosa2014.1.x86_64.rpm из /var/cache/urpmi/rpms
Подготовка...                    #########################################################################################################
Failed to open 'glibc.conf', ignoring: No such file or directory
ERROR: 'script' failed for nscd-2.19-20-rosa2014.1.x86_64: 
error: %pre(nscd-2.19-20.x86_64) scriptlet failed, exit status 1
error:   install: %pre ошибка сценария (2), пропускается nscd-2.19-20.x86_64
Comment 14 Denis Silakov 2015-10-21 19:35:23 MSD
This was my fault. New packages are available.

Advisory:
Provide tmpfiles config for nscd service to fix it start after system reboot.

Build lists:
https://abf.io/build_lists/2588440
https://abf.io/build_lists/2588441
Comment 15 Vladimir Potapov 2015-10-22 08:36:03 MSD
The update is sent to expanded testing
**************************************
Comment 16 Zombie Ryushu 2015-10-22 08:38:09 MSD
This fix seems to work, but I am wondering if there is a way to remove the nscd socket as it interferes with sssd
Comment 17 Vladimir Potapov 2015-11-16 20:55:37 MSK
glibc-2.19-21
https://abf.io/build_lists/2588440
https://abf.io/build_lists/2588441
*************************** Advisory *****************************
Provide tmpfiles config for nscd service to fix it start after system reboot.
*****************************************************************
QA Verified