Bug 6185 - libgpod segfault when communicating to some iOS devices (Patches included)
: libgpod segfault when communicating to some iOS devices (Patches included)
Status: RESOLVED DUPLICATE of bug 6187
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
https://bugs.launchpad.net/ubuntu/+so...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 08:41 MSD by Zombie Ryushu
Modified: 2015-09-29 00:53 MSD (History)
3 users (show)

See Also:
RPM Package: libgpod
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zombie Ryushu 2015-09-17 08:41:23 MSD
The fix for libgpod fixes a segfaulting issue where apon connection or access of an iOS device, libgpod will segfault (as well as any program using it) while attempting to parse the playcount.xml file on the device.
Comment 1 Zombie Ryushu 2015-09-17 09:06:28 MSD
I have committed a nukmber of patches to my repo on ABF, theses patches fix the Segfault. Due to issues with Bugzilla I cannot post them here, but they are in the ABF repo.

create mode 100644 github.com-jburton-libgpod-fix-segfault.patch
 create mode 100644 libgpod-0.8.2-pkgconfig_overlinking.patch
 create mode 100644 libgpod-0.8.3-mono4.patch
 create mode 100644 libgpod-fixswig.patch
Comment 2 Zombie Ryushu 2015-09-17 09:18:04 MSD
The issue with gvfs-iPhone (aka gvfs-afc) is that it's not starting when the iOS device is detected by udev. Instead we get the device's PTP mode which only provides access to the device's photos. (We can't access the music / video / apps / database / etc. directories.)

gvfs-afc does not even run when the device is connected. Instead we see this in the system's dmesg:

usb 1-3: new high-speed USB device number 4 using ehci-pci
[  550.887425] usb 1-3: New USB device found, idVendor=05ac, idProduct=1293
[  550.887442] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  550.887450] usb 1-3: Product: iPod
[  550.887457] usb 1-3: Manufacturer: Apple Inc.

[  551.012633] audit: type=1130 audit(1442464679.381:223): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=usbmuxd comm="systemd" exe="/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

This is a udev rule issue with usbmuxd. the program that is supposed to run is /lib/udev/iphone-setinfo.
Comment 3 Zombie Ryushu 2015-09-17 09:54:08 MSD
he Crux of the problem, is that iOS devices do not show up correctly, they appear as PTP devices rather than MTP devices.
Comment 4 Denis Silakov 2015-09-29 00:53:28 MSD
Suggested patches are included in libgpod update handled together with update of other related packages in bug 6187.

*** This bug has been marked as a duplicate of bug 6187 ***