Bug 618 - dhcpdump is crashed after start
: dhcpdump is crashed after start
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 15:32 MSD by FirstLevel
Modified: 2016-04-09 23:56 MSD (History)
3 users (show)

See Also:
RPM Package: dhcpdump-1.8-4-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
some diagnostic information (5.24 KB, text/plain)
2012-08-06 15:32 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-08-06 15:32:49 MSD
Created attachment 451 [details]
some diagnostic information

Description of problem:
When I start dhcpdump for interface eth0 I have an error
# dhcpdump -i eth0
Ошибка сегментирования (слепок снят)

Some diagnostic information is attached.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Dmitry Mikhirev 2012-08-10 11:39:30 MSD
I can not reproduce this bug with the same dhcpdump version. Please provide a backtrace.

# urpmi gdb dhcpdump-debug glibc-debug libnl-debug libpcap-debug
# LC_ALL=C gdb dhcpdump
(gdb) run -i eth0
(gdb) bt
Comment 2 FirstLevel 2012-08-13 11:54:30 MSD
(In reply to comment #1)
> I can not reproduce this bug with the same dhcpdump version. Please provide
> a backtrace.
> 
> # urpmi gdb dhcpdump-debug glibc-debug libnl-debug libpcap-debug
> # LC_ALL=C gdb dhcpdump
> (gdb) run -i eth0
> (gdb) bt

(gdb) bt
#0  0x00007ffff792ca92 in __strcpy_ssse3 () from /lib64/libc.so.6
#1  0x000000000040129a in pcap_callback (user=0x0, h=0x7fffffffd9f0, sp=0x7ffff70a4046 "\377\377\377\377\377\377\360\336\361\335\062\006\b") at dhcpdump.c:159
#2  0x00007ffff7bab05f in pcap_read_linux_mmap (handle=0x6052e0, max_packets=0, callback=0x4010e0 <pcap_callback>, user=0x0) at ./pcap-linux.c:4053
#3  0x00007ffff7bae9f1 in pcap_loop (p=0x6052e0, cnt=0, callback=0x4010e0 <pcap_callback>, user=0x0) at ./pcap.c:527
#4  0x00000000004010a8 in main (argc=3, argv=0x7fffffffdbd8) at dhcpdump.c:111
Comment 3 Denis Silakov 2012-08-13 12:46:15 MSD
Maybe it is vmware network interfaces that lead to dhcpdump confusions? Does it work if you turn off vmnet* interfaces?
Comment 4 FirstLevel 2012-08-13 21:41:07 MSD
(In reply to comment #3)
> Maybe it is vmware network interfaces that lead to dhcpdump confusions? Does
> it work if you turn off vmnet* interfaces?

The problem is repeated:

# ifconfig vmnet1 down
# ifconfig vmnet8 down
# dhcpdump -i eth0
Ошибка сегментирования (слепок снят)

When I have deinstalled VMware-Player from my system the problem is repeated

# vmware-installer -u vmware-player
# dhcpdump -i eth0
Ошибка сегментирования (слепок снят)
Comment 5 FirstLevel 2014-06-03 16:35:00 MSD
checking the relevance
Comment 6 Stanislav Fomin 2015-03-06 19:26:35 MSK
Нужно будет перетестировать при выпуске нового Enterprise.
Скорее всего, будет неактуально.
Comment 7 Denis Silakov 2015-03-11 12:33:45 MSK
Может и актуально, т.к. dhcpdump не обновлялся уже 11 лет. Только надо бы иметь возможность воспроизвести проблему.

Если что, первоисточник ошибки здесь - http://forum.rosalab.ru/viewtopic.php?f=3&t=1124#p6905
Comment 8 Denis Silakov 2015-04-03 22:57:38 MSD
But let's move it to Fresh bugs. dhcpdump is in contrib, so it doesn't make sense to file bugs against Enterprise Desktop.
Comment 9 Denis Silakov 2016-04-09 23:56:38 MSD
Let's call as "worksforme". Feel free to create a new bug if you are able to reproduce this issue in modern environment.