Bug 6132 - [UPDATE REQUEST] apache 2.4.16
: [UPDATE REQUEST] apache 2.4.16
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 6119
  Show dependency treegraph
 
Reported: 2015-09-02 18:31 MSD by Denis Silakov
Modified: 2015-09-28 22:19 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-09-02 18:31:45 MSD
New bugfix release of Apache is available.

Advisory:
Updated apache to version 2.4.16.

Build lists:
https://abf.rosalinux.ru/build_lists/2560572
https://abf.rosalinux.ru/build_lists/2560573
Comment 1 FirstLevel 2015-09-04 08:28:01 MSD
With such strange scenarion I could not start OLD and NEW version of apache.

1. Install apache-base and ALL apache-mod packages with appropriate versions
2. Start httpd
3. Got an error:
r6-32 ~ # systemctl start httpd
Job for httpd.service failed. See "systemctl status httpd.service" and "journalctl -xe" for details.
r6-32 ~ # systemctl status httpd.service
● httpd.service - The Apache HTTP Server (prefork MPM)
   Loaded: loaded (/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
   Active: failed (Result: resources) since Пт 2015-09-04 07:23:42 MSK; 12s ago
  Process: 9838 ExecStart=/usr/sbin/httpd $OPTIONS -k start (code=exited, status=0/SUCCESS)

сен 04 07:23:39 r6-32 systemd[1]: Starting The Apache HTTP Server (prefork MPM)...
сен 04 07:23:40 r6-32 httpd[9838]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0...s message
сен 04 07:23:41 r6-32 systemd[1]: PID file /var/run/httpd/httpd.pid not readable (yet?) after start.
сен 04 07:23:42 r6-32 systemd[1]: httpd.service never wrote its PID file. Failing.
сен 04 07:23:42 r6-32 systemd[1]: Failed to start The Apache HTTP Server (prefork MPM).
сен 04 07:23:42 r6-32 systemd[1]: Unit httpd.service entered failed state.
сен 04 07:23:42 r6-32 systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
r6-32 ~ # 



I think that I need to configure default htpd.conf or othe configuration file for some module. 
Is it important?
Comment 2 Denis Silakov 2015-09-04 11:43:56 MSD
There is likely a problem in some of the apache-mod-* packages which install their own configs in /etc/http.d/ folder. For more details, you should look into journalctl output and /var/log/httpd logs. But this is not an issue in apache itself.
Comment 3 FirstLevel 2015-09-07 10:24:32 MSD
Install old + update and install new process goes well for 32 and 64 bit
Comment 4 Vladimir Potapov 2015-09-08 18:56:18 MSD
The update is sent to expanded testing
**************************************
Comment 5 Denis Silakov 2015-09-18 12:53:52 MSD
New builds with fixed logrotate configuration (http://forum.rosalab.ru/en/viewtopic.php?f=53&t=6044):

https://abf.io/build_lists/2573058
https://abf.io/build_lists/2573059
Comment 6 Vladimir Potapov 2015-09-23 06:21:51 MSD
The update is sent to expanded testing
***************************************
Comment 7 Denis Silakov 2015-09-23 22:29:50 MSD
I suggest to push these builds to testing, they contain additional fix for subversion (from bug 6119):

https://abf.io/build_lists/2574879
https://abf.io/build_lists/2574880
Comment 8 Vladimir Potapov 2015-09-24 09:33:02 MSD
(In reply to comment #7)
> I suggest to push these builds to testing, they contain additional fix for
> subversion (from bug 6119):
> 
> https://abf.io/build_lists/2574879
> https://abf.io/build_lists/2574880

Please, up the release number!
Comment 9 Denis Silakov 2015-09-24 11:52:11 MSD
https://abf.io/build_lists/2575594
https://abf.io/build_lists/2575595

Please ignore test failures, they are caused by several packages from Contrib repository that will be removed in the nearest future.
Comment 10 Vladimir Potapov 2015-09-24 13:55:24 MSD
The update is sent to expanded testing
**************************************
Comment 11 Vladimir Potapov 2015-09-28 19:47:17 MSD
apache-2.4.16-3
https://abf.io/build_lists/2575594
https://abf.io/build_lists/2575595
************************* Advisory *****************************
Updated apache to version 2.4.16
****************************************************************
QA Verified