Bug 6115 - [UPDATE REQUEST] zenity 3.12.1 > 3.16.3
: [UPDATE REQUEST] zenity 3.12.1 > 3.16.3
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 11:26 MSD by symbianflo
Modified: 2015-09-08 12:05 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
zenity-o1.png (232.24 KB, image/png)
2015-08-27 17:41 MSD, FirstLevel
Details
zenity-o2.png (227.11 KB, image/png)
2015-08-27 17:41 MSD, FirstLevel
Details
zenity-o3.png (151.75 KB, image/png)
2015-08-27 17:42 MSD, FirstLevel
Details
zenity-o4.png (282.21 KB, image/png)
2015-08-27 17:42 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description symbianflo 2015-08-27 11:26:20 MSD
Description of problem:
New bugfix and build fix version of zenity 3.16.3

Version-Release number of selected component (if applicable):
[UPDATE REQUEST] zenity 3.12.1 > 3.16.3

Changelog:
ftp://ftp.gnome.org/pub/GNOME/sources/zenity/3.16/zenity-3.16.3.changes
Comment 1 symbianflo 2015-08-27 11:28:21 MSD
Advisory: "Update zenity to 3.16.3"

https://abf.rosalinux.ru/build_lists/2558280
https://abf.rosalinux.ru/build_lists/2558281
Comment 2 FirstLevel 2015-08-27 17:41:31 MSD
Created attachment 4238 [details]
zenity-o1.png
Comment 3 FirstLevel 2015-08-27 17:41:48 MSD
Created attachment 4239 [details]
zenity-o2.png
Comment 4 FirstLevel 2015-08-27 17:42:04 MSD
Created attachment 4240 [details]
zenity-o3.png
Comment 5 FirstLevel 2015-08-27 17:42:21 MSD
Created attachment 4241 [details]
zenity-o4.png
Comment 6 FirstLevel 2015-08-27 17:43:37 MSD
Update goes well for 32 and 64 bit.
But I see some nontranslated items, see attachments.
Left - new, right - old
Comment 7 symbianflo 2015-08-28 01:01:15 MSD
(In reply to comment #6)
> Update goes well for 32 and 64 bit.
> But I see some nontranslated items, see attachments.
> Left - new, right - old

Thanks for testing it , I would really want to help but I don't speak russian,
I guess you must choose between bad russian translations and glade fix, screen centered dialog , multi line tooltip, --notification, text-info confirm, and much more...
The point is that I can not find no regressions in russian locales, or, at least they forget to mention it , and I'm really sorry for that.
Comment 8 Denis Silakov 2015-09-02 20:39:33 MSD
This comes not from zenity itself, since all its messages are translated. This likely comes from underlying gnome or gtk libraries and will be likely fixed once gnome stack is updated to 3.16.

On the other hand, these localization issues are not crucial. I guess all users nowadays will understand "Ok", "Cancel", "Yes" and "No" labels on buttons.
Comment 9 symbianflo 2015-09-02 21:43:04 MSD
(In reply to comment #8)
> This comes not from zenity itself, since all its messages are translated.
> This likely comes from underlying gnome or gtk libraries and will be likely
> fixed once gnome stack is updated to 3.16.
> 
> On the other hand, these localization issues are not crucial. I guess all
> users nowadays will understand "Ok", "Cancel", "Yes" and "No" labels on
> buttons.

Actually this update was made for 3.16, but since "mrb script guy" asked for this update I thought that will be needed by somebody else too.
Thanks Denis.
Anyway is already available in gnome316 branch.
Comment 10 Vladimir Potapov 2015-09-03 16:28:10 MSD
The update is sent to expanded testing
**************************************
Comment 11 symbianflo 2015-09-03 20:29:43 MSD
(In reply to comment #10)
> The update is sent to expanded testing
> **************************************

Thank you.
Comment 12 Vladimir Potapov 2015-09-08 10:35:07 MSD
zenity-3.16.3-1
https://abf.rosalinux.ru/build_lists/2558280
https://abf.rosalinux.ru/build_lists/2558281
***************************** Advisory ****************************
Update zenity to 3.16.3
*******************************************************************
QA Verified