Bug 6104 - [UPDATE REQUEST] libgdata 0.17.2
: [UPDATE REQUEST] libgdata 0.17.2
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-25 21:20 MSD by Denis Silakov
Modified: 2015-12-12 22:06 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
new-claws-mail.png (206.31 KB, image/png)
2015-08-26 15:33 MSD, FirstLevel
Details
new-evolution1.png (172.20 KB, image/png)
2015-08-26 15:33 MSD, FirstLevel
Details
old-claws-mail.png (168.40 KB, image/png)
2015-08-26 15:33 MSD, FirstLevel
Details
old-evolution.png (170.62 KB, image/png)
2015-08-26 15:33 MSD, FirstLevel
Details
evolution-test-build.png (228.93 KB, image/png)
2015-08-27 11:21 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 FirstLevel 2015-08-26 15:32:38 MSD
32bit

install old evolution totem gnome-documents videotop claws-mail, update, launch - ok
install new , launch  - ok


64bit

install old evolution totem gnome-documents videotop claws-mail, update, launch - ok
install new , launch  - ok
Comment 2 FirstLevel 2015-08-26 15:33:01 MSD
Created attachment 4228 [details]
new-claws-mail.png
Comment 3 FirstLevel 2015-08-26 15:33:17 MSD
Created attachment 4229 [details]
new-evolution1.png
Comment 4 FirstLevel 2015-08-26 15:33:31 MSD
Created attachment 4230 [details]
old-claws-mail.png
Comment 5 FirstLevel 2015-08-26 15:33:44 MSD
Created attachment 4231 [details]
old-evolution.png
Comment 6 FirstLevel 2015-08-26 15:34:10 MSD
But I have some localization issues with evolution and claws-mail. See attachments
Comment 7 Denis Silakov 2015-08-27 00:17:40 MSD
Interesting, I wonder if this is caused by new libgdata or by smth else.

Could you check these evolution builds:
https://abf.rosalinux.ru/build_lists/2557841
https://abf.rosalinux.ru/build_lists/2557842

This is the same evolution as we have in repositories, with old libgdata, just rebuild with the current build environment.
Comment 8 FirstLevel 2015-08-27 11:21:42 MSD
Created attachment 4234 [details]
evolution-test-build.png
Comment 9 FirstLevel 2015-08-27 11:21:56 MSD
(In reply to comment #7)
> Interesting, I wonder if this is caused by new libgdata or by smth else.
> 
> Could you check these evolution builds:
> https://abf.rosalinux.ru/build_lists/2557841
> https://abf.rosalinux.ru/build_lists/2557842
> 
> This is the same evolution as we have in repositories, with old libgdata,
> just rebuild with the current build environment.

See attachment evolution-test-build.png
Comment 10 Vladimir Potapov 2015-09-09 18:08:09 MSD
Localization issue
********************
QA Denied
Comment 11 Denis Silakov 2015-10-15 16:59:04 MSD
Let's try again. Claws-mail localization issue was caused by the fact that new claws-mail just don't provide Russian po file (maybe because it was not updated for a very long time). I pushed an old ru.po from their git; it is not perfect and should be improved, but claws-mail is a contrib package and this issue shouldn't prevent us from libgdata update.

As for evolution localization issue, I just failed to reproduce it. Maybe you forgot to update evolution-data-server? In any case, that evolution regression is a minor one, not so huge like in case of claws-mail.

(libgdata)
https://abf.io/build_lists/2586631
https://abf.io/build_lists/2586632

(totem)
https://abf.io/build_lists/2586640
https://abf.io/build_lists/2586641

(grilo-plugins)
https://abf.io/build_lists/2586642
https://abf.io/build_lists/2586643

(evolution)
https://abf.io/build_lists/2586644
https://abf.io/build_lists/2586645

(evolution-data-server)
https://abf.io/build_lists/2586646
https://abf.io/build_lists/2586694

(gnome-documents)
https://abf.io/build_lists/2586695
https://abf.io/build_lists/2586696

(gnome-online-miners)
https://abf.io/build_lists/2586698
https://abf.io/build_lists/2586651

== contrib packages - we can skip their tests, but the builds should be published with new libgdata ==

(videotop)
https://abf.io/build_lists/2586654
https://abf.io/build_lists/2586655

(eog-plugins)
https://abf.io/build_lists/2586656
https://abf.io/build_lists/2586657

(claws-mail)
https://abf.io/build_lists/2586658
https://abf.io/build_lists/2586659
Comment 12 Vladimir Potapov 2015-11-18 12:46:39 MSK
Plase, re-create containers
Comment 14 Vladimir Potapov 2015-11-19 17:36:10 MSK
а как gnome-documents под KDE проверить можно? Просто так не запускается.
Comment 15 Vladimir Potapov 2015-11-25 17:14:49 MSK
The update is sent to expanded testing
**************************************
Comment 16 Vladimir Potapov 2015-11-30 16:08:28 MSK
libgdata-0.17.2-1
https://abf.io/build_lists/2599450
https://abf.io/build_lists/2599451

totem-3.12.2-2
https://abf.io/build_lists/2599464
https://abf.io/build_lists/2599465

grilo-plugins-0.2.12-3
https://abf.io/build_lists/2599470
https://abf.io/build_lists/2599471

evolution-3.12.9-2
https://abf.io/build_lists/2599466
https://abf.io/build_lists/2599467

evolution-data-server-3.12.9-2
https://abf.io/build_lists/2599468
https://abf.io/build_lists/2599469

gnome-documents-3.12.1-4
https://abf.io/build_lists/2599472
https://abf.io/build_lists/2599473

gnome-online-miners-3.12.0-3
https://abf.io/build_lists/2599474
https://abf.io/build_lists/2599475

****************************** Advisory *************************
Updated libgdata to version 0.17.2.
*****************************************************************
QA Verified