Bug 6091 - gnome R5 fail after update
: gnome R5 fail after update
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 21:34 MSD by Vladimir Potapov
Modified: 2015-09-01 14:22 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
Install.log (468.41 KB, text/x-log)
2015-08-27 19:34 MSD, Vladimir Potapov
Details
Install2.log (276.40 KB, text/x-log)
2015-08-27 19:51 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-08-22 21:34:19 MSD
http://hw.rosalinux.ru/index.php?probe=2c66e69305

After update in VM Gmome r5 fail (X not start)
Comment 1 Vladimir Potapov 2015-08-23 16:54:20 MSD
systemctl start gdm solve the issue
Comment 2 Vladimir Potapov 2015-08-24 11:10:14 MSD
LXDe too (systemctl start graphical.target solve the issue)
Comment 3 a.lahin 2015-08-25 16:14:39 MSD
We have following script in systemd.spec:
	# Try to read default runlevel from the old inittab if it exists
	runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
	if [ -z "$runlevel" ] ; then
		target="/lib/systemd/system/graphical.target"
	else
		target="/lib/systemd/system/runlevel$runlevel.target"
	fi

	# And symlink what we found to the new-style default.target
	/bin/ln -sf "$target" %{_sysconfdir}/systemd/system/default.target 2>&1 || :

And /etc/inittab contains:
# Default runlevel. The runlevels used by Mandriva are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
# 
id:3:initdefault:
...

So the script creates symlink: default.target -> runlevel3.target

We can remove this script as we don't support upgrade from pre-systemd systems.
Comment 4 a.lahin 2015-08-25 20:34:09 MSD
Advisory:
systemd with the migration removed

https://abf.io/build_lists/2556864
https://abf.io/build_lists/2556865
Comment 5 Vladimir Potapov 2015-08-25 21:16:48 MSD
The update is sent to expanded testing
**************************************
Comment 6 Andrey Bondrov 2015-08-27 18:42:26 MSD
Advisory: "Remove migration from pre-systemd runlevels. Don't use Google's IPv6 DNS servers by default (fixes bug #6095)"

https://abf.rosalinux.ru/build_lists/2558657
https://abf.rosalinux.ru/build_lists/2558658
Comment 7 Vladimir Potapov 2015-08-27 19:34:25 MSD
Created attachment 4243 [details]
Install.log

log with error
Comment 8 Vladimir Potapov 2015-08-27 19:51:13 MSD
Created attachment 4244 [details]
Install2.log

Full log
Comment 9 Vladimir Potapov 2015-08-28 11:43:44 MSD
The update is sent to expanded testing
***************************************
Comment 10 Vladimir Potapov 2015-08-28 19:05:01 MSD
On lxde fail after update.
http://hw.rosalinux.ru/index.php?probe=3a588a9949
systemctl set-default graphical.target solve the issue
Comment 11 Vladimir Potapov 2015-09-01 09:39:19 MSD
systemd-219-1.20150505.16
https://abf.rosalinux.ru/build_lists/2558657
https://abf.rosalinux.ru/build_lists/2558658
******************************* Advisory ****************************
Remove migration from pre-systemd runlevels. Don't use Google's IPv6 DNS servers by default (fixes bug #6095)
*********************************************************************
QA Verified