Bug 6083 - [UPDATE REQUEST] qemu 2.4.0
: [UPDATE REQUEST] qemu 2.4.0
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 22:22 MSD by Eugene Shatokhin
Modified: 2015-09-08 12:07 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-08-20 22:22:02 MSD
QEMU was updated to version 2.4.0 with lots of improvements and fixes. Its pre-preqs were updated too.
Comment 1 Eugene Shatokhin 2015-08-20 22:26:29 MSD
Advisory: 
QEMU was updated to version 2.4.0 with lots of fixes and improvements all-around, including the fixes for a number of CVEs (bug #4718). Its prerequisites were updated as well.


Build lists:

1. ACPICA - moved to Main from Contrib with release up but no other updates.
i586:	https://abf.io/build_lists/2553893
x86_64:	https://abf.io/build_lists/2553894

2. seabios
i586:	https://abf.io/build_lists/2554623
x86_64:	https://abf.io/build_lists/2554624

3. ipxe
i586:	https://abf.io/build_lists/2554779
x86_64:	https://abf.io/build_lists/2554780

4. libseccomp
i586:	https://abf.io/build_lists/2554621
x86_64:	https://abf.io/build_lists/2554622

5. libcgroup
i586:	https://abf.io/build_lists/2554625
x86_64:	https://abf.io/build_lists/2554626

6. qemu
i586:	https://abf.io/build_lists/2554803
x86_64:	https://abf.io/build_lists/2554804
Comment 2 Eugene Shatokhin 2015-08-20 22:41:17 MSD
Hints for testing

To avoid the possible influence of libvirt and such, I recommend not using it for testing but rather start QEMU directly. 

First, create a virtual HDD:
  qemu-img create -f qcow2 mydisk.qcow2 60G

Assuming the test happens on the real hardware, one can use a command similar to the following ones to start a VM with ROSA R6 as a guest OS. Replace the paths to the HDD and the ISO image appropriately, of course.

For x86_64:
------------------------------
qemu-system-x86_64 \
    -name Test \
    -machine accel=kvm \
    -smp 2 \
    -m 2G \
    -usb \
    -usbdevice tablet \
    -balloon virtio \
    -vga std \
    -drive file=/home/user/test/VMs/mydisk.qcow2,if=virtio,index=0,media=disk \
    -monitor stdio \
    -net nic,vlan=0,model=virtio,macaddr=C6:2E:79:26:10:6B \
    -net user,vlan=0,net=192.168.28.0/24,host=192.168.28.1,hostfwd=tcp::7028-:22 \
    -soundhw hda \
    -serial file:/tmp/serial-test.log \
    -cdrom /home/user/test/iso/rosa_fresh_kde/x86_64/ROSA.FRESH.KDE.R6.12408.b.x86_64.iso \
    -boot order=dc
------------------------------

For i586 (no more than 2047 Mb of the virtual RAM seems to be supported):
------------------------------
qemu-system-i386 \
    -name Test \
    -machine accel=kvm \
    -smp 2 \
    -m 2047M \
    -usb \
    -usbdevice tablet \
    -balloon virtio \
    -vga std \
    -drive file=/home/user/test/VMs/mydisk.qcow2,if=virtio,index=0,media=disk \
    -monitor stdio \
    -net nic,vlan=0,model=virtio,macaddr=C6:2E:79:26:12:6B \
    -net user,vlan=0,net=192.168.28.0/24,host=192.168.28.1,hostfwd=tcp::7026-:22 \
    -soundhw hda \
    -serial file:/tmp/serial-test.log \
    -cdrom /home/user/test/iso/rosa_fresh_kde/i586/ROSA.FRESH.KDE.R6.12412.b.i586.iso \
    -boot order=dc
------------------------------

See a brief explanation of the options here (in Russian):
https://corpwiki.rosalinux.ru/QEMU_-_%D0%BF%D0%BE%D0%BB%D0%B5%D0%B7%D0%BD%D1%8B%D0%B5_%D1%81%D0%BE%D0%B2%D0%B5%D1%82%D1%8B

Note also that there are some problems with graphics in QEMU (or in the BIOS files it uses) that remain unfixed for years. For example - wrong display resolution when '-vga std' is used, so that the guest screen does not fit to the UI window (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=654823).

Workarounds:
* For ROSA R6 guests, it is possible to use EDID override as described here: http://wiki.rosalab.ru/en/index.php/Kernel#Monitor_EDID_Loading. For example, you can add "drm_kms_helper.edid_firmware=edid/1024x768.bin" to the kernel options in the guest system at boot.
* Use "-vga cirrus" instead of "-vga std".
* Use "-vga virtio" (x64 only) instead of "-vga std".
* Try other vga options (see "man qemu").
Comment 3 Denis Silakov 2015-09-03 20:55:20 MSD
*** Bug 2526 has been marked as a duplicate of this bug. ***
Comment 4 Denis Silakov 2015-09-08 12:07:15 MSD
I have tested new qemu on my machines and it worked fine. Though I had to add an explicit versioned dependency on ipxe package since new qemu doesn't work with old ipxe roms. With such a little change, new qemu was published to repositories.