Bug 6037 - [NEWPACKAGE] nvidia352 + updates for libvdpau and ldetect-lst
: [NEWPACKAGE] nvidia352 + updates for libvdpau and ldetect-lst
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks: 6070
  Show dependency treegraph
 
Reported: 2015-08-11 23:41 MSD by Eugene Shatokhin
Modified: 2015-08-17 22:45 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-08-11 23:41:56 MSD
A new potentially long-lived branch of NVidia's graphics drivers, 352.x, is now available. The updates of libvdpau and ldetect-lst are needed for it as well.
Comment 1 Eugene Shatokhin 2015-08-11 23:57:45 MSD
Advisory:
The packages for version 352.30 of the NVidia's graphics drivers are now available. Compared to the branch 346.x, this version provides support for 2 more OpenGL extensions (GL_ARB_copy_buffer, GL_ARB_texture_buffer_object), a few enhancements to VDPAU (support for lossless H.264/AVC video streams, decoding of H.265/HEVC video streams), G-SYNC improvements and more. 

nvidia352 requires the updates of libvdpau to version 1.1 and ldetect-lst to version 0.1.331, which have also been prepared.

Build lists:

nvidia352, version 352.30:
i586: https://abf.io/build_lists/2549674
x86_64: https://abf.io/build_lists/2549675

libvdpau, version 1.1:
i586: https://abf.io/build_lists/2549433
x86_64: https://abf.io/build_lists/2549434

ldetect-lst, version 0.1.331 (needed for XFdrake to see the new driver)
i586: https://abf.io/build_lists/2549518
x86_64: https://abf.io/build_lists/2549519
Comment 2 Eugene Shatokhin 2015-08-12 00:07:17 MSD
Hints for testing

1. After adding the containers, it may be convenient to update ldetect-lst first and then use XFdrake to select the new driver and setup the graphics.

As usual with the different driver packages, a regular package update will not replace nvidia346 with nvidia352 automatically. It is needed to use XFdrake.

2. If one needs to check support for CUDA, the following additional packages are needed:
nvidia-cuda-toolkit
nvidia-cuda-toolkit-devel
nvidia352-devel
nvidia352-cuda-opencl

No additional symlinks to libcuda.so (unlike http://forum.rosalab.ru/viewtopic.php?f=53&t=4529&p=48730#p48676) should be required here.
Comment 3 Vladimir Potapov 2015-08-17 21:42:49 MSD
nvidia352-352.30-2
https://abf.io/build_lists/2549674
https://abf.io/build_lists/2549675


libvdpau-1.1-1
https://abf.io/build_lists/2549433
https://abf.io/build_lists/2549434

ldetect-lst-0.1.331-1
https://abf.io/build_lists/2549518
https://abf.io/build_lists/2549519
*************************** Advisory ************************
The packages for version 352.30 of the NVidia's graphics drivers are now available. Compared to the branch 346.x, this version provides support for 2 more OpenGL extensions (GL_ARB_copy_buffer, GL_ARB_texture_buffer_object), a few enhancements to VDPAU (support for lossless H.264/AVC video streams, decoding of H.265/HEVC video streams), G-SYNC improvements and more. 

nvidia352 requires the updates of libvdpau to version 1.1 and ldetect-lst to version 0.1.331, which have also been prepared.
**************************************************************
QA Verified