Bug 6035 - Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel
: Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 17:45 MSD by Andrey Bondrov
Modified: 2015-08-17 22:50 MSD (History)
2 users (show)

See Also:
RPM Package: systemd
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-08-11 17:45:53 MSD
libsystemd-journal0-devel should require libsystemd-id1280-devel package. 

Otherwise some builds will fail with:

/usr/include/systemd/sd-journal.h:31:22: fatal error: sd-id128.h: No such file or directory
 #include "sd-id128.h"
Comment 1 Andrey Bondrov 2015-08-11 18:08:13 MSD
Advisory: "Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel"

https://abf.rosalinux.ru/build_lists/2549629
https://abf.rosalinux.ru/build_lists/2549630
Comment 2 Andrey Bondrov 2015-08-13 14:50:49 MSD
Advisory: "Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel. Fix triggers."

https://abf.rosalinux.ru/build_lists/2550255
https://abf.rosalinux.ru/build_lists/2550256
Comment 3 Andrey Bondrov 2015-08-13 15:01:16 MSD
P.S. This update is very important because current systemd is broken (triggers don't work properly).
Comment 4 Vladimir Potapov 2015-08-13 15:50:07 MSD
The update is sent to expanded testing
**************************************
Comment 5 Andrey Bondrov 2015-08-17 20:39:16 MSD
Advisory: "Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel. Fix triggers. Fix update issues from systemd 208."

https://abf.rosalinux.ru/build_lists/2553111
https://abf.rosalinux.ru/build_lists/2553112
Comment 6 Vladimir Potapov 2015-08-17 22:09:10 MSD
systemd-219-1.20150505.14
https://abf.rosalinux.ru/build_lists/2553111
https://abf.rosalinux.ru/build_lists/2553112
************************** Advisory **************************
Make sure libsystemd-journal0-devel package requires libsystemd-id1280-devel. Fix triggers. Fix update issues from systemd 208.
**************************************************************
QA Verified