Bug 6034 - [UPDATE REQUEST] libtasn1 4.5
: [UPDATE REQUEST] libtasn1 4.5
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-11 16:36 MSD by Denis Silakov
Modified: 2015-08-17 22:21 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-08-11 16:36:22 MSD
We have a very old version of libtasn1 in our repositories.
Unfortunately, Upstream Tracker doesn't provide compatibility report for modern libtasn versions, but at least library soname remains the same and changelog (http://upstream.rosalinux.ru/changelogs/libtasn1/4.5/changelog.html) mentions only changes that shouldn't break backward compatibility. So we don't have to rebuild applications that depend on libtasn1.

Advisory:
Updated libtasn1 to version 4.5.

Build lists:
https://abf.io/build_lists/2549453
https://abf.io/build_lists/2549454

Note for testers:
libtasn is used by gnutls and p11-kit, so it makes sense to check programs that use gnutls (lftp, filezilla, ...).
Comment 1 Denis Silakov 2015-08-11 16:38:23 MSD
*** Bug 5356 has been marked as a duplicate of this bug. ***
Comment 2 Vladimir Potapov 2015-08-13 20:55:46 MSD
The update is sent to expanded testing
**************************************
Comment 3 Vladimir Potapov 2015-08-17 21:47:37 MSD
libtasn1-4.5-1
https://abf.io/build_lists/2549453
https://abf.io/build_lists/2549454
************************* Advisory *************************
Updated libtasn1 to version 4.5.
************************************************************
QA Verified