Bug 6021 - fail2ban don't work
: fail2ban don't work
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-08 05:00 MSD by Vladimir Potapov
Modified: 2015-08-15 00:20 MSD (History)
1 user (show)

See Also:
RPM Package: fail2ban
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-08-08 05:00:50 MSD
fail2ban needed folder in /run, but /run in tmpfs
add to /lib/systemd/system/fail2ban.service
ExecStartPre=/bin/mkdir /run/fail2ban
solved this issue
Comment 1 Denis Silakov 2015-08-11 15:12:23 MSD
Should be fixed now.
Comment 2 Vladimir Potapov 2015-08-12 10:18:40 MSD
Денис, перезапуск сервиса при этом не работает.
надо еще ключик -p добавить.
Т.е. полностью
ExecStartPre=/bin/mkdir -p /run/fail2ban
Comment 3 Denis Silakov 2015-08-12 12:13:08 MSD
Добавление ExecStartPre в service файл - решение не совсем правильное, и в новом пакете не оно используется. Правильное решение - создавать такие файлы и директории с помощью systemd-tmpfiles, для которого создается несложный конфиг - https://abf.rosalinux.ru/import/fail2ban/blob/rosa2014.1/fail2ban.tmpfiles.conf

Но похоже, при установке пакета systemd-tmpfiles не отработал. Надо будет глянуть.
Comment 4 Denis Silakov 2015-08-12 12:48:09 MSD
Pleas try to update once again, I have made some fixes.
Comment 5 Denis Silakov 2015-08-15 00:20:18 MSD
Hopefully it works now. Feel free to reopen the bug if it doesn't.