Bug 6006 - kernel 4.1 plymouth issue
: kernel 4.1 plymouth issue
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: -Enter Bugs Here-
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Desktop Triage Team
: Desktop Triage Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 15:06 MSD by Vladimir Potapov
Modified: 2016-04-25 12:04 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-08-05 15:06:45 MSD
A plymouth partially (1/2 boot time) showed on boot with new 4/1 kernel
Comment 1 Shalok Shalom 2015-11-25 18:36:23 MSK
I vote, if there is something to vote for me, one more time for the removal of Plymouth. It make some devices again and again not boot able and cause other issues. Kernel parameters at boot and shutdown are very useful in same cases as well and there is still KSplashScreen to make to boot process beautiful.
Comment 2 Eugene Shatokhin 2015-11-25 19:25:04 MSK
Disabling Plymouth for all machines is not something we should do, I think.

If there are problems with it on a particular system, Plymouth can be disabled there. Add plymouth.enable=0 somewhere in the value of GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then run update-grub2 and you are all set.

Besides, this bug #6006 is not about unbootable system. It is about Plymouth showing too late in the boot process.
Comment 3 Shalok Shalom 2015-11-26 00:27:53 MSK
"Add plymouth.enable=0 somewhere in the value of GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then run update-grub2"

A casul user dont even know, what Plymouth, GRUB or the CL is and especially with a non bootable system might it be difficult, to google about a solution:

Especially, again, if you even dont know, what the issue is actually.

Whats so great about Plymouth ?

"Besides, this bug #6006 is not about unbootable system. It is about Plymouth showing too late in the boot process."

I know, it just reminds me at all my Plymouth issues.

Whats about the Kernel boot and shutdown messages ?

They are actually useful, imho.
Comment 4 Eugene Shatokhin 2015-11-26 14:48:15 MSK
(In reply to comment #3)
> I know, it just reminds me at all my Plymouth issues.

In your case, the problem is likely not in Plymouth itself but in the ordering of startup operations, may be, the dependencies of the services and such. Plymouth could just make it visible. The problem might be still there, hidden, until, say, some update of the system services makes it trigger again.

The boot process is far from perfect, so it would be very useful, if you could investigate the problem and find the root cause. If it is in Plymouth itself, you could try to locate it in the code. This would be a great help because we could not reproduce the problems you talk about on our test systems so far. 

Comparing the boot process to that of Fedora installed on the same system may make the analysis easier.
Comment 5 Shalok Shalom 2015-11-26 16:34:28 MSK
"In your case, the problem is likely not in Plymouth itself but in the ordering of startup operations, may be, the dependencies of the services and such."

No, because it works, once i disable Plymouth.

"Plymouth could just make it visible."

Plymouth makes nothing visible, besides of a non working due non booting OS.

Kernel boot parameters make things visible.

"The boot process is far from perfect, so it would be very useful, if you could investigate the problem and find the root cause. If it is in Plymouth itself, you could try to locate it in the code. This would be a great help because we could not reproduce the problems you talk about on our test systems so far. 

Comparing the boot process to that of Fedora installed on the same system may make the analysis easier."

Disable Plymouth work in my cases, so there is nothing more to investigate for me.

Sacrifice usability for a nice graphical boot up isnt my case and my experience shows, that update a kernel/gpu driver can cause such issues.

That means, no Plymouth for me by default.
Comment 6 Vladimir Potapov 2016-04-25 12:04:26 MSD
Fixed by quiet grub option