Bug 6000 - real time kernel
: real time kernel
Status: RESOLVED NOTABUG
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Hardware
: RED
: All Linux
: Normal normal
: ---
Assigned To: Groups for solving hardware issues.
: Eugene Shatokhin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 17:13 MSD by Shalok Shalom
Modified: 2015-08-07 06:29 MSD (History)
0 users

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-08-02 17:13:25 MSD
Is the realtime kernel again useable and recommended  ?

If not, is it maybe sense full, to remove it from this page:

http://wiki.rosalab.ru/en/index.php/Kernel
Comment 1 Eugene Shatokhin 2015-08-02 18:16:10 MSD
Lucky number 6000 :-)

In short:

* The name of nrj-realtime flavour is a bit misleading because that kernel does not provide realtime guarantees in a way that one commonly expects.

* -rt and rtQL do provide such guarantees.

However, none of these flavours are officially supported by ROSA. The users are free to try them at their own risk.

That wiki page describes the kernel flavours prepared by the respected kernel specialist, Nicolò Costanza, both the official and unofficial ones, so it should remain as it is.

As we always explain, currently, the officially supported kernel flavours are nrj-desktop, nrj-laptop and their PAE variants for 32-bit systems. 

The unofficial flavours are available in Contrib and the additional repositories.
Comment 2 Shalok Shalom 2015-08-04 23:46:35 MSD
"As we always explain"

Where ? In the Wiki ?

" ROSA Kernel

This text was started on 27 Feb 2014, this is only the very first draft, an early 'work in progress'...

at the end, when complete, it would contain the main specs of each flavours and suggestion of use.


ROSA has in its availability a great number of kernel series

    Kernel ONE with nr.3 flavour series: basic, nrj, nrjQL 

    Kernel ONE is the most complex and complete source with so many configs and features, it can configure and generate a lot of different specialized flavours, also called (69) Yin/Yang for its completeness 

    Kernel Vanilla with one basic vanilla flavour plus two vanilla + nrj based flavours
    Kernel RT with one basic rt flavour plus one rt based flavour (rtQL) "

Here is Kernel-RT described as official ROSA Kernel. What is Kernel ONE ?
Comment 3 Eugene Shatokhin 2015-08-05 10:16:52 MSD
This is not a bug. 

As I wrote before, that wiki page is for the kernels maintained by Niccolo Costanza. He does a really great job and provides us with a variety of kernel variants. The kernels he naintains are available in http://abf-downloads.rosalinux.ru/kernels_<version>x_personal/.

We take the patchsets and configs for some of them as a starting point for our official kernels.

> "As we always explain" Where ?

When the users ask at the forums or by any other means.

The packages officially maintained by ROSA are in the following repositories: "main", "non-free", "restricted" as well as their update repositories.

If one wants to see if a package is officially maintained at the moment, the most reliable way is to look in the repositories, for example, http://abf-downloads.rosalinux.ru/rosa2014.1/repository/x86_64/{main,non-free,restricted}
Comment 4 Shalok Shalom 2015-08-05 13:42:21 MSD
Here is Kernel-RT described as official ROSA Kernel and what is Kernel ONE ?

"ROSA Kernel

This text was started on 27 Feb 2014, this is only the very first draft, an early 'work in progress'...

at the end, when complete, it would contain the main specs of each flavours and suggestion of use.


ROSA has in its availability a great number of kernel series

    Kernel ONE with nr.3 flavour series: basic, nrj, nrjQL 

    Kernel ONE is the most complex and complete source with so many configs and features, it can configure and generate a lot of different specialized flavours, also called (69) Yin/Yang for its completeness 

    Kernel Vanilla with one basic vanilla flavour plus two vanilla + nrj based flavours
    Kernel RT with one basic rt flavour plus one rt based flavour (rtQL)"
Comment 5 Eugene Shatokhin 2015-08-05 14:21:08 MSD
(In reply to comment #4)
> what is Kernel ONE ?

Kernel ONE is a project (boils down to an RPM.spec file), from which many kernel flavours can be built including nrj-desktop, nrjQL-*, etc.

It is not a kernel flavour per se and is mostly of interest for maintainers.
Comment 6 Shalok Shalom 2015-08-06 16:45:17 MSD
Ah, i see. Its maybe senseful to mention this ?

And whats about the rt Kernel under the Category ROSA Kernel ?

That suggest, that both, ONE and rt are official flavours, imho.
Comment 7 Shalok Shalom 2015-08-07 06:29:46 MSD
Might be nice as a comment ? https://wiki.archlinux.org/index.php/Btrfs#Linux-rt_kernel