Bug 60 - Vpn agent not starting during boot
: Vpn agent not starting during boot
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: i586 Linux
: Normal enhancement
: ---
Assigned To: alexander barakin
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 16:10 MSD by oldmanduser
Modified: 2012-05-25 18:55 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oldmanduser 2012-04-17 16:10:19 MSD
Description of problem: I have installed cisco vpn client. In ROSA EE 2011 the vpnagent used to start automatically during boot. But in 2012 I need to start it manually everytime. When I go to drakconf I see that none of the services are configured to be started on boot. I guess there is a disconnect between how the services are started during boot and what is shown in drakconf


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install cisco vpn client
2. Restart the system
Comment 1 Alexander Burmashev 2012-04-25 14:44:10 MSD
Hello, can you please tell what package are you referring to when you speaking about cisco vpn agent ? Is it some external entity downloaded from some website ?
Comment 2 oldmanduser 2012-04-25 18:11:43 MSD
I am using cisco anyconnect vpn client. The installation went through fine. But then when I boot the vpnagent does not start. I digged through the logs and found the following

pcscd.service operation timed out. Terminating.

Since the service pcscd.service was timing out the Operating system had not got a chance to handle the other services which were supposed to be started. What I did is that I uninstalled pcsc-tools and pcsc-lite and things started working fine after that.

The observation I had was that when I started drakconf none of the services were selected, but then once I uninstalled the above mentioned package the services are correctly listed in drakconf.
Comment 3 alexander barakin 2012-05-21 21:07:43 MSD
i think the problem is as follows:

1. pcscd starts and runs fine:
$ ps ax | grep pcscd
 1899 ?        Sl     0:00 pcscd

2. but systemd says otherwise:
$ systemctl status pcscd.service 
pcscd.service - LSB: Smart Card Services
          Loaded: loaded (/etc/rc.d/init.d/pcscd)
          Active: failed since Fri, 18 May 2012 13:04:31 +0400; 3 days ago
         Process: 1720 ExecStart=/etc/rc.d/init.d/pcscd start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/pcscd.service
                  └ 1899 pcscd

i will deal with this next systemd-problem
Comment 4 alexander barakin 2012-05-25 10:36:15 MSD
2 oldmanduser:

please try new version of pcsc-lite from my personal repo:

32bit:
urpmi.addmedia sash_kan_personal http://abf.rosalinux.ru/downloads/sash_kan_personal/repository/rosa2012lts/i586/main/release

64bit:
urpmi.addmedia sash_kan_personal http://abf.rosalinux.ru/downloads/sash_kan_personal/repository/rosa2012lts/x86_64/main/release

p.s. related bug 258
Comment 5 oldmanduser 2012-05-25 17:39:18 MSD
Seems to be working fine.

Thanks,
Arun
Comment 6 alexander barakin 2012-05-25 17:46:33 MSD
(In reply to comment #5)
> Seems to be working fine.
> 
> Thanks,
> Arun

bug can be closed as fixed?
Comment 7 Alexander Burmashev 2012-05-25 17:48:34 MSD
Should not pcsc lite be pushed to the updates ?
Comment 8 alexander barakin 2012-05-25 18:41:29 MSD
(In reply to comment #7)
> Should not pcsc lite be pushed to the updates ?

see bug 258
Comment 9 Alexander Burmashev 2012-05-25 18:46:38 MSD
Oh sorry, it is ok then.
Yes i think this bug should be closed.
Comment 10 alexander barakin 2012-05-25 18:55:02 MSD
resolved as fixed·
package pcsc-lite updated: see bug 258