Bug 5948 - No Internet while WLAN is up and connected
: No Internet while WLAN is up and connected
Status: IN_PROGRESS
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: RED
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-16 00:41 MSD by Shalok Shalom
Modified: 2015-07-20 19:42 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-07-16 00:41:06 MSD
I install ROSA X2 on this device and it runs fine for 2 weeks with linux 3.14.33
The Internet connection fails from one day to the other, no updates get installed.


I update to 44 and then 4.1, both bring me the internet back.
Now is the issue back. The only thing, which i do, is a reboot.

hw-probe for that system after the issue with the network: 
http://hw.rosalinux.ru/index.php?probe=d98fb29e1f

The WLAN is shown as connected in the systray, nor browser activity or wget/package manager is working.

I try it with another WLAN Chip (via USB) and its the same issue there.
Comment 1 Shalok Shalom 2015-07-16 00:42:43 MSD
KDE Plasma mentions each ~ 10 minutes or so: Diffusion de message de .......
pcmups@localhost is unavailable. Even in the time, while the Internet was working.
Comment 2 Eugene Shatokhin 2015-07-16 12:58:53 MSD
1. When the problem happens again, try restarting the NetworkManager and see if it helps:

(as root)
systemctl restart NetworkManager.service

2. Please check if the problem shows up when kernel 4.1.2 and the experimental linux-firmware package are used. For x64, they are available here:

http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/rosa2014.1/x86_64/kernel_4_1/release/
http://abf-downloads.rosalinux.ru/spectre_personal/container/2519766/x86_64/main/release/
Comment 3 Shalok Shalom 2015-07-16 17:25:03 MSD
4.1.2 is already in use, which package of them: http://abf-downloads.rosalinux.ru/spectre_personal/container/2519766/x86_64/main/release/

I try already with complete restart and systemctl restart, same result.
Comment 4 Eugene Shatokhin 2015-07-16 19:26:37 MSD
(In reply to comment #3)
> 4.1.2 is already in use, which package of them:

The data uploaded by hw-probe above are for 3.14.33-nrj-desktop-1rosa. Please upload the data for the kernel 4.1.2 after the problem happens as well.
Comment 5 Shalok Shalom 2015-07-16 22:59:11 MSD
Hnn, GRUB choose for some strange reason 3.14.44 from advanced options by default, while 4.1.2 is installed and was choosen before, as the previous option.

Idk, how this happens, Internet work now, so kernel was the issue, thanks a lot. :) What is strange as well: 3.14.44 work before and when i boot now into it, work all fine. Then, reboot into 4.1.2 fails again.

I will send you a hw-probe in some seconds, just reboot into ROSA here.
Comment 6 Shalok Shalom 2015-07-16 23:13:40 MSD
http://hw.rosalinux.ru/index.php?probe=f825c9540e
Comment 7 Shalok Shalom 2015-07-20 19:42:14 MSD
In KaOS work the Browser, while the Package managment via Pacman is unuseable. Is it maybe an issue in NetworkManager ?