Bug 5910 - skype run error
: skype run error
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-08 19:34 MSD by Vladimir Potapov
Modified: 2015-07-20 12:13 MSD (History)
1 user (show)

See Also:
RPM Package: get-skype
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2015-07-08 19:34:40 MSD
x64 system
$ skype
ERROR: ld.so: object '/usr/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Comment 1 Denis Silakov 2015-07-15 00:57:52 MSD
Тут нет ничего страшного. У нас команда запуска skype выглядит вот так:

LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so env PULSE_LATENCY_MSEC=60 /usr/share/skype/skype

Т.е. сначала выставляется LD_PRELOAD, потом запускается команда env, а потом уже сам skype. Проргамма "env" в 64битной системе 64битная, так что это от нее ругань идет на невозможность подгрузить 32битный v4l2convert.so, а не от скайпа.

Но я сейчас переделаю немного скрипт запусак, чтобы и ошибки не было, и работало все нормально.
Comment 2 Denis Silakov 2015-07-15 01:11:27 MSD
Advisory:

Fixed skype launch script to avoid LD_PRELOAD warnings on 64bit systems.

Build lists:
https://abf.io/build_lists/2522047
Comment 3 Vladimir Potapov 2015-07-15 13:12:29 MSD
The update is sent to expanded testing
***************************************
Comment 4 Vladimir Potapov 2015-07-20 11:55:03 MSD
get-skype-4.3.0.37-4
https://abf.io/build_lists/2522047
************************** Advisory ***************************
Fixed skype launch script to avoid LD_PRELOAD warnings on 64bit systems.
***************************************************************
QA Verified