Bug 585 - Dolphin does not remember password for SMB share
: Dolphin does not remember password for SMB share
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Group of QA Team
: ROSA Linux Bugs
: [Cobalt]
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 09:18 MSD by FirstLevel
Modified: 2015-04-28 17:46 MSD (History)
5 users (show)

See Also:
RPM Package: kdebase4-4.8.3-2.src.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
Enetering name and password first time (40.26 KB, image/png)
2012-07-27 09:18 MSD, FirstLevel
Details
query to enter pass after reboot (46.59 KB, image/png)
2012-07-27 09:19 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-07-27 09:18:59 MSD
Created attachment 439 [details]
Enetering name and password first time

Description of problem:
I have created entry point to Windows share (with AD), specified path to share, username and password. I have seen that checkbox "remember password" is presented and I have enabled it.
After I have rebooted my system I need to enter username and password again when I have access to entry point and I see that checkbox is disabled.
Early versions of dolphin offer some option: remember for session, remember always. 
What does checkbox "remember password" mean  nowadays? How could I remember password forever?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-07-27 09:19:16 MSD
Created attachment 440 [details]
query to enter pass after reboot
Comment 2 Sylvainsjc 2012-08-18 09:35:08 MSD
Not sure that's your case but I've fixed this problem by activating kwallet
Comment 3 FirstLevel 2012-08-18 21:18:57 MSD
(In reply to comment #2)
> Not sure that's your case but I've fixed this problem by activating kwallet

Thanks, I'll try this method.
Comment 4 FirstLevel 2012-08-19 14:10:26 MSD
(In reply to comment #3)
> (In reply to comment #2)
> > Not sure that's your case but I've fixed this problem by activating kwallet
> 
> Thanks, I'll try this method.

The kwallet is enabled by this user. But password request is repeated.
Comment 5 Sylvainsjc 2012-08-19 14:54:37 MSD
(In reply to comment #4)

> The kwallet is enabled by this user. But password request is repeated.

yes but does the user have a valid wallet managed ? By default, there isn't any wallet configured for kwallet
Comment 6 Denis Koryavov 2012-08-19 15:11:31 MSD
Try this method:

1. Create a new user. 
2. Open your share in Dolphin. 
3. When you will see a suggestion to configure KWalled - do this, but leave the password for KWallet blank.
Comment 7 Sylvainsjc 2012-08-19 15:57:19 MSD
(In reply to comment #6)
> Try this method:
> 
> 1. Create a new user. 
> 2. Open your share in Dolphin. 
> 3. When you will see a suggestion to configure KWalled - do this, but leave
> the password for KWallet blank.

I noticed that Dolphin doesn't ask to set up a portfolio on the creation of a share.
There isn't option to store the password : http://wstaw.org/w/1iMH/

Whereas if I enable the wallet : http://wstaw.org/w/1iMI/

Then the possibility to store the password is proposed : http://wstaw.org/w/1iMJ/
Comment 8 FirstLevel 2012-08-19 21:11:52 MSD
(In reply to comment #7)
> (In reply to comment #6)
> > Try this method:
> > 
> > 1. Create a new user. 
> > 2. Open your share in Dolphin. 
> > 3. When you will see a suggestion to configure KWalled - do this, but leave
> > the password for KWallet blank.
> 
> I noticed that Dolphin doesn't ask to set up a portfolio on the creation of
> a share.
> There isn't option to store the password : http://wstaw.org/w/1iMH/
> 
> Whereas if I enable the wallet : http://wstaw.org/w/1iMI/
> 
> Then the possibility to store the password is proposed :
> http://wstaw.org/w/1iMJ/

User has answered that he has enabled kwallet and he has not problem with ftp and webdav. The problem is appeared only for smb resources
Comment 9 Stanislav Fomin 2014-03-17 16:25:39 MSK
Надо проверить, по преждему ли воспроизводится в Marathon и воспроизводится ли во Fresh.
(При включенном kwallet)

Если у нас не воспроизведется (в Fresh вроде ОК, тут надо скорее проверить Марафон) → закрываем с WORKSFORME.

Если воспроизводится хотя бы в одной из систем — переводим статус в CONFIRMED.

Желательно сопроводить воспроизведенный баг скринкастом (лучше грузить на mail.ru, впрочем, можно продолжать использовать 2safe.com)

В целом, нужно собрать максимум полезной информации, чтобы баг был исправлен.
Comment 10 FirstLevel 2014-03-17 17:49:12 MSK
(In reply to comment #9)
> Надо проверить, по преждему ли воспроизводится в Marathon и воспроизводится
> ли во Fresh.
> (При включенном kwallet)
> 
> Если у нас не воспроизведется (в Fresh вроде ОК, тут надо скорее проверить
> Марафон) → закрываем с WORKSFORME.
> 
> Если воспроизводится хотя бы в одной из систем — переводим статус в
> CONFIRMED.
> 
> Желательно сопроводить воспроизведенный баг скринкастом (лучше грузить на
> mail.ru, впрочем, можно продолжать использовать 2safe.com)
> 
> В целом, нужно собрать максимум полезной информации, чтобы баг был исправлен.

Пока проверил предварительно. Получилась такая картина. Для нового пользователя вообще не происходит вопроса от kwallet при обращении к ресурсу с паролем в LTS. По идее, как только сказал "Сохранить пароль", тут же появляется окно kwallet с запросом "Будем ли им пользоваться"  (во Fresh - так и происходит).
Для LTS после первого обращения к ресурсу с паролем не возникает никакого окна от kwallet.  Он вообще для LTS включен?
Comment 11 FirstLevel 2014-04-03 11:00:53 MSD
Актуально в свежеустановленном кобальте
Comment 12 Denis Silakov 2015-04-28 17:46:03 MSD
(In reply to comment #10)

> Пока проверил предварительно. Получилась такая картина. Для нового
> пользователя вообще не происходит вопроса от kwallet при обращении к ресурсу
> с паролем в LTS. По идее, как только сказал "Сохранить пароль", тут же
> появляется окно kwallet с запросом "Будем ли им пользоваться"  (во Fresh -
> так и происходит).

Since this works in Fresh, it also works in RED X2. No need to Marathon backport, since this is not a crucial bug.