Bug 5833 - [UPDATE REQUEST] btrfs-progs 3.19.1
: [UPDATE REQUEST] btrfs-progs 3.19.1
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-25 16:13 MSD by Denis Silakov
Modified: 2015-06-30 11:48 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-06-25 16:13:43 MSD
We have ancient btrfs-progs in repository and we need newer version to build Docker.

Advisory:

btrfs-progs was updated to version 3.19.1 with lots of upstream changes. Besides, btrfs tools are now placed in /sbin (like the tools for ext4, xfs and other file systems are), rather than to /usr/sbin/ as before.

In addition, gparted has been updated to version 0.19.1 to correctly work with new btrfs-progs.

Build lists:
(btrfs-progs)
https://abf.io/build_lists/2513909
https://abf.io/build_lists/2513910

(gparted)
https://abf.io/build_lists/2513911
https://abf.io/build_lists/2513912
Comment 1 FirstLevel 2015-06-26 10:36:08 MSD
btrfs-prog

32bit

update - ok
create, move, resize btrfs partition - ok

64bit

update - ok
create, move, resize btrfs partition - ok
Comment 2 Vladimir Potapov 2015-06-26 11:16:46 MSD
The update is sent to expanded testing
*************************************
Comment 3 Vladimir Potapov 2015-06-27 11:33:39 MSD
Gparted need gpart for menu recovery partition work  (please, add to image!)
But gpart version in repo too old (please, update it!)
Comment 4 Denis Silakov 2015-06-29 14:44:07 MSD
Ok. Let's simply add gpart to gparted requirements then.

(gparted)
https://abf.io/build_lists/2514898
https://abf.io/build_lists/2514899

(gpart)
https://abf.io/build_lists/2514896
https://abf.io/build_lists/2514897
Comment 5 Vladimir Potapov 2015-06-29 18:57:20 MSD
http://bugs.rosalinux.ru/show_bug.cgi?id=5852
Comment 6 Denis Silakov 2015-06-29 23:47:02 MSD
Here is gparted with 'yelp' dependency added to fix bug 5852:

https://abf.rosalinux.ru/build_lists/2515070
https://abf.rosalinux.ru/build_lists/2515069
Comment 7 Vladimir Potapov 2015-06-30 06:46:40 MSD
btrfs-progs-3.19.1-1
https://abf.io/build_lists/2513909
https://abf.io/build_lists/2513910

gpart-0.2.1-1
https://abf.io/build_lists/2514896
https://abf.io/build_lists/2514897

gparted-0.19.1-4
https://abf.rosalinux.ru/build_lists/2515070
https://abf.rosalinux.ru/build_lists/2515069
****************************** Advisory ********************************
btrfs-progs was updated to version 3.19.1 with lots of upstream changes. Besides, btrfs tools are now placed in /sbin (like the tools for ext4, xfs and other file systems are), rather than to /usr/sbin/ as before.

In addition, gparted has been updated to version 0.19.1 to correctly work with new btrfs-progs.
Here is gparted with 'yelp' dependency added to fix bug#5852
************************************************************************
QA Verified