Bug 579 - Icon oddly trembles/moves upon single click
: Icon oddly trembles/moves upon single click
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: 2012 Marathon RP1
Assigned To: Denis Koryavov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 11:35 MSD by Zeffanyx
Modified: 2012-08-07 23:31 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
alex.burmashev: published+


Attachments
After a few clicks, the name icon become cut off from the bottom. Please see the attachment (18.78 KB, image/jpeg)
2012-08-03 20:10 MSD, Alexander Petryakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeffanyx 2012-07-25 11:35:58 MSD
Description of problem:
When I click an icon on the desktop, it is not selected but strangely moves up by two pixels (or so). In order to select it I have to drag a selection rectangle from outside of the icon.
If I double-click an icon, it launches correctly, though that odd move still occurs

Steps to Reproduce:
1. Click any icon on the desktop one time
2. Watch the icon move up and down by few pixels.
Comment 1 Denis Koryavov 2012-08-02 12:03:41 MSD
Advisory:

Fixed bug when icon of file on the desktop just trembles/moves upon single click on it and file seems as not selected.

Build Lists:
https://abf.rosalinux.ru/build_lists/640176
https://abf.rosalinux.ru/build_lists/640177
Comment 2 Denis Koryavov 2012-08-03 17:10:24 MSD
UP?
Comment 3 Alexander Petryakov 2012-08-03 20:10:44 MSD
Created attachment 448 [details]
After a few clicks, the name icon become cut off from the bottom. Please see the attachment
Comment 4 Alexander Petryakov 2012-08-03 20:14:23 MSD
New bug after update.
After a few clicks, the name icon become cut off from the bottom.
Please see the attachment
Comment 5 Denis Koryavov 2012-08-06 14:59:46 MSD
I can't reproduce this bug. Have you tried to remove /var/tmp/kdecache-[youusername] and reboot your machine before checking?
Comment 6 Denis Koryavov 2012-08-06 17:14:18 MSD
I've added workaround for this kde-bug in postinstall script, try these packages:

https://abf.rosalinux.ru/build_lists/658310
https://abf.rosalinux.ru/build_lists/658309
Comment 7 Denis Koryavov 2012-08-06 17:14:51 MSD
Advisory:

Fixed bug when icon of file on the desktop just trembles/moves upon single click on it and file seems as not selected.

BuildLists: 
https://abf.rosalinux.ru/build_lists/658310
https://abf.rosalinux.ru/build_lists/658309
Comment 8 Alexander Petryakov 2012-08-06 22:19:58 MSD
The same error (for 1.2.5-2), but if remove /var/tmp/kdecache-[youusername] and reboot - all correct.
I suppose, user should not remove cache catalog by hand. If i not right, i will grant qa approval.
Comment 9 Denis Koryavov 2012-08-06 22:56:00 MSD
It is strange. Maybe you just not rebooted your system after you have installed 1.2.5-2? But we can do nothing more for this, KDE - it is very ugly software. :(
Comment 10 Alexander Petryakov 2012-08-07 23:26:33 MSD
plasma-desktoptheme-rosa-1.2.5-2-rosa.lts2012.0
************** Advisory **************
Fixed bug when icon of file on the desktop just trembles/moves upon single click on it and file seems as not selected.
Warning: After update user should remove /var/tmp/kdecache-[username] and reboot his machine.
**************************************
QA Verified