Bug 5786 - [UPDATE REQUEST] hplip 3.15.6
: [UPDATE REQUEST] hplip 3.15.6
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-17 16:55 MSD by Denis Silakov
Modified: 2015-06-22 17:38 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
32bit-printer-setup.txt (5.76 KB, text/plain)
2015-06-18 09:33 MSD, FirstLevel
Details
32bit-printer-setup.webm (5.55 MB, video/webm)
2015-06-18 09:34 MSD, FirstLevel
Details
64bit-printer-setup.txt (5.60 KB, text/plain)
2015-06-18 09:34 MSD, FirstLevel
Details
64bit-printer-setup.webm (6.26 MB, video/webm)
2015-06-18 09:35 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Silakov 2015-06-17 16:55:32 MSD
Advisory:

Updated hplip to new version 3.15.6 with support for new printer models. Switched hplip to use python3 by default.

Build lists:
(python-reportlab)
https://abf.io/build_lists/2511780
https://abf.io/build_lists/2511781

(hplip)
https://abf.io/build_lists/2511791
https://abf.io/build_lists/2511792
Comment 1 FirstLevel 2015-06-18 09:33:39 MSD
I have tested such case.
1. Install updates from rhis bug http://bugs.rosalinux.ru/show_bug.cgi?id=5786
2. Install update from this bug http://bugs.rosalinux.ru/show_bug.cgi?id=5785
3. Set up network printer HP MFP 2727

You can see results in attachments.
I think it was an error that after choosing ip-address of network printer and clicking "Next"  I cannot see driver page until I click "Next" again.
As I remember driver page should appear automatically.

After that SECOND clicking printer set up goes well and printing test page goes well too.
Comment 2 FirstLevel 2015-06-18 09:33:56 MSD
Created attachment 4115 [details]
32bit-printer-setup.txt
Comment 3 FirstLevel 2015-06-18 09:34:25 MSD
Created attachment 4116 [details]
32bit-printer-setup.webm
Comment 4 FirstLevel 2015-06-18 09:34:41 MSD
Created attachment 4117 [details]
64bit-printer-setup.txt
Comment 5 FirstLevel 2015-06-18 09:35:10 MSD
Created attachment 4118 [details]
64bit-printer-setup.webm
Comment 6 Denis Silakov 2015-06-18 10:09:17 MSD
Not good, but are you sure that hplip is the root of the problem? Did everything work fine with previous version?

The problem in the logs can be caused by recent python updates, not by hplip. Please try system-config-printer from these containers:
https://abf.rosalinux.ru/build_lists/2512033
https://abf.rosalinux.ru/build_lists/2512034
Comment 7 FirstLevel 2015-06-18 11:33:26 MSD
(In reply to comment #6)
> Not good, but are you sure that hplip is the root of the problem? Did
> everything work fine with previous version?
> 
> The problem in the logs can be caused by recent python updates, not by
> hplip. Please try system-config-printer from these containers:
> https://abf.rosalinux.ru/build_lists/2512033
> https://abf.rosalinux.ru/build_lists/2512034

With new system-config-printer  - all is ok. Driver has found after first clickink without hanging.


[sergei32@r5-32 ~]$ system-config-printer
task-printing-server-2014-1-rosa2014.1.i586
task-printing-hp-2014-1-rosa2014.1.i586
rmmod: ERROR: Module lp is not currently loaded
task-printing-hp-2014-1-rosa2014.1.i586
libsane-hpaio1-3.15.6-1-rosa2014.1.i586
xsane-0.999-5-rosa2014.1.i586
No ID match for device socket:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;
task-printing-hp-2014-1-rosa2014.1.i586
libsane-hpaio1-3.15.6-1-rosa2014.1.i586
xsane-0.999-5-rosa2014.1.i586
No ID match for device socket://172.25.183.212:9100:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;
task-printing-hp-2014-1-rosa2014.1.i586
libsane-hpaio1-3.15.6-1-rosa2014.1.i586
xsane-0.999-5-rosa2014.1.i586
No ID match for device socket://172.25.183.212:9100:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;

(system-config-printer.py:6370): libnotify-WARNING **: Failed to connect to proxy
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
[sergei32@r5-32 ~]$ 



[sergei64@r564 ~]$ system-config-printer
task-printing-server-2014-1-rosa2014.1.x86_64
task-printing-hp-2014-1-rosa2014.1.x86_64
rmmod: ERROR: Module lp is not currently loaded
task-printing-hp-2014-1-rosa2014.1.x86_64
lib64sane-hpaio1-3.15.6-1-rosa2014.1.x86_64
xsane-0.999-5-rosa2014.1.x86_64
No ID match for device socket:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;
task-printing-hp-2014-1-rosa2014.1.x86_64
lib64sane-hpaio1-3.15.6-1-rosa2014.1.x86_64
xsane-0.999-5-rosa2014.1.x86_64
No ID match for device socket://172.25.183.212:9100:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;
task-printing-hp-2014-1-rosa2014.1.x86_64
lib64sane-hpaio1-3.15.6-1-rosa2014.1.x86_64
xsane-0.999-5-rosa2014.1.x86_64
No ID match for device socket://172.25.183.212:9100:
MFG:Hewlett-Packard;MDL:HP LaserJet M2727nf MFP;CMD:PJL,PML,PCLXL,POSTSCRIPT,PCL;DES:Hewlett-Packard LaserJet M2727nf MFP;

(system-config-printer.py:5367): libnotify-WARNING **: Failed to connect to proxy
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
[sergei64@r564 ~]$
Comment 8 Vladimir Potapov 2015-06-18 13:15:33 MSD
The update is sent to expanded testing
**************************************
Comment 9 Vladimir Potapov 2015-06-18 13:18:38 MSD
The update is sent to expanded testing
***************************************
Comment 10 Vladimir Potapov 2015-06-22 14:20:04 MSD
python-reportlab-3.1.8-5
https://abf.io/build_lists/2511780
https://abf.io/build_lists/2511781

hplip-3.15.6-1
https://abf.io/build_lists/2511791
https://abf.io/build_lists/2511792

system-config-printer-1.4.7-6
https://abf.rosalinux.ru/build_lists/2512033
https://abf.rosalinux.ru/build_lists/2512034

********************** Advisory **************************
Updated hplip to new version 3.15.6 with support for new printer models. Switched hplip to use python3 by default.
***********************************************************
QA Verified