Bug 5768 - [UPDATE REQUEST] dracut-041
: [UPDATE REQUEST] dracut-041
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: High normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-15 13:36 MSD by Eugene Shatokhin
Modified: 2015-06-22 18:17 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
eugene.shatokhin: published+


Attachments
boot.log (11.70 KB, text/x-log)
2015-06-18 21:57 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shatokhin 2015-06-15 13:36:21 MSD
dracut was updated to version 041 with additional patches from Fedora.
Comment 1 Eugene Shatokhin 2015-06-15 13:49:06 MSD
Advisory:
dracut was updated to version 041 with additional patches. 
This version brings a number of enhancements and fixes all-around (USB, network, SDHCI, RAID and more). 
Additionally, it is now possible to set the amount of memory to store the changes in the file system in Live mode. DeviceMapper's thin snapshots with support for fstrim in Live mode (experimental feature) are also available. 
Besides that, we  moved the default configuration for dracut to /usr/lib/dracut/dracut.conf.d/ from /etc/dracut.conf.d/ to make it easier to override it and made dracut less verbose by default.

Build lists:
i586:
https://abf.io/build_lists/2509453
x86_64:
https://abf.io/build_lists/2509454


Hints for testing
Among other things, please check for regressions related to:
* suspend/hibernate/resume
* ROSA Freeze
* (if possible) RAID & LVM

Here are the test ISO images with the new dracut and kernel 3.14.44:
https://abf.io/platforms/rosa2014.1/products/111/product_build_lists/11649
May help test Live mode.
Comment 2 Eugene Shatokhin 2015-06-15 18:22:09 MSD
Cancelling this update request for now: a problem was found with 32-bit Live images (64-bit ones seem to be OK). dracut is the likely cause here.

The update may be postponed until after the release of ROSA R6.
Comment 3 Eugene Shatokhin 2015-06-15 18:25:37 MSD
This is what gets output when I start the 32-bit image from a USB stick on my EeePC:
-------------
EXT2-FS (sdb1): error: unable to read superblock
EXT4-FS (sdb1): unable to read superblock
SQUASHFS error: squashfs_read_data failed to read block 0x0
SQUASHFS error: unable to read squashfs_super_block
dracut: FATAL: Failed to mount block device of live image
dracut: refusing to continue
reboot: System halted
-------------

Works OK in VirtualBox though. 

The image built with kernel 3.14.44 and the old dracut works fine on that EeePC.

So, dracut needs more work, and this update should be postponed until later.
Comment 4 Konstantin Vlasov 2015-06-15 18:44:48 MSD
Additional information: in VirtualBox it works because ISO is attached as DVD disk. If you convert ISO file into VDI hard disk image, attach it and boot from it, then this problem occurs in VirtualBox as well. And I suppose, if you burn ISO onto DVD and boot on real hardware from it, there won't be any problem (though I didn't check this).
Comment 5 Eugene Shatokhin 2015-06-18 18:39:46 MSD
These builds of dracut 041-8 should fix the problem described above:

Build lists:
i586:
https://abf.io/build_lists/2512112
x86_64:
https://abf.io/build_lists/2512113
Comment 6 Eugene Shatokhin 2015-06-18 18:41:12 MSD
Advisory:
dracut was updated to version 041 with additional patches. 
This version brings a number of enhancements and fixes all-around (USB, network, SDHCI, RAID and more). 
Additionally, it is now possible to set the amount of memory to store the changes in the file system in Live mode. DeviceMapper's thin snapshots with support for fstrim in Live mode (experimental feature) are also available. 
Besides that, we  moved the default configuration for dracut to /usr/lib/dracut/dracut.conf.d/ from /etc/dracut.conf.d/ to make it easier to override it and made dracut less verbose by default.

Build lists:
i586:
https://abf.io/build_lists/2512112
x86_64:
https://abf.io/build_lists/2512113


Hints for testing
Among other things, please check for regressions related to:
* suspend/hibernate/resume
* ROSA Freeze
* (if possible) RAID & LVM

Here are the test ISO images with the new dracut and kernel 3.14.44:
https://abf.io/platforms/rosa2014.1/products/111/product_build_lists/11728
Comment 7 Vladimir Potapov 2015-06-18 21:45:00 MSD
(In reply to comment #6)
> Advisory:
> dracut was updated to version 041 with additional patches. 
> This version brings a number of enhancements and fixes all-around (USB,
> network, SDHCI, RAID and more). 
> Additionally, it is now possible to set the amount of memory to store the
> changes in the file system in Live mode. DeviceMapper's thin snapshots with
> support for fstrim in Live mode (experimental feature) are also available. 
> Besides that, we  moved the default configuration for dracut to
> /usr/lib/dracut/dracut.conf.d/ from /etc/dracut.conf.d/ to make it easier to
> override it and made dracut less verbose by default.
> 
> Build lists:
> i586:
> https://abf.io/build_lists/2512112
> x86_64:
> https://abf.io/build_lists/2512113
> 
> 
> Hints for testing
> Among other things, please check for regressions related to:
> * suspend/hibernate/resume
> * ROSA Freeze
> * (if possible) RAID & LVM
> 
> Here are the test ISO images with the new dracut and kernel 3.14.44:
> https://abf.io/platforms/rosa2014.1/products/111/product_build_lists/11728

dracut -f work without any messages.
Is it correct?
Comment 8 Eugene Shatokhin 2015-06-18 21:53:29 MSD
(In reply to comment #7)
> dracut -f work without any messages.
> Is it correct?

Yes, as I wrote before, I made it less verbose by default. It will report only errors.

If the old behaviour is needed, one may add '-v' option when running dracut.
Comment 9 Vladimir Potapov 2015-06-18 21:57:31 MSD
Created attachment 4124 [details]
boot.log

Incorrect boot.log format
Comment 10 Eugene Shatokhin 2015-06-18 22:01:39 MSD
(In reply to comment #9)
> Incorrect boot.log format

These symbols are for the colored output to the console. 
Looks like the log is saved as is, similar to what you get via serial connection, for example. Should not be critical.
Comment 11 Eugene Shatokhin 2015-06-18 22:30:31 MSD
Run less /var/log/boot.log and you will see.
Comment 12 Vladimir Potapov 2015-06-19 11:06:05 MSD
The update is sent to expanded testing
**************************************
Comment 13 Vladimir Potapov 2015-06-19 11:15:22 MSD
          ################################################################################################################################################################################  
DNS-FRESH-i586 keleg # systemctl status systemd-tmpfiles-setup.service                                                                                                                                             
systemd-tmpfiles-setup.service - Create Volatile Files and Directories                                                                                                                                             
   Loaded: loaded (/lib/systemd/system/systemd-tmpfiles-setup.service; static)                                                                                                                                     
   Active: failed (Result: exit-code) since Пт 2015-06-19 14:54:07 IRKT; 20min ago                                                                                                                                 
     Docs: man:tmpfiles.d(5)                                                                                                                                                                                       
           man:systemd-tmpfiles(8)                                                                                                                                                                                 
  Process: 636 ExecStart=/bin/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev (code=exited, status=1/FAILURE)                                                                                      
 Main PID: 636 (code=exited, status=1/FAILURE)                                                                                                                                                                     
                                                                                                                                                                                                                   
июн 19 14:54:07 DNS-FRESH-i586 systemd[1]: Starting Create Volatile Files and Directories...
июн 19 14:54:07 DNS-FRESH-i586 systemd[1]: systemd-tmpfiles-setup.service: main process exited, code=exited, status=1/FAILURE
июн 19 14:54:07 DNS-FRESH-i586 systemd[1]: Failed to start Create Volatile Files and Directories.
июн 19 14:54:07 DNS-FRESH-i586 systemd[1]: Unit systemd-tmpfiles-setup.service entered failed state.
Comment 14 Eugene Shatokhin 2015-06-19 13:24:22 MSD
(In reply to comment #13)
> systemd-tmpfiles-setup.service entered failed state.

Looks like the problem is not in dracut but rather it is because 'lockdev' package failed to install during the build of the 32-bit image and failed to create 'lock' group as a result.

See also http://bugs.rosalinux.ru/show_bug.cgi?id=4829#c0.

It seems to be a separate problem.
Comment 15 Vladimir Potapov 2015-06-22 14:27:01 MSD
dracut-041-7
https://abf.io/build_lists/2509453
https://abf.io/build_lists/2509454
**************************** Advisory ****************************
dracut was updated to version 041 with additional patches. 
This version brings a number of enhancements and fixes all-around (USB, network, SDHCI, RAID and more). 
Additionally, it is now possible to set the amount of memory to store the changes in the file system in Live mode. DeviceMapper's thin snapshots with support for fstrim in Live mode (experimental feature) are also available. 
Besides that, we  moved the default configuration for dracut to /usr/lib/dracut/dracut.conf.d/ from /etc/dracut.conf.d/ to make it easier to override it and made dracut less verbose by default.
*******************************************************************
QA Verified
Comment 16 Vladimir Potapov 2015-06-22 18:17:25 MSD
Sorry, incorrect containers

dracut-041-8
https://abf.io/build_lists/2512112
https://abf.io/build_lists/2512113
**************************** Advisory ****************************
dracut was updated to version 041 with additional patches. 
This version brings a number of enhancements and fixes all-around (USB, network, SDHCI, RAID and more). 
Additionally, it is now possible to set the amount of memory to store the changes in the file system in Live mode. DeviceMapper's thin snapshots with support for fstrim in Live mode (experimental feature) are also available. 
Besides that, we  moved the default configuration for dracut to /usr/lib/dracut/dracut.conf.d/ from /etc/dracut.conf.d/ to make it easier to override it and made dracut less verbose by default.
*******************************************************************
QA Verified