Bug 5749 - We need to switch from procps to procps-ng
: We need to switch from procps to procps-ng
Status: VERIFIED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Highest blocker
: 2014 KDE R6
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-10 19:44 MSD by Andrey Bondrov
Modified: 2015-06-16 11:42 MSD (History)
3 users (show)

See Also:
RPM Package: procps
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
denis.silakov: published+


Attachments
ss (2.83 KB, text/x-log)
2015-06-11 20:41 MSD, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Bondrov 2015-06-10 19:44:34 MSD
We need to switch from procps to procps-ng. Some packages require new version of libprocps.
Comment 2 Vladimir Potapov 2015-06-11 17:03:17 MSD
urpmi dkms-open-vm-tools 
    http://abf-downloads.rosalinux.ru/rosa2014.1/container/2509009/i586/main/release/dkms-open-vm-tools-9.4.6-3-rosa2014.1.i586.rpm
                                                                                                                                           

устанавливается dkms-open-vm-tools-9.4.6-3-rosa2014.1.i586.rpm из /var/cache/urpmi/rpms
Подготовка...                    #########################################################################################################
      1/1: dkms-open-vm-tools    #########################################################################################################

Creating symlink /var/lib/dkms/open-vm-tools/9.4.6-3/source ->
                 /usr/src/open-vm-tools-9.4.6-3

DKMS: add Completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.14.39-nrj-desktop-pae-4rosa-i586 VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vmblock; make VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vmci; make VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vmhgfs; make VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vmsync; make VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vmxnet; make VM_UNAME=$kernelver MODULEBUILDDIR=/var/lib/dkms/open-vm-tools/9.4.6/build -C vsock......(bad exit status: 2)

Error! Bad return status for module build on kernel: 3.14.39-nrj-desktop-pae-4rosa-i586 (i586)
Consult the make.log in the build directory
/var/lib/dkms/open-vm-tools/9.4.6-3/build/ for more information.

Error! Could not locate vmblock.ko for module open-vm-tools in the DKMS tree.
You must run a dkms build for kernel 3.14.39-nrj-desktop-pae-4rosa-i586 (i586) first.
Comment 3 Andrey Bondrov 2015-06-11 17:06:06 MSD
Eugene, can you please take a look at this DKMS module?
Comment 4 Eugene Shatokhin 2015-06-11 18:56:22 MSD
Please post that make.log from /var/lib/dkms/open-vm-tools/9.4.6-3/build/ mentioned above.
Comment 5 Andrey Bondrov 2015-06-11 19:27:49 MSD
BTW, please note that we didn't have dkms-open-vm-tools in old package. It's not a regression, just a new package that doesn't work properly (and must be fixed). It shouldn't block procps-ng update.
Comment 6 Vladimir Potapov 2015-06-11 20:41:49 MSD
Created attachment 4097 [details]
ss
Comment 7 Eugene Shatokhin 2015-06-11 21:13:10 MSD
(In reply to comment #6)
> Created attachment 4097 [details]
> ss

Well, that code might have worked for the older kernels (more than 2 years ago) but the kernel API has changed a lot since then (esp. file system API, which is the main problem for dkms-open-vm-tools). 

The problem with current_uid() can be fixed. Rewriting the code to use vfs_iterate() instead of vfs_readdir() is a much bigger issue.

Taking into account that this code has been broken for a long time (more than a year), I'd suggest to drop it rather than to try to fix it.
Comment 8 Andrey Bondrov 2015-06-12 08:07:41 MSD
Let's drop DKMS module then.

open-vm-tools:

Advisory: "Switch from procps to procps-ng"
https://abf.rosalinux.ru/build_lists/2509379
https://abf.rosalinux.ru/build_lists/2509380
Comment 9 Vladimir Potapov 2015-06-12 11:37:05 MSD
The update is sent to expanded testing
****************************************
Comment 10 Vladimir Potapov 2015-06-16 10:08:46 MSD
procps-ng-3.3.10-1
https://abf.rosalinux.ru/build_lists/2508999
https://abf.rosalinux.ru/build_lists/2509000

open-vm-tools-9.4.6-4
https://abf.rosalinux.ru/build_lists/2509379
https://abf.rosalinux.ru/build_lists/2509380

*************************** Advisory ******************************
Switch from procps to procps-ng
*******************************************************************
QA Verified