Bug 5734 - qupzilla is packaged with Qt5 and crash non stop
: qupzilla is packaged with Qt5 and crash non stop
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-05 15:59 MSD by Shalok Shalom
Modified: 2016-04-13 15:41 MSD (History)
2 users (show)

See Also:
RPM Package: qupzilla
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shalok Shalom 2015-06-05 15:59:51 MSD
I wish to set up a lean ROSA with KDE and remove mariadb-server for this porpose. :) It runs already really nice, the only thing, which is heavy: Firefox and Chrome. These GTK Browsers consume a lot more RAM as Qupzilla does.

Since the KDE SC 4 use Qt4 by default, is this toolkit already loaded, why do i have to load Qt5 libs as well ? And Qupzilla crash a lot here, Facebook and other sides are mostly unuseable, at least if i want to surf longer as some minutes.

Please fix that and rewritte the rpm, thanks. :) 

(A seperate, new Qt4 Qupzilla, next to the current one is also fine :) )
Comment 1 Denis Silakov 2015-06-05 16:05:24 MSD
Qupzilla was supposed to be used with LXQt desktop which uses Qt5 framework.

Not sure that it will become more stable if rebuilt with qt4...
Comment 2 Shalok Shalom 2015-06-05 19:04:39 MSD
I dont think, its Qt5, that makes it such unuseable for me, i use it in KaOS as my default Browser and works perfect there. (Now, in qt5 with plasma 5, as well as in KDE SC 4 and qt4)

Thanks for your quick and informative response :)
Comment 3 symbianflo 2015-07-27 20:42:16 MSD
(In reply to comment #2)
> I dont think, its Qt5, that makes it such unuseable for me, i use it in KaOS
> as my default Browser and works perfect there. (Now, in qt5 with plasma 5,
> as well as in KDE SC 4 and qt4)
> 
> Thanks for your quick and informative response :)

You could try otter-browser pure qt5
Comment 4 Shalok Shalom 2015-08-02 00:13:42 MSD
Yes, i already use it since 3 Weeks, very stable
Comment 5 symbianflo 2015-08-02 02:33:55 MSD
(In reply to comment #4)
> Yes, i already use it since 3 Weeks, very stable

With qtwebengine enabled is experimental and the dev81 it is , but ain't that bad , i had a few segfaults , it is still in early stage but is growing strong.
Comment 6 Denis Silakov 2016-03-17 00:34:16 MSK
Do you still have problems with modern qupzilla? It is at version 1.8.9 now.
Comment 7 Shalok Shalom 2016-03-22 23:05:47 MSK
I use now Qupzilla 1.99 with Qt 5.6 and the QtWebEngine, which runs perfect. (in KaOS) I will test your Qupzilla 1.8.9 soon on the device of a friend. :)
Comment 8 Denis Silakov 2016-03-31 23:00:10 MSD
We'll package 2.0.0 as soon as qt 5.6 is available, this is work-in-progress now.
Comment 9 Denis Silakov 2016-04-13 15:41:11 MSD
qupzilla 2.0.0 has been finally published and works ok.