Bug 5724 - Initial boot of the system hangs for 20 seconds with systemd-208-53
: Initial boot of the system hangs for 20 seconds with systemd-208-53
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: 2014 KDE R6
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-04 15:01 MSD by Andrey Ponomarenko
Modified: 2015-07-02 20:12 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Ponomarenko 2015-06-04 15:01:59 MSD
Description of problem:

The system hangs at first start for about 20 seconds with systemd-208-53 after the desktop is fully loaded. It doesn't hang after first and all following reboots.

HW probe: http://hw.rosalinux.ru/index.php?probe=3f627f9826

All is OK with systemd-208-38.

Version-Release number of selected component (if applicable): R5 KDE


How reproducible: always


Steps to Reproduce:
1. Install system
2. Boot system
3.
Comment 1 Andrey Ponomarenko 2015-06-04 15:03:06 MSD
*** Bug 5565 has been marked as a duplicate of this bug. ***
Comment 2 Andrey Ponomarenko 2015-06-04 15:04:34 MSD
Reproduced with the latest image: https://abf.rosalinux.ru/platforms/rosa2014.1/products/111/product_build_lists/11474
Comment 3 Andrey Ponomarenko 2015-06-04 15:31:19 MSD
Two first reboots also hangs.
Comment 4 Vladimir Potapov 2015-06-19 20:22:55 MSD
I reproduce the issue on my main computer.
I fix it by delete file /etc/xdg/autostart/pulseaudio.desktop
May be present double PA initialization?
Comment 5 Andrey Bondrov 2015-06-22 13:28:32 MSD
Advisory: "Workaround PulseAudio bug #58758 (Initial boot of the system hangs for 20 seconds if pulseaudio-module-x11 is installed)"

https://abf.rosalinux.ru/build_lists/2512783
https://abf.rosalinux.ru/build_lists/2512784
Comment 6 Vladimir Potapov 2015-06-23 21:26:22 MSD
It's upstream KDE bug
https://bugs.kde.org/show_bug.cgi?id=317926
Comment 7 Vladimir Potapov 2015-06-25 13:17:31 MSD
I delete the query from QA - it's upstream bug.
Comment 8 Vladimir Potapov 2015-07-02 14:56:42 MSD
I found correct workaround. Please, also add symbolic link for start-pulseaudio-x11 to /etc/skel/.kde4/autostart.
Comment 9 Andrey Bondrov 2015-07-02 18:59:50 MSD
Let's see if kmix update fixes it: http://bugs.rosalinux.ru/show_bug.cgi?id=5867
Comment 10 Konstantin Vlasov 2015-07-02 19:40:26 MSD
(In reply to comment #9)
> Let's see if kmix update fixes it:
> http://bugs.rosalinux.ru/show_bug.cgi?id=5867

Is symlink still required?
Comment 11 Vladimir Potapov 2015-07-02 20:12:50 MSD
No, new version kmix without block (for me)